GrantKaneBattlefield: Bad Company 2 [BLES00773]
Started by GrantKane




8 posts in this topic
GrantKane
RPCS3 Tester


0
2,667 posts 1,776 threads Joined: Aug 2017
06-06-2017, 02:03 AM -
#1
RPCS3 v0.0.2-6-8e64e9d Alpha
White screen only.
GrantKane
RPCS3 Tester


0
2,667 posts 1,776 threads Joined: Aug 2017
11-11-2017, 02:48 PM -
#2
RPCS3 v0.0.3-3-8c0bdd7 Alpha | HEAD
Black screen only.


Attached Files
.7z   RPCS3.7z (Size: 89.47 KB / Downloads: 15)
Deminating
RPCS3 Tester


1
388 posts 105 threads Joined: Mar 2018
06-21-2018, 02:11 PM -
#3
RPCS3 v0.0.5-7727-c5026f71 Alpha | HEAD

Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.93 GiB RAM | AVX+ | TSX


Ingame. Some issues with the first area being way too dark, and a few audio stutters and fps drops during firefights/explosions.
Still, seems quite close to playable.
This post was last modified: 01-14-2019, 03:21 PM by Deminating. Edit Reason: New compat report


Attached Files Thumbnail(s)
           

.gz   RPCS3.log.gz (Size: 1.39 MB / Downloads: 2)
Deminating
RPCS3 Tester


1
388 posts 105 threads Joined: Mar 2018
01-18-2019, 08:56 AM -
#4
c5026f71 
Ping ping compat bot
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
01-11-2020, 08:48 PM -
#5
(06-21-2018, 02:11 PM)Deminating Wrote: RPCS3 v0.0.5-7727-c5026f71 Alpha | HEAD

Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.93 GiB RAM | AVX+ | TSX


Ingame. Some issues with the first area being way too dark, and a few audio stutters and fps drops during firefights/explosions.
Still, seems quite close to playable.

The same in my report as him. but a lot of time it freezes in loading screens. and sometime showing error message on start. can't provide Log file cause i removed it after finishing the game.
klepp0906
Member


0
11 posts 3 threads Joined: Sep 2018
07-13-2020, 08:49 PM -
#6
just tried 00779 and 00773. Both result in a black screen.
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
11-16-2020, 07:06 PM -
#7
Tried it now on 0.0.13-11249-b1710bb7
Specs: 
i7 9700k 16 GB ram
RTX 2070 super 

Settings:
I enabled Write color buffers. all the rest as default

Playing on 28-30 fps on default resolution & 4k
some audio shuttering here and there not something serious.
a bit of the grass texture was missing also not serious.
I didn't complete the game yet but planning to.

So i think it can be set as playable.


log:
https://drive.google.com/file/d/1QkkACRp...sp=sharing
This post was last modified: 11-17-2020, 09:17 PM by ori0032.


Attached Files Thumbnail(s)
           
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
11-17-2020, 09:50 PM -
#8
(11-16-2020, 07:06 PM)ori0032 Wrote: Tried it now on 0.0.13-11249-b1710bb7
Specs: 
i7 9700k 16 GB ram
RTX 2070 super 

Settings:
I enabled Write color buffers. all the rest as default

Playing on 28-30 fps on default resolution & 4k
some audio shuttering here and there not something serious.
a bit of the grass texture was missing also not serious.
I didn't complete the game yet but planning to.

So i think it can be set as playable.


log:
https://drive.google.com/file/d/1QkkACRp...sp=sharing

Update:
About the audio shuttering. it's because of the Xaudio2. so i set it to OpenAL and it fixed it.
About the missing grass texture it's probably related to the game version I play on the emulator which is Eu version, compared to what I have on a physical disc which is probably an US version.
I'm in the middle of the game right now and it didn't crashed even once. 
And it's 28-30 fps till now.


Gameplay Video:
https://youtu.be/no4IrLePwks?t=22
This post was last modified: 11-17-2020, 10:22 PM by ori0032.
ori0032
Member


0
38 posts 4 threads Joined: Nov 2017
11-20-2020, 10:12 AM -
#9
(11-17-2020, 09:50 PM)ori0032 Wrote:
(11-16-2020, 07:06 PM)ori0032 Wrote: Tried it now on 0.0.13-11249-b1710bb7
Specs: 
i7 9700k 16 GB ram
RTX 2070 super 

Settings:
I enabled Write color buffers. all the rest as default

Playing on 28-30 fps on default resolution & 4k
some audio shuttering here and there not something serious.
a bit of the grass texture was missing also not serious.
I didn't complete the game yet but planning to.

So i think it can be set as playable.


log:
https://drive.google.com/file/d/1QkkACRp...sp=sharing

Update:
About the audio shuttering. it's because of the Xaudio2. so i set it to OpenAL and it fixed it.
About the missing grass texture it's probably related to the game version I play on the emulator which is Eu version, compared to what I have on a physical disc which is probably an US version.
I'm in the middle of the game right now and it didn't crashed even once. 
And it's 28-30 fps till now.


Gameplay Video:
https://youtu.be/no4IrLePwks?t=22

Last Update:
Just finished the game on 4k. it's playable from start to the end. 
Need patch for the pixels when playing on higher resolutions.
With openAL it's much better, but the voice still need a bit of fixing.
I encountered with two times that the game froze and by clearing the cache you can fix it.

So i think it can be considered as playable
This post was last modified: 11-20-2020, 10:14 AM by ori0032.


Forum Jump:


Users browsing this thread: 1 Guest(s)