OpenGL renderer. ARB_texture_buffer_object is required but not supported by your GPU
Started by khoast40




5 posts in this topic
khoast40
Unregistered


 
05-30-2017, 08:13 AM -
#1
Hey! Long time no see because I was enjoying RPCS3, but in the lately builds (since RPCS3 updated to v0.0.2 to be exact), I ran into a problem, I think this happened because my PC not strong enough to run the emulator, but what I wonder is why v0.0.1 builds work perfectly fine, but v0.0.2 it has this error . Is v0.0.2 has any big changes?

My PC meet the minimum requirements for RPCS3 (the red text is my computer's performance) (although it's weak but it can run project diva f on v0.0.1 build at 15-25fps)

If anyone can explain (or can solve) this error for me, I'd be glad to hear it!

(the "this error" and "meet" texts has links with them for the examples, click them to see) and BTW, I use OGL for rendering because it's the fastest renderer for my computer
Ani
Administrator
*******


16
4,015 posts 104 threads Joined: Aug 2017
05-30-2017, 11:22 AM -
#2
Are you using latest build? Intel drivers are bad and don't report extensions properly so it thinks your GPU doesn't support them.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux
khoast40
Unregistered


 
05-30-2017, 11:32 AM -
#3
(05-30-2017, 11:22 AM)Annie Wrote: Are you using latest build? Intel drivers are bad and don't report extensions properly so it thinks your GPU doesn't support them.
I use the lasted build, let me check if the driver has any update...
ps0ne
Member


0
304 posts 59 threads Joined: Oct 2017
05-30-2017, 08:51 PM -
#4
This is the list of gpus that NOT support relevant extension www.opengl.gpuinfo.org/gl_listreports.php?listreportsbyextensionunsupported=GL_ARB_texture_buffer_object

somehow i see intel 4600 among them
ssshadow
Administrator
*******


4
2,494 posts 63 threads Joined: Aug 2017
05-31-2017, 12:02 AM -
#5
That list must be messed up, it lists GTX 1080 too.

Maybe DX12 works better on this Intel GPU.
ps0ne
Member


0
304 posts 59 threads Joined: Oct 2017
05-31-2017, 07:13 AM -
#6
Interesting.. its fresh case

Here is official statement https://communities.intel.com/thread/111482 :The Intel driver supports this extension however, due to a situation we are currently working on, support for this extension is not announced.

Now its up to devs what they do with it. Probably omit some checks?

Ah and yes, ssshadow ur right, dx12 is best for intel, if available.


Forum Jump:


Users browsing this thread: 1 Guest(s)