Tales of Graces F [BLUS30903]
Started by jazjaz36




127 posts in this topic
xanas
Member


0
2 posts 0 threads Joined: Oct 2019
10-16-2019, 03:38 AM -
I played around with the settings for a bit on my machine and think I got the right performance for regular gameplay (skits + map + battles) without adjusting vblank or using the framelimiter by just adjusting the PPU Decoder to "Interpreter (precise)"  Settings for the SPU Decoder didn't really seem to make any difference to the framerate changes or desynchronized audio/etc.
The problem with using PPU Decoder Interpreter was that it made the FMVs extremely choppy, otherwise everything else was perfect.

Adjusting vblank had downsides in that it resulted in desynchronized audio over time for me, as well as resulting in choppy travel on the open world map (30 was the worst, 40 was not that bad).  Limiting FPS to 30 worked fine for everything except that it seemed to slow the battles down about 30-50% or so. 

Vulkan seems to be much more unstable than OpenGL in this game. It would crash/segfault regularly no matter what else I changed. 

This was using 0.0.7-8900 Alpha using Intel® Core™ i7-4790K CPU @ 4.00GHz / GTX 1080 on Manjaro with kernel 5.3.5-1 and recent Nvidia drivers. 
Klarth
Member


0
1 posts 0 threads Joined: Oct 2019
10-28-2019, 07:35 PM -
For anyone that is trying to play this on a low-end PC like me, here are some essential things that made it possible for me to run this in a somewhat tolerable state;

  • First of all, as mentioned in the thread before, I set the Vblank rate to 40 and the frame limit to 60 in order to get properly synced skits. I am using OpenGL as Vulkan is really buggy for me with this game. (Lots of graphical glitches, makes it unplayable)
  • I used LLVM Recompilers for both the SPU and the PPU.
  • I set the SPU threads value to 1, it greatly helps with the performance.
  • For the audio, I checked Downmix to Stereo and Convert to 16 bit.
  • I set the Sleep Timers Accuracy to All Timers, this might be placebo but I felt like I got 2-3 more FPS with this setting on.
If these worked for you, that's great, ignore the next steps I have taken. But for me, even with these settings on, I still got sluggish combat due to low FPS in some areas of the game which I got around by going to the custom config file of the game and changing these;
  • Disable ZCull Occlusion Queries: true (I am not sure if this made any difference, change it back to false if it causes problems)
  • Enable Frame Skip: true (For me, enabling Frame Skip made a great deal of difference, the game looks more "jumpy" but at least the combat stopped being sluggish and runs in the speed it was meant to run. I experimented with Consecutive Frames To Draw and Skip values a bit, if both set to 1 feels too jumpy for you, you can change the Frames to Draw value to 2.
  • Enabling Frame Skip introduced some audio sluttering for me. I fixed it by enabling the debugger and using the thread pausing method. This video explains how to do that starting at 3:08.
I tested these on i7-4510U and Radeon HD 8500M. On average I get 25-30 FPS in combat, 20-30 FPS in the overworld.
HigurashiCentral
Member


0
1 posts 0 threads Joined: Nov 2019
11-14-2019, 04:55 AM -
My personal settings. If nothing in this topic has worked for you, try this.

Preferred SPU Threads: 1
Renderer: Vulkan
Framelimit: 60
Strict Rendering Mode On
VSync On
Multithreaded RSX On
VBlank Frequency: 30
Clocks Scale: 50%

These settings get me a very smooth 30 FPS in the field and cutscenes. 60 FPS for synced skits and combat. The only sacrifice is the full anime FMVs chug and become unwatchable, but skippable. I consider this is very small sacrifice, considering how few of them there are. The real setting that breaks these FMVs is the Clocks Scale. So if you really have to see them, return that setting to default whenever there is one you need to see.
bachou
Member


0
5 posts 0 threads Joined: Sep 2019
01-08-2020, 04:30 AM -
hi does anyone got this problem ?

the environment looks like night scene but it's actually daytime, sometime the glitch goes of by advance the story

this happens after a nice scene event and the environment lighting stays for the rest of it.

the earliest time you encounter this bug is when you came back to asbel town from the capital for the first time, there was a cottage next to the save point, if you enter the cottage then leave the bug happens, even tho it was normal before entering the cottage.

i have tried everything like strict render mode, clear all shaders cache etc but when i load the save game it's still the same, even opengl still won't fix this

here is the screenshot to show what it looks like

https://postimg.cc/75LJ7FbM

https://postimg.cc/GB8BgvF4
waterfly
Member


0
1 posts 0 threads Joined: Jan 2020
01-24-2020, 04:50 AM -
(11-14-2019, 04:55 AM)HigurashiCentral Wrote: My personal settings. If nothing in this topic has worked for you, try this.

Preferred SPU Threads: 1
Renderer: Vulkan
Framelimit: 60
Strict Rendering Mode On
VSync On
Multithreaded RSX On
VBlank Frequency: 30
Clocks Scale: 50%

These settings get me a very smooth 30 FPS in the field and cutscenes. 60 FPS for synced skits and combat. The only sacrifice is the full anime FMVs chug and become unwatchable, but skippable. I consider this is very small sacrifice, considering how few of them there are. The real setting that breaks these FMVs is the Clocks Scale. So if you really have to see them, return that setting to default whenever there is one you need to see.
THX,These settings are very good. The full anime FMVs can be fix by setting:

Clocks scale:100% 
Strict Rendering Mode:off
Resolution Scale:300%(If you vedio card is good enough)
Resolution Scale threshold: 1/1(key setting)
xanas
Member


0
2 posts 0 threads Joined: Oct 2019
03-18-2020, 06:10 AM -
Confirmed your combination of settings waterfly is still working great in the latest version as well, this seems like the perfect settings set, FMV, Combat, World map all seems to work perfectly with no obvious slowdowns or speedups.
This post was last modified: 03-18-2020, 06:12 AM by xanas.
Gandorfin
Member


0
4 posts 0 threads Joined: Sep 2017
04-23-2020, 01:12 PM -
the game doesn't boot anymore on latest version (rpcs3-v0.0.9-10258-256c74de_win64)
it throws up
F {PPU[0x1000000] Thread (main_thread) [0x00478700]} SIG: Thread terminated due to fatal error: Trap! (0x478700)
anyone else getting this issue on latest build?

edit: fixed it by changing default resolution to 720p (it was 1080p) which is weird since I have 300% scaling anyway
This post was last modified: 04-23-2020, 07:18 PM by Gandorfin. Edit Reason: update
Olemannen
Member


0
1 posts 0 threads Joined: Apr 2020
04-29-2020, 06:53 PM -
Hello, does anyone got a cheat for grade? Can't seem to get cheatengine or RCPS3 cheats to work.


Forum Jump:


Users browsing this thread: 1 Guest(s)