Hello There, Guest! Register

Super Stardust HD [NPUA80068]
#1
Build: 5f38098

Hardware:
i7 5820K @ 4.4ghz
R9 Fury Tri X
16GB 2400mhz DDR4
Win10 Pro

Settings:

PPU: Interpreter(fast)
SPU: Interpreter(precise) ~ Required for enemies and asteroids to spawn
Renderer: Vulkan
Resolution: 1280x720
Audio: Xaudio2

LLE: Automatically load required libraries.

Screenshots:
[Image: eNDfz9A.jpg]
[Image: XYruyGu.jpg]
Reply
#2
It starts perfect, but after some minutes (sometimes seconds) the glitches appear, most of the time ending with a video freeze and audio still going.

In this video I recorded with v0.0.3-3-5a03db7, glitches appear from 2:45 on with slowdowns and corrupted graphics (false green asteroids and over bright hud elements). The attached log is not from the video gameplay but it also had similar duration and glitches.



Attached Files
.gz   RPCS3.log.gz (Size: 110 KB / Downloads: 7)
Reply
#3
RPCS3 v0.0.5-6638-568118634 Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.94 GiB RAM | AVX+ | TSX

Same issue with different renderers or settings.

There are different versions of Super Stardust HD.
Ver 1.00 (fw1.70) has no DLC and is fully playable, at least the first world. I die before getting to world 2.

Newer versions crash to black screen after selecting the game mode or when the game play demo starts.
Version #s and firmware revs pulled from PARAM.SFO file.

I have tested:
v3.00 (fw2.20)
v4.00 (fw2.20)
v5.00 (fw3.30)
v7.00 (fw3.70)

They crash whether the DLC is authorized or not.

The forum will not let me attach the 1.11MB .gz log.  It keeps crashing.

E {PPU[0x1000000] Thread (main_thread) [0x00034b8c]} 'sys_memory_allocate_from_container' failed with 0x80010002 : CELL_EINVAL [1]
F {PPU[0x1000000] Thread (main_thread) [0x004d30d4]} MEM: Access violation writing location 0x40

******** Assert failed: ********
Where: f:/Work/Projects/SD3D/Game/Code/Game/System_Memory_Manager.cpp(158):
What : m_raw_pool != 0.
Msg  : Allocation from container failed!

Awesome work on the emulator so far.
Reply
#4
(04-06-2018, 11:57 PM)Ape8000 Wrote: There are different versions of Super Stardust HD.
Ver 1.00 (fw1.70) has no DLC and is fully playable, at least the first world. I die before getting to world 2.

Version 1.00 is Playable from start to finish with no graphical issues, after you finish the game it loops on a harder difficulty and this works without issues. All other versions crash with a PPU error just after selecting a level, like Ape8000 mentioned.

This has been true for a while now, but i'm currently using latest master 0.0.5-6694.

RPCS3 v0.0.5-6694-25ec899cf Alpha | HEAD

Intel® Core™ i7-6700 CPU @ 3.40GHz | 8 Threads | 15.87 GiB RAM | AVX+ | TSX
&

Intel® Core™ i7-7700K CPU @ 5.00GHz | 8 Threads | 15.87 GiB RAM | AVX+ | TSX
Reply
#5
(05-01-2018, 09:13 AM)chane2k1 Wrote:
(04-06-2018, 11:57 PM)Ape8000 Wrote: There are different versions of Super Stardust HD.
Ver 1.00 (fw1.70) has no DLC and is fully playable, at least the first world. I die before getting to world 2.

Version 1.00 is Playable from start to finish with no graphical issues, after you finish the game it loops on a harder difficulty and this works without issues. All other versions crash with a PPU error just after selecting a level, like Ape8000 mentioned.

This has been true for a while now, but i'm currently using latest master 0.0.5-6694.

RPCS3 v0.0.5-6694-25ec899cf Alpha | HEAD

Intel® Core™ i7-6700 CPU @ 3.40GHz | 8 Threads | 15.87 GiB RAM | AVX+ | TSX
&

Intel® Core™ i7-7700K CPU @ 5.00GHz | 8 Threads | 15.87 GiB RAM | AVX+ | TSX
As of 0.0.5-6905 my version 6.00 of the game with all DLC works just beautifully I have fully played through 3 worlds on different game modes and only have two problems, one is that the Rock Crusher sprite doesn't show, or the effect doesn't render, and some slowdowns when there are a ton of things on the screen, though my pc isn't the most powerful..

I7-2600 @ 4.23Ghz 16Gb DDR3 GTX 970 with modded bios and resistor mods, hit's about 1550 reliably and stays there most of the time Big Grin

EDIT: So after some testing I have found that both versions 5.00 and 6.00 have the missing gfx problem, but version 4.00 does not, and i am now 3 worlds into the game, also I have experienced none of the slowdowns that were present in the 5.00 and 6.00 versions
Reply
#6
tested with rpcs3-v0.0.5-7195-23b52e1b_win64.7z

Works like a charm with both LLVM recompilers selected and "Accurate Xfloat" checked.  In the other hand set PPU to ASMJIT if you want to run without "Accurate Xfloat"

latter test with rpcs3-v0.0.5-7253-7b4f7039_win64.7z


Attached Files Thumbnail(s)
           

.gz   RPCS3.log.gz (Size: 149.23 KB / Downloads: 2)
Reply
#7
We need a proper playable report or else this cannot be moved to playable https://forums.rpcs3.net/thread-196671.html
Reply
#8
(08-17-2018, 01:57 AM)profzerg Wrote: tested with rpcs3-v0.0.5-7195-23b52e1b_win64.7z

Works like a charm with both LLVM recompilers selected and "Accurate Xfloat" checked.  In the other hand set PPU to ASMJIT if you want to run without "Accurate Xfloat"

latter test with rpcs3-v0.0.5-7253-7b4f7039_win64.7z

What version of the game do you have? I am currently using version 5.01 but from what I've seen myself and others have reported is that in version 5 and 6 have a graphical bug where the rock crusher weapon does not render correctly. Version 4 of the game apprently does not have this issue but I dont have this verison to test. I know version 1 of the demo worked fine as well.
Reply
#9
Euro version playable.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)