Gran Turismo® 6 [BCES01893]
Started by eoiz




62 posts in this topic
Attelee
Member


0
10 posts 0 threads Joined: Apr 2019
07-03-2020, 05:54 AM -
#51
BioSchock96 i tested with your config. Crash for me. I think non TSX cpu's never playable this game.
Here is the video of the situation. https://youtu.be/XeFNg2Rc21Q
This post was last modified: 07-03-2020, 05:56 AM by Attelee.
PY3AN
Member


0
2 posts 0 threads Joined: Apr 2020
07-08-2020, 04:02 PM -
#52
Hey all.

Gran Turismo®6 [BCES01893] Ver. 1.05
 
Tested on these PC Specs:

AMD Ryzen 5 3600
16GB DDR4 3200, overclocked to 3466
Radeon RX 580
 
RPCS3 Build: 10627
 
CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
Additional Settings: Enable Thread Scheduler/ON,
Enable SPU Loop Detection:/ON,
SPU Cache/ON,
Else/OFF
SPU Block Size: Mega
 
GPU
Renderer: Vulkan
AF: auto
Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Additional Settings: VSync/ON,
Multithreaded RSX/ON,
Else/OFF

Debug
GPU: Disable ZCull Occlusion Queries/ON,
Force CPU Bit Emulation/ON,
Disable FIFO Reordering/ON,
Use GPU Texture Scaling: On
Else/OFF

FPS:  30 – 60

On these settings, the game shows good performance, playable, but you must wait until the SPUs are compiled, at this time it may freeze, or the performance will be lower and there will be sound freezes. Using these Debug settings, some lighting effects are disabled, but the constant blinking of the screen is removed (emulation of dynamic brightness changes is not work, it is possible to drop to 10 FPS) and performance increases.
Disable Vulkan Memory does not bring any changes except the fall of FPS. Virtual mirror does not work. Sometimes desynchronization occurs and the emulator freezes during the race, happens randomly, with a frequency of 5-10 times per hour to 2-3 in 6-7 hours, there is a dependence on FPS. When loading a lunar expedition (mission 1), the emulator freezes with an error in the log:

F {RSX [0x0bbf650]} SIG: Thread terminated due to fatal error: rsx::get_address(offset=0x402c9b10, location=0x1): RSXIO memory not mapped!
(in file d:\a\1\s\rpcs3\Emu\RSX\RSXThread.cpp:874)


During boot race, the emulator may crash without being reflected in the log. Also, when loading a race, the emulator may freeze with an error

F {SPU[0x0000100] Thread (PDICellSpursKernel0) [0x11c10]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x31b0 (Out_MBox=empty)
(in file d:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3312)

Moreover, the frequency increases with the number of opponents on the track and if you raise the Resolution Scale to 150% (1920x1080).
When updating the game to a version greater than 1.05, all shaders disappear (black screen), as I understand it.
There are also minor graphical issues

Logs and screenshots:

https://drive.google.com/file/d/1tybP9yf...sp=sharing
This post was last modified: 08-02-2020, 04:03 PM by PY3AN.
mhh2
Member


0
4 posts 0 threads Joined: Mar 2020
07-09-2020, 12:47 AM -
#53
(07-08-2020, 04:02 PM)PY3AN Wrote: Hey all.

Gran Turismo®6 [BCES01893] Ver. 1.05
 
Tested on these PC Specs:

AMD Ryzen 5 3600
16GB DDR4 3200, overclocked to 3466
Radeon RX 580
 
RPCS3 Build: 10627
 
CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
Additional Settings: Enable Thread Scheduler/ON,
Enable SPU Loop Detection:/ON,
SPU Cache/ON,
Else/OFF
SPU Block Size: Mega
 
GPU
Renderer: Vulkan
AF: auto
Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Additional Settings: VSync/ON,
Multithreaded RSX/ON,
Else/OFF

Debug
GPU: Disable ZCull Occlusion Queries/ON,
Force CPU Bit Emulation/ON,
Disable FIFO Reordering/ON,
Use GPU Texture Scaling: On
Else/OFF

FPS:  30 – 60

On these settings, the game shows good performance, playable, but you must wait until the SPUs are compiled, at this time it may freeze, or the performance will be lower and there will be sound freezes. Using these Debug settings, some lighting effects are disabled, but the constant blinking of the screen is removed (emulation of dynamic brightness changes is not implemented, it is possible to drop to 10 FPS) and performance increases.
Disable Vulkan Memory does not bring any changes except the fall of FPS. Virtual mirror does not work. Sometimes desynchronization occurs and the emulator freezes during the race, happens randomly, with a frequency of 5-10 times per hour to 2-3 in 6-7 hours, there is a dependence on FPS. When loading a lunar expedition (mission 1), the emulator freezes with an error in the log:

F {RSX [0x0bbf650]} SIG: Thread terminated due to fatal error: rsx::get_address(offset=0x402c9b10, location=0x1): RSXIO memory not mapped!
(in file d:\a\1\s\rpcs3\Emu\RSX\RSXThread.cpp:874)


During boot race, the emulator may crash without being reflected in the log. Also, when loading a race, the emulator may freeze with an error

F {SPU[0x0000100] Thread (PDICellSpursKernel0) [0x11c10]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x31b0 (Out_MBox=empty)
(in file d:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3312)

Moreover, the frequency increases with the number of opponents on the track and if you raise the Resolution Scale to 150% (1920x1080).
When updating the game to a version greater than 1.05, all shaders disappear (black screen), as I understand it.
There are also minor graphical issues

Logs and screenshots:

https://drive.google.com/file/d/1tybP9yf...sp=sharing

If you leave SPU Block Size at safe, you get way better framerates and you don't have to wait for it to compile. I can do everything in game, buy cars, tune them and race but after an hour or so the game crashes randomly, doesn't matter what i'm doing ingame. i get 35-40fps.

our systems are almost identical:
Gran Turismo®6 [BCES01893] Ver. 1.02
AMD Ryzen 5 2600 @4.1ghz 
32GB DDR4 3266
Radeon RX 590
RPCS3 Build: i allways update to latest version

you have the better cpu so you should get better framerates than i do.
I feel like if the RPCS3 team would invest 1 week to optimize this game like they did with metal gear solid 4 it would run without crashing, and with enough cpu power it would run smooth enough.
Sandi1987
Member


0
127 posts 15 threads Joined: Sep 2017
08-31-2020, 05:33 AM -
#54
Game crash when i buy car.

[Image: 4enolrI.png]
This post was last modified: 08-31-2020, 05:45 AM by Sandi1987.
yeahimdukenukem
Member


0
1 posts 0 threads Joined: Sep 2020
09-16-2020, 10:33 PM -
#55
GT6 in version 1.22 always crashes after the intro video.
I tried several settings, but nothing gets me past that screen.
The non-patched version from my bluray runs and lets me at least drive the first race.
I have attached the log file:
.gz   RPCS3.log.gz (Size: 675.94 KB / Downloads: 1)
May I support in finding and fixing the issue? I really would love to play this on my PC instead of my PS3.
This post was last modified: 09-18-2020, 04:58 AM by yeahimdukenukem.
Paultimate
Member


0
1 posts 0 threads Joined: Sep 2020
09-26-2020, 03:50 AM -
#56
(08-31-2020, 05:33 AM)Sandi1987 Wrote: Game crash when i buy car.

Why did you even bother to post this when you gave no log nor any useful information. What do you expect a dev to do with this?
nfsmurilo
Member


0
5 posts 0 threads Joined: Oct 2020
10-03-2020, 07:00 PM -
#57
Hey all.

Gran Turismo®6 [BCES01893] Ver. 1.05

Tested on these PC Specs:

Acer Nitro 5 AN-515-52
Intel Core i5 8300h
16GB DDR4 2666
GTX 1050

RPCS3 Build: 0.0.12-10973

CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
Additional Settings: Enable Thread Scheduler/OFF,
Enable SPU Loop Detection:/OFF,
SPU Cache/ON,
Else/OFF
SPU Block Size: SAFE

GPU
Renderer: Vulkan
AF: 2X
Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Additional Settings: VSync/ON,
Else/OFF

Advanced
Core: all off
Sleep Timers: Usleep Only
Max Num SPURS: 4
Firmware Sett: Load liblv2.sprx only
Gpu: all off
Driver Wakeup: 1
Vblank: 60
Clock scale: 100

Debug
GPU:
Force CPU Bit Emulation/ON,
Else/OFF

LLVM FPS:  25 - 35 - (edit)
Interpreter FPS: 19 - 30 (but slooowly like walking on moon hehe) - (edit)

When i use interpreter (fast), the game works but slooowly, but even with this setting, in some tracks the game crash with the same error! (edit)

On these settings, the game shows good performance. When loading almost any race on national A, happens more with the kart races, the emulator freezes with an error in the log:

F {SPU[0x3000100] Thread (PDICellSpursKernel3) [0x1033c]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x0 (Out_MBox=empty)
(in file D:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3468)

During boot race, the emulator may crash without being reflected in the log. But seens like turning off the Relaxed Zcull sync solves this (it don't, i'm sorry).

PY3AN, i'm using your post as a template, sorry, but thank you! i'ts well described i think. everything i didn't change, matches with mine.
This post was last modified: 10-05-2020, 09:44 PM by nfsmurilo.
Ani
Administrator
*******


10
3,266 posts 91 threads Joined: Aug 2017
10-05-2020, 05:48 AM -
#58
Removed attachment that was not a log file, if you want to attach a log file, attach the actual RPCS3.log file
nfsmurilo
Member


0
5 posts 0 threads Joined: Oct 2020
10-05-2020, 09:47 PM -
#59
(10-05-2020, 05:48 AM)Ani Wrote: Removed attachment that was not a log file, if you want to attach a log file, attach the actual RPCS3.log file

I'm sorry, i've noticed it later what log was the right, i'm trying to get the log, but the emulator crash and delete the log file when the window closes.
nfsmurilo
Member


0
5 posts 0 threads Joined: Oct 2020
10-07-2020, 01:05 PM -
#60
RPCS3 Build: 0.0.12-10983

CPU
PPU Decoder: LLVM
SPU Decoder: LLVM
SPU Cache/ON, Accurate xfloat/ ON, Else/OFF
SPU Block Size: SAFE
Preferred SPU Threads: 2

GPU
Renderer: Vulkan
AF: Auto, AA: Auto, Framelimit: Auto

Default Resolution: 1280x720
Resolution Scale: 100% (1280x720)
Shader Mode: Async: (Multi threaded)
Resolution Scale Threshold: 1x1
Additional Settings: VSync/ON,
Else/OFF

Advanced
Core: all off
Sleep Timers: Usleep Only
Max Num SPURS: 4
Firmware Sett: Load liblv2.sprx only
Gpu: all off
Driver Wakeup: 1
Vblank: 60
Clock scale: 100

Debug
GPU:
Force CPU Bit Emulation/ON,
Else/OFF

Core:
Accurate SPU DMA/ON
Else/OFF

Accurate 128 PPU Reservation: Aways Enabled

LLVM FPS: 10 - 19 (drops for me because of Accurate xfloat)
Interpreter i didn't test cause LLVM is already gives me troubles with FPS.

Seens to me like the accurate xfloat solves this error: F {SPU[0x3000100] Thread (PDICellSpursKernel3) [0x1033c]} SIG: Thread terminated due to fatal error: Unknown STOP code: 0x0 (Out_MBox=empty)
(in file D:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:3468). And turning on some other accurate things like spu dma, helps with the game freezing from nothing, didn't stop, but get better.

tell me if it works!


Forum Jump:


Users browsing this thread: 3 Guest(s)