Sengoku Basara 4: Sumeragi [BLJM61248]
Started by GrantKane




18 posts in this topic
GrantKane
RPCS3 Tester


0
2,667 posts 1,776 threads Joined: Aug 2017
05-19-2017, 07:03 PM -
#1
RPCS3 v0.0.2-3-d5107aa Alpha
Ingame.
escapedmc
Guest


 
08-02-2017, 05:14 PM -
#2
Since 0.0.3-5487 it stopped to run the game with Vulkan and with "Write color buffers" option. Without this option its just a white screen with sound.
Solstar82
Guest


 
08-18-2017, 11:06 AM -
#3
(08-02-2017, 05:14 PM)escapedmc Wrote: Since 0.0.3-5487 it stopped to run the game with Vulkan and with "Write color buffers" option. Without this option its just a white screen with sound.

can still confirm the bug with latest release

using opengl and write buffers the game runs, up to where you can actually control your character,but its extremely slow,and has a lot of hiccups even in the main menu screen
dsyo2008
Member


0
1 posts 0 threads Joined: Sep 2017
09-06-2017, 11:52 AM -
#4
rpcs3 0.0.3-939 kd-11
vulkan Sticky OK

[Image: 005teDSOgy1fja2zp67gej30zm0l3npd.jpg?ssi...698596950_]
[Image: 005teDSOgy1fja2zo0npzj30zm0l37wh.jpg]
[Image: 005teDSOgy1fja2znwyn0j30zm0l3b29.jpg?ssi...698611231_]
[Image: 005teDSOgy1fja2zo2srjj30zm0l34qp.jpg]
bjakja
Member


0
10 posts 0 threads Joined: Aug 2017
09-09-2017, 06:38 PM -
#5
New builds from fbo_fixes branch do not need white colors anymore (tested on 3 games). It also fixes missing dlc loading screen, logos and opening. Turn off white colors give big speedup. I get 20-60 fps. This game constantly crashes audio thread I can play only once per run game, second play have missing audio. dsyo2008, nice character, I try her on my next play.
On newest fbo_fixes build audio crashes after fourth stage.


When I try to play on two players, split screen mode bottom screen is not show properly, background is from first screen. sometimes I can see second character.
This post was last modified: 09-21-2017, 01:33 PM by bjakja. Edit Reason: Added gameplay


Attached Files Thumbnail(s)
   
Vlan
Member


0
6 posts 2 threads Joined: Nov 2017
11-12-2017, 03:39 PM -
#6
For some reason it's not working for me.

The game starts up, I can hear one short sound clip, but the screen however is black, and nothing happens afterwards.

OpenGL, Vulkan, different Interpreters, Write Color Buffers, nothing is working.

Am I missing something here?
This post was last modified: 11-12-2017, 03:41 PM by Vlan.
BurningSky
Member


0
5 posts 1 threads Joined: Nov 2017
11-12-2017, 07:50 PM -
#7
(11-12-2017, 03:39 PM)Vlan Wrote: For some reason it's not working for me.

The game starts up, I can hear one short sound clip, but the screen however is black, and nothing happens afterwards.

OpenGL, Vulkan, different Interpreters, Write Color Buffers, nothing is working.

Am I missing something here?
Same for me.

Builds later than 0.0.3-6194 aren't working, black Screen after capcom.
bjakja
Member


0
10 posts 0 threads Joined: Aug 2017
12-02-2017, 03:04 PM -
#8
Game stopped working after merge fbo_fixes to master, for me it shows first scenes only on clear "installation" of RPCS3, second time it shows only white screen, with no fps counter.
Vlan
Member


0
6 posts 2 threads Joined: Nov 2017
01-25-2018, 04:05 PM -
#9
I recently watched the news update trailer for the emulator, and saw SB4 actually working.

But when I try to start up the game, I still get a black / white screen.

Am using 0.0.4-6355-c8965564e atm.


Code:
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x00a0a338]} sys_vm: sys_vm_memory_map(vsize=0x10000000, psize=0x6900000, cid=0xffffffff, flags=0x200, policy=0x1, addr=*0xd0016350)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)[/color]
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1][/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)[/color]
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [2][/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)[/color]
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [3][/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01640d80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01617f0c]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x0114a924]} cellSysutil TODO: cellVideoOutConfigure(videoOut=0, config=*0xd0015d60, option=*0x0, waitForEvent=0)[/color]
[color=#c02f1d]E {rsx::thread} RSX: NV3089_IMAGE_IN_SIZE: Invalid blit dimensions passed[/color]
[color=#008000]S {PPU[0x1000000] Thread (main_thread) [0x016189ac]} PPU: LLVM: Loaded module v2-libnet.sprx-FFB9AC229DA8A825-haswell.obj[/color]
[color=#008000]S {PPU[0x1000000] Thread (main_thread) [0x016189ac]} sys_prx: Loaded module: /dev_flash/sys/external/libnet.sprx[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x011476d4]} cellNetCtl TODO: cellNetCtlAddHandler(handler=*0x1400628, arg=*0x20d0b5b0, hid=*0x20d0b690)[/color]
[color=#ff6000]U {PPU[0x1000000] Thread (main_thread) [0x01147664]} cellNetCtl TODO: cellNetCtlGetInfo(code=0x4 (INFO_LINK), info=*0xd0015bd0)[/color]
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x01670090]} 'sys_fs_open' failed with 0x80010002 : CELL_EINVAL [1][/color]
[color=#c02f1d]E {PPU[0x1000000] Thread (main_thread) [0x00e57878]} Stat: '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [x5][/color]
This post was last modified: 01-25-2018, 04:06 PM by Vlan.
Yukimuraden should be 2p
Member


0
2 posts 0 threads Joined: Mar 2018
03-18-2018, 08:00 PM -
#10
Has anyone had any luck recently with this game? I would play yukimuraden, but I don't care to play a single player game.


Forum Jump:


Users browsing this thread: 1 Guest(s)