Hello There, Guest! Register

Tales of Vesperia J [BLJS10053]
#1
Core
PPU: Interpreter (fast)
SPU: Interpreter (fast)

LLM: Load liblv2.sprx only

Graphics
- Vulkan
- 1280x720
- Auto (Frame limit)

Audio
- XAudio2

Skipping videos goes ingame, but just can access to the menu


Reply
#2
Logos loading OK, at 50-60 FPS. Then, intro video is loaded with a strange reddish -effect.

[Image: nn7ajr.jpg]

After that, a black screen stands for the main screen and if you press start, you'll eventually get this:

[Image: vdpqg.jpg]

Next, a kind of battle scene appears but turns into a blueish screen in a flash, and finally, for some unknown reason. all the scenes start all over again. The kind of ppu and spu used don't seem to have much of an effect, except for the reddish intro video, which, if you use the recompilers, gets almost normal colours, and I say "almost" because some frames of it are still reddish.

I'm using OpenGL. Here it is the log https://mega.nz/#!42ZQCb4T!7Gtn4DuRvipdp...vIvRrXoxPQ
Reply
#3
Don't put threads on Loadable if they're Intro.
Reply
#4
I can't reply to PMs if the recipient's inbox is disabled
Reply
#5
(05-28-2017, 07:39 PM)Annie Wrote: I can't reply to PMs if the recipient's inbox is disabled

As far as I know, mine isn't, since I received the notification, but I don't really know. Thank you for trying, though. Don't worry, let's play it safe. I'll limit myself to reply to threads whenever I can help, so everyone's happy. Have a nice day
Reply
#6
Since I can't reply, basically you created duplicated threads because they already existed. I've merged them, plus they were in incorrect areas because it shows image therefore it's Intro or above.
Reply
#7
Progress report:

LLVM
Thanks to the new LLVM, all issues related to it are solved. It no longer throws a MEM: Access violation error upon starting a new game, and display is now the same as on Interpretor.
No major performance change, though. Except maybe a small frameskipping appearing, making the game progress a little bit faster. Ingame menu also sees a nice increase in FPS.
Videos are running at full speed.

RSX
kd's recent changes didn't really affect this game. The only two changes being:
- Rivers, oceans and loot points are visible on the World Map (this was already the case in recent builds of kd's Vulkan branch).

- Using Vulkan, the skybox is black, while it was working properly before.

Reply
#8
Thanks to kd's work, a lot of graphical issues are fixed. This is very encouraging.

Graphical issues left to fix include:
- Black characters, monsters and loot chests (possibly cel-shading not working correctly)
- Depth issues with the background veil effect
- Half screen issues in some scenes in the Noble quarter, Ragou's manor, on Barbos' ship. Also affects the menu background
- Lighting issues (?) in some areas








Non-graphical issues include:
- Trap errors (see below).
- Text is not working properly.
- Very low FPS even with recompilers (4-5fps in towns, <10fps on the world map, <15fps in battle)

Trap errors (code: F {PPU[0x1000009] Thread () [0x00466334]} class std::runtime_error thrown: Trap! (0x466334) )
- When leaving Zaphias for the first time, after getting the World Map from a random citizen
- Capua Nor seems like a nest for those trap errors, as they occur anytime you enter the town, either through the entrance, the inn's door or Ragou's manor exit
- At the end of the scene after entering Caer Bocram, when you get the control of your character back (this error seems inconsistent, sometimes it only happens when you start a skit; if you don't have it at the end of the scene, you can just keep going, play skits in buildings)
- At the beginning of the scene when you're about to leave Caer Bocram
- Before the final fight, after your party arrives to meet the boss
I'm pretty sure this error has something to do with transition screens.
Reply
#9
Since PR 3083, game slows down to <1fps after a short while ingame, sometimes it even hangs and gets stuck forever. Only happens with Vulkan.
This problem also affects Tales of Graces f, and from what I read on these forums, could also affect Tales of Zestiria and Berseria.
Reply
#10
(07-31-2017, 08:40 AM)GeniusMage Wrote: Since PR 3083, game slows down to <1fps after a short while ingame, sometimes it even hangs and gets stuck forever.
This problem also affects Tales of Graces f, and from what I read on these forums, could also affect Tales of Zestiria and Berseria.

The fps's are decreasing in the last builds of rpcs3, same happen to me too . Also Berseria freeze at the beginning, so it's not playable, just go ingame Sad
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)