Tales of Vesperia [BLJS10053]
Started by Butz_san




61 posts in this topic
LifeWulf
Member


0
3 posts 0 threads Joined: Sep 2017
09-09-2017, 06:32 AM -
#11
Hi, I'm aware that each new release of RPCS3 seems to have caused regressions in Tales of Vesperia, but it's now to the point where I can't get past the main menu. I can see the intro video just fine, but then I start a new game and am immediately greeted by an illegible menu (bunch of broken lines where text should be). If I manage to fumble through the menus via the button prompts, I get to what seems like cutscenes, but all I got was a laggy bit of water before I could progress no further.

I've tried both OpenGL and Vulkan, with rpcs3 outright crashing on Vulkan. I've also tried both PPU interpreters and the recompiler, and switched from the default "load libvl2.sprx only" in the firmware settings, to "Automatically load required libraries".
This post was last modified: 09-09-2017, 02:38 PM by LifeWulf. Edit Reason: Removed unnecessary info
Gandorfin
Member


0
4 posts 0 threads Joined: Sep 2017
09-09-2017, 01:30 PM -
#12
Tested on latest build "rpcs3-v0.0.3-2017-08-15-0457f23b_win64"
Windows 10 64bit

Same story like LifeWulf's
Vulkan completely crashes whole program pretty soon after or right as main menu loads




using OpenGl it's possible to get in game but it hangs up after while and graphics are broken
,another issue this game Fonts are completely broken (same issue like in tales of Xillia)
This post was last modified: 09-23-2017, 08:04 AM by Gandorfin.
marthgun
Member


0
28 posts 0 threads Joined: Sep 2017
09-22-2017, 02:38 AM -
#13
still same problems listed above on the newest build.

intro video looks great though.
GeniusMage
Member


0
26 posts 0 threads Joined: Aug 2017
09-22-2017, 06:41 PM -
#14
As of today, the game is back to its early July status. No more crashes in Vulkan, out of the Trap errors.
brosa
Member


0
1 posts 0 threads Joined: Nov 2017
11-15-2017, 06:54 PM -
#15
No progress as of today either. Still getting black characters and scrambled text, as well as ~20 framerate even on an 8700K system
GeniusMage
Member


0
26 posts 0 threads Joined: Aug 2017
12-01-2017, 07:04 PM -
#16
EDIT: these got reverted in PR #3827

After the 01/12 changes from Jarves and kd:

   
Cel-shading now appears, with the same issue as in Graces f

   
World map is a bit broken, sky texture is bugged (similar issue in the main menu)

   
This is the main menu without Strict Rendering mode, models are now visible (also appear ingame)
This post was last modified: 12-10-2017, 10:24 AM by GeniusMage. Edit Reason: update
Aquanaut14
Member


0
3 posts 0 threads Joined: Dec 2017
12-07-2017, 10:39 PM -
#17
Just curious about how long you guy's have been working on this?
Nilvarno
Member


0
5 posts 0 threads Joined: Dec 2017
01-17-2018, 10:00 AM -
#18
Is there some news? I want to play this game since years, but the last time i tried, it was so far from playable...
This post was last modified: 03-24-2018, 12:53 PM by Nilvarno.
GeniusMage
Member


0
26 posts 0 threads Joined: Aug 2017
03-21-2018, 11:56 AM -
#19
Thanks to pauls-gh, black characters are now fixed.
New issues are now visible. Such as squares around folds and patterns, and some textures are not quite of the right color.

The text issue may be fixed for Nvidia users, using OGL and Strict Rendering Mode (needs more testing).


Attached Files Thumbnail(s)
   
marthgun
Member


0
28 posts 0 threads Joined: Sep 2017
03-22-2018, 07:14 PM -
#20
(03-21-2018, 11:56 AM)GeniusMage Wrote: Thanks to pauls-gh, black characters are now fixed.
New issues are now visible. Such as squares around folds and patterns, and some textures are not quite of the right color.

The text issue may be fixed for Nvidia users, using OGL and Strict Rendering Mode (needs more testing).

text issue was only fixed with OpenGL and Strict Rendering, game runs way too slow to feasibly play.  at least for me, it was about 11-12 fps


Forum Jump:


Users browsing this thread: 1 Guest(s)