Final Fantasy X/X-2 HD Remaster [NPUB31247]
Started by twdarkeh




13 posts in this topic
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
04-25-2017, 06:08 AM -
#1
Game select works, both recompilers, load liblvl_2 only. Almost gets in game, gets stuck in a loading loop saying it can't decrypt something. US PSN version, so making a new thread.

X-2 seems to get stuck somewhere. Waited 2-3 minutes on a black screen, but FPS counter is still going and it's not throwing errors. Not sure what's up.
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
04-30-2017, 08:34 PM -
#2
Going ingame now. Save/load works, sound stutters a bit. Will test more later.

FFX-2 gets to main menu, and can play the opening cutscene, but crashes with a mem access violation when it tries to enter the first battle.
che
Guest


 
05-01-2017, 12:45 PM -
#3
(04-30-2017, 08:34 PM)twdarkeh Wrote: Going ingame now. Save/load works, sound stutters a bit. Will test more later.

FFX-2 gets to main menu, and can play the opening cutscene, but crashes with a mem access violation when it tries to enter the first battle.

plz share video
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
05-01-2017, 01:20 PM -
#4
Moving to ingame
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
05-21-2017, 11:29 PM -
#5
FFX runs at full speed on my i5-3470 with a GTX 670 with kd-11s latest PR and *seems* playable. Only issue is that in movie-style cutscenes, the audio and video are out of sync. I can get a log if anyone wants one.

FFX-2 still crashes after the opening video, log is attached. Also has the same movie-style cutscene issue.
bobjanderson8080
Guest


 
06-10-2017, 07:07 PM -
#6
Final Fantasy X/X-2 HD Remaster [NPUB31247] is not going into the save screen in-game but, the game plays fine for me. Just load save at the title screen.

Rpcs3 Settings for FF X/X-2 HD Remaster.

Core/ Interpreter (fast)
Core/ Recompiler (ASMJIT)

Load libraries/ Load liblv2.sprx only

Graphics/ Vulkan
Resolution/ 1280x720 16:9
Framelimit/off

Just boot (S)ELF/ ffx_phyreApp.elf

C:\Users\YOUR NAME\Emulators Location\PS3\EmuCR-rpcs3-20170611-x64\dev_hdd0\game\NPUB31247\USRDIR\ffx_phyreApp.elf

[Image: Screenshot_41.jpg]
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
06-12-2017, 09:26 AM -
#7
There is no save UI yet; save just calls the save function and saves it in a default slot. Load loads the default slot. Save UI is coming eventually.
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
06-24-2017, 02:39 AM -
#8
I'm not sure which commit did it, but FFX-2 now goes ingame. Got to the last battle in the opening stage before I hit a mem access violation, which used to happen right after the opening cutscene, so pretty good progress. Only other major flaw is the fact that it gets stuck recompiling every few seconds.

Tested on RPCS3 v0.0.2-5338-677a04b0 Alpha
Ani
Administrator
*******


10
3,483 posts 94 threads Joined: Aug 2017
06-25-2017, 02:27 PM -
#9
(06-24-2017, 02:39 AM)twdarkeh Wrote: I'm not sure which commit did it, but FFX-2 now goes ingame. Got to the last battle in the opening stage before I hit a mem access violation, which used to happen right after the opening cutscene, so pretty good progress. Only other major flaw is the fact that it gets stuck recompiling every few seconds.

RPCS3 v0.0.2-13-7555ddf Alpha
·! 0:00:00.000000 LDR: Path: C:/Users/Spencer/Desktop/rpcs3/dev_hdd0/game/NPUB30089/USRDIR/EBOOT.BIN
·! 0:00:00.000323 LDR: Title: Digger HD
·! 0:00:00.000350 LDR: Serial: NPUB30089

Careful with posting wrong logs.
twdarkeh
Member


0
58 posts 7 threads Joined: Aug 2017
06-25-2017, 02:40 PM -
#10
(06-25-2017, 02:27 PM)Annie Wrote:
(06-24-2017, 02:39 AM)twdarkeh Wrote: I'm not sure which commit did it, but FFX-2 now goes ingame. Got to the last battle in the opening stage before I hit a mem access violation, which used to happen right after the opening cutscene, so pretty good progress. Only other major flaw is the fact that it gets stuck recompiling every few seconds.

RPCS3 v0.0.2-13-7555ddf Alpha
·! 0:00:00.000000 LDR: Path: C:/Users/Spencer/Desktop/rpcs3/dev_hdd0/game/NPUB30089/USRDIR/EBOOT.BIN
·! 0:00:00.000323 LDR: Title: Digger HD
·! 0:00:00.000350 LDR: Serial: NPUB30089

Careful with posting wrong logs.

Er. That's odd. I'll get a new one.

Edit: This is not the wrong log. I just didn't restart the emulator between tests. Simply search NPUB31247 to get to the part where it starts. I only posted it because of the change; I wasn't expecting it.


Forum Jump:


Users browsing this thread: 1 Guest(s)