Hello There, Guest! Register

Just a few questions
#1
Just started using rpcs3 today and its working really good. Thanks for your hardwork guys.WinkSmile

Just a few questions
1) How do i update the rpcs3 emulator to the latest version do i have to download a new 1 each time or is there any other way
I am using a build for Dai-3-Ji Super Robot Taisen Z Jigoku-hen [BLJS10256]
which i got from somewhere but the thing is that 1 is 29-03-2017 version so is there
anyway to upgrade it to the latest version without changing the build?

2) Also the game stops working every time i try using Vulkan for graphics open gl works fine though
Using a acer aspire E1-570 laptop
intel core i3-3217U(1.8Ghz,3MB L3 cache)
Intel HD Graphics 4000
Ram 4GB
Not sure if it supports Vulkan or not.
Heard that vulkan has better fps so i hope i can use it somehow. Added a log too.

Any help is appreciated.
Reply
#2
First question is answered on the website's FAQs: you have to download the latest build and replace it on your folder. I don't understand what you mean by upgrading without changing the build, if you're upgrading then you're getting a new build.

Your iGPU doesn't support OpenGL 4.3 let alone Vulkan or D3D12.
Even for GPUs that do support them, support for Intel Integrated Graphics is not guaranteed as their drivers are pretty bad.
If it works on some games you're lucky although it may break as it misses required OpenGL functions used by RPCS3, but it won't work on latest versions since they check if the GPU has proper OpenGL support before attempting to start the emulation.
You'll need a better computer for RPCS3 I'm afraid.
Reply
#3
(04-15-2017, 09:48 PM)Annie Wrote: First question is answered on the website's FAQs: you have to download the latest build and replace it on your folder. I don't understand what you mean by upgrading without changing the build, if you're upgrading then you're getting a new build.

Your iGPU doesn't support OpenGL 4.3 let alone Vulkan or D3D12.
Even for GPUs that do support them, support for Intel Integrated Graphics is not guaranteed as their drivers are pretty bad.
If it works on some games you're lucky although it may break as it misses required OpenGL functions used by RPCS3, but it won't work on latest versions since they check if the GPU has proper OpenGL support before attempting to start the emulation.
You'll need a better computer for RPCS3 I'm afraid.

Thanks for the info. Guess i need to get a new computer then..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)