Sonic Generations [BLES01236]
Started by Aeternal600




2 posts in this topic
Aeternal600
Guest


 
03-31-2017, 03:12 PM -
#1
Tested using rpcs3-v0.0.2-2017-03-30-c4066b92_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Interpreter (fast)
SPU decoder: Recompiler (ASMJIT)
LLE libraries picked automatically by RPCS3
Graphics settings: OpenGL, DX12, Vulkan @ 1280x720 w/ VSync
Audio settings: XAudio2
Input/Output: XInput

DX12 immediately crashes RPCS3. Vulkan shows a grey window but doesn't go any further. Using OpenGL, the game boots into an animated loading screen (see screenshot #1) which runs at ~20 fps. Unfortunately it doesn't go beyond the loading screen at the moment. If you leave it running, the screen freezes after a couple of minutes.
basic.wizard
Member


0
5 posts 1 threads Joined: Jul 2018
07-22-2018, 11:33 AM -
#2
With SPU Decoder set to "Interpreter (fast)", this now goes in-game. Everything 3D (excluding dust particles, for whatever reason) is rendered black, making it very hard to complete any level. It's also very slow, on account of the SPU interpreter. It also freezes randomly...

Screenshots:

[Image: bsflzu.png]

[Image: kensrj.png]

[Image: oflqps.png]

[Image: hygcci.png]

[Image: expife.png]

(it crashed at the above screenshot)

RPCS3 Version: 0.0.5-7117-12b8908a0 Alpha


Attached Files
.gz   RPCS3.log.gz (Size: 295.23 KB / Downloads: 18)
yurinator557
RPCS3 Tester


0
34 posts 9 threads Joined: Jul 2019
11-18-2020, 12:39 AM -
#3

(11-18-2020, 12:39 AM)yurinator557 Wrote: Game seems to have come a loooooooooong way. It's looking very good so far. I haven't played through the entire game yet (just the first 2 stages) but I've gotten rock solid 30fps on every stage so far besides Chemical Plant Act 2 (only dropping to mid 20s, still fine imo). Log is attached.

RPCS3 v0.0.13-11263-68931b4c Alpha

Settings:
SPU/PPU decoders: Recompiler (LLVM)
Thread scheduler enabled
SPU block size: Safe
Preferred SPU Threads: Auto
Renderer: Vulkan
Frame Limit: 59.94 (doesn't seem to matter, won't go above 32fps)
Anisotropic Filtering: 16x
Anti-aliasing: Auto
Shader Mode: Async (Multi Threaded)
Multithreaded RSX enabled

Specs:
Ryzen 7 5800X
EVGA FTW3 RTX 2070 Super
16GB DDR4-3600 CL18 RAM

As a side note, it loves to spam the below in the log, but I've no idea if it's the game doing it or a setting being wrong:
RSX: FS exports depth component but depth test is disabled (INVALID_OPERATION)
This post was last modified: 11-18-2020, 12:46 AM by yurinator557. Edit Reason: forgot rpcs3 version


Attached Files Thumbnail(s)
               

.gz   RPCS3 (2).log.gz (Size: 1.95 MB / Downloads: 9)


Forum Jump:


Users browsing this thread: 1 Guest(s)