Spider-Man: Edge of Time [BLUS30760]
Started by GrantKane

26 posts in this topic

13 posts 1 threads Joined: Jan 2018
01-02-2019, 04:45 PM -
(01-02-2019, 04:29 PM)Asinine Wrote: You should try SPU LLVM it might help with the audio and performance. Also try 2-3 spu threads, it may or may not be better than auto. If you're still having audio problems try Ruipins WiP build which will probably fix it: https://ci.appveyor.com/api/buildjobs/ky...6_win64.7z
NOTE: Please, don't use this if you're reading this more than a month or two from now...

Tried SPU LLVM, waited a half an hour to load the game, build all those SPU caches, but it still crashed when I tried, also I tried ruipin's build, audio might have been a little better but only for a very short time. I'll try using 2-3 SPU threads, see if it changes anything. Edit: Tried every spu thread, from 1 to 6, no change, not better but not worse also. What could be the reason for this audio stutter, if he doesn't have it? I know i7 8700K is stonger then a Ryzen 5 2600, but I think it should be enough.
This post was last modified: 01-02-2019, 11:13 PM by Patkos96.

124 posts 51 threads Joined: Feb 2018
01-03-2019, 04:21 AM -
After the first crash I had no issues. Asinine has asked if I'd test in OpenGL so I'll retest in OpenGL tomorrow sometime. I won't have a video for that, but I'll attach log file. Cheers!

ps. sorry you're having issues buddy. Seems to work fine for me.

13 posts 1 threads Joined: Jan 2018
01-03-2019, 11:16 AM -
(01-03-2019, 04:21 AM)MasterTurkey Wrote: After the first crash I had no issues. Asinine has asked if I'd test in OpenGL so I'll retest in OpenGL tomorrow sometime. I won't have a video for that, but I'll attach log file. Cheers!

ps. sorry you're having issues buddy. Seems to work fine for me.

I bet it's gonna work for you, but OpenGL does the same for me, it also runs slower and compiling shaders last forever with that in every game. But I think one of my applications was causing the crash since after I closed everything else besides RPCS3 the game never crashed. Performance and audio stayed the same unfortunately. Edit: Seems like crash remains, even with everything else closed.
This post was last modified: 01-03-2019, 12:22 PM by Patkos96.
RPCS3 Tester

388 posts 105 threads Joined: Mar 2018
01-03-2019, 11:33 AM -
Just throwing my 2 cents in here as I've played it too fairly recently (a month ago?). My 8700k did experience slowdowns in a few areas, but they weren't severe. SPU LLVM does not play well with this game, as it (seemingly) infinitely builds cache.
I never had it crash and I played it on Vulkan for a couple hours.

I'd personally say this is still playable from my experiences and the time passed since then. Probably only just barely performance wise though-- anything other than top tier RPCS3 CPUs may have performance issues until speed is improved generally.
This post was last modified: 01-03-2019, 11:34 AM by Deminating.

3 posts 1 threads Joined: May 2019
08-14-2019, 02:03 AM -
I wanted to throw in my results with this game, the issue Deminating described seems to apply to me as well. Switching to the Interpreter makes the game work as opposed to LLVM which causes it to freeze after a little while. Performance is iffy, dropping to 10FPS in some areas, but it does run. Unlike Deminating though, I have a 6700K, so my performance won't be as good.

I also have another issue; the game runs great the first time, but after that it locks up almost immediately after the game is launched, on the screen that tells you "This game has an autosave function" and all that. I figured out it's got to do with the trophy cache; if I delete the trophy cache after playing the game, it'll launch fine again, but I have to delete that folder after it gets generated after each time I play the game.

I'll include info from a launch where the trophy-related freeze happened below (and the log file of course):

RPCS3 v0.0.6-8482-7fda07eb Alpha
Firmware v4.84
OS: Win10 x64
CPU: Intel i7-6700K
GPU: Nvidia GTX 1080

The trophies folder that causes the issue is found at the directory below:

Deleting that folder lets the game launch again like normal.


I did find a workaround that lets you not have to mess with deleting the trophy folder every time, as long as you're willing to lose the trophies feature. This workaround sets the trophies directory to point to NUL (ie it says "this folder goes nowhere").
Open an Administrative Command Prompt and go to
(or wherever your trophies folder is usually located).
Delete the "trophy" folder in that folder, then enter the following command in the command prompt:
mklink /D trophy NUL

I haven't tested the fix extensively, but it seems to work with no other issues.


Bug has been fixed, leaving the workaround up for historical reasons/in case it helps another issue somewhere.
This post was last modified: 03-25-2020, 03:31 AM by HyperSpider. Edit Reason: bug update

Attached Files
.gz   RPCS3.log.gz (Size: 75.87 KB / Downloads: 6)

69 posts 0 threads Joined: Mar 2020
03-24-2020, 10:19 AM -
Beaten the game from start to finished with random audio stuttering in default setting.  Gameplay FPS is stableOpenAL reduces audio stuttering and give a comfortable and clear audio in most stuttering area.

# Gameplay FPS = (29~30)
# Cutscenes (29~30)
# RPCS3 v0.0.9-10007-eb1de04c Alpha
# Default setting [Res. scale= 300% Fullscreen 4K]
# Intel i9-9900K @ 3.60GHz | 32GB RAM | 2070S 8GB Nvidia |NVMe storage (3500MB/2500MB Read/Write).

@ Random Stuttering Audio Problems

# Select OpenAL (AUDIO)
# Enable buffering = 24ms (AUDIO)
              # Enable Time Stretching = 24% (AUDIO) ==> reduced stuttering in few area.
              # Enable Time Stretching = 48% (AUDIO) ==> audio stuttering reduction is acceptable in all area.
              # Enable Time Stretching = 72% (AUDIO) ==> reduced stuttering in most area.

Attached Files Thumbnail(s)

.rar   RPCS3.rar (Size: 1.23 MB / Downloads: 22)

1,949 posts 79 threads Joined: Aug 2017
07-03-2020, 12:17 PM -
I played this for ~40mins and it was working fine. Shadows are fixed now too.

Forum Jump:

Users browsing this thread: 1 Guest(s)