Hello There, Guest! Register

Odin Sphere Leifthrasir [BLUS31601]
#21
I'm having the same issue, I have the game on a separete folder
(D:\vids\ps3\ <---here is the emu
D:\vids\ps3 gaems\OSL\BLUS31601 <--- here is the game)
, on a folder with the correct name (BLUS31601).

I attached the rpcs3.log (I hope this is the file you are referring to)

edit: found out what the problem was, rpcs3 wasn't detecting my controler, a quick config and just pressing x will let you pass that screen into the endless "setting thropy data"
Reply
#22
Odin Sphere Leifthrasir [BLUS31601] Playable on any builds but the newest builds is the best
ppu-Interpreter(fast)or recompiler(LLVM) & spu- recompiler(ASMJIT)
Vulkan or opengl but Vulkan is better and give you more fbs
and you need cpu better than main because my game drops below 30 fbs in some crowded places
the trophy loading problem still here you need to start the game multiple times until it's loaded correctly
and another problem the sound in the cutscenes is behind the game graphics so the cutscenes will finish before the audio you can fix this by locking the game fbs to 30 fbs this make the game better but not 100%
my pc i5 750 gtx 970 8gram w7 x64
Odin Sphere Leifthrasir full playthrough on rpcs3 by me













and this is the full playlist
https://www.youtube.com/playlist?list=PL...TiC1XIakKJ
Reply
#23
Stop not following submission guidelines or I'll have to restrict your posting.

Duplicated thread & Missing Log / used Commit.
Reply
#24
Can't boot this successfully anymore on the latest versions, not even with the pause and resume trick I talked about weeks ago:

(04-30-2017, 11:54 AM)rauldj Wrote:
(04-28-2017, 08:56 PM)DigitalFarce Wrote: Strange. I've tried a ton of different settings and versions and it gets past the trophy screen like 2% of the time. Very random and can't get replicate it with a certain string of settings either way. Thanks for your help Smile

In my case, the only way to get pass of that is pausing the emulation when the "Checking savefiles" screen is disappearing, and then resuming it.

Log: https://my.mixtape.moe/gombqf.log
Reply
#25
trophy screen bug bypass like 2% of the time, same for me as well.
with this bug how is this playable ?
Reply
#26
(07-16-2017, 04:26 PM)Jhon1234 Wrote: trophy screen bug bypass like 2% of the time, same for me as well.
with this bug how is this playable ?


Yeah, I'm asking that to myself too. It's quite a shame that "just" because of this one can't even boot the game, a game that if this were to be fixed would run mostly OK.
Reply
#27
having problem stuck at loading trophy scene too

but i delete folder trophy in data folder and restart the game , 2 out of 5 can get pass setting trophy scene

so is it true if just set up a joy stick controller will solve the problem ?
Reply
#28
Can something be done to fix this issue? I've been unable to boot the game for weeks, not even on interpreter.
Reply
#29
(08-06-2017, 09:58 PM)rauldj Wrote: Can something be done to fix this issue? I've been unable to boot the game for weeks, not even on interpreter.

This is a definite game bug. Basically RPCS3 is too fast which causes some broken synchronization code in the game itself to fail. This can be fixed by making the game frame rate much lower as it starts up. See in the screenshot here how I slowed down the game to ~6 fps which seems to certainly get past the bug.

Actually, we speed up the game and therefore lower frame rate if you get what I mean. Anyway, just download cheat engine, attach to RPCS3, and use the speed hack at a factor 10 or more (just try 100). Then start the game. When you are past the trophy screen you can turn speed hack off and play as usual. I tested several times and it seems to only work with interpreter. LLVM fails every time, even slowed down to 0.1 fps.

Edit: Of course be careful with this tool. Download it here: https://github.com/cheat-engine/cheat-engine
Make damn sure not a remnant of this tool is in memory if you are going to play online games. Restart you computer after using it, because it will lead to VAC ban for example.


Reply
#30
(08-07-2017, 04:51 PM)ssshadow Wrote:
(08-06-2017, 09:58 PM)rauldj Wrote: Can something be done to fix this issue? I've been unable to boot the game for weeks, not even on interpreter.

This is a definite game bug. Basically RPCS3 is too fast which causes some broken synchronization code in the game itself to fail. This can be fixed by making the game frame rate much lower as it starts up. See in the screenshot here how I slowed down the game to ~6 fps which seems to certainly get past the bug.

Actually, we speed up the game and therefore lower frame rate if you get what I mean. Anyway, just download cheat engine, attach to RPCS3, and use the speed hack at a factor 10 or more (just try 100). Then start the game. When you are past the trophy screen you can turn speed hack off and play as usual. I tested several times and it seems to only work with interpreter. LLVM fails every time, even slowed down to 0.1 fps.

Edit: Of course be careful with this tool. Download it here: https://github.com/cheat-engine/cheat-engine
Make damn sure not a remnant of this tool is in memory if you are going to play online games. Restart you computer after using it, because it will lead to VAC ban for example.

Thank you very much for the explanation. Unfortunately, I'm still unable to boot the game no matter the setting (10x -> 6 FPS, 20x -> 3 FPS... even 500x and 0.25x), I get the exact same result as before. I even tried lowering CPU frequency to its minimum and got the same thing.

What a miserable fate this beautiful game has to suffer...
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)