Hello There, Guest! Register

Trine (Demo) [NPEB90200]
#1
Tested using rpcs3-v0.0.1-2017-03-03-48b05838_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Interpreter (fast)
SPU decoder: Recompiler (ASMJIT)
LLE libraries picked automatically by RPCS3
Graphics settings: DX12 @ 1280x720 w/ VSync, Frame limit set to Auto
Audio settings: XAudio2
Input/Output: XInput

After decrypting all the .sdat files that come with the game, it goes past the initial loading screen. All the menus appear to work fine, including animations, sound and music. The credits can be played back. When starting a new game, RPCS3 randomly crashes or (rarely) freezes when the loading screen starts to fade away and the ingame cursor appears, as seen in my last screenshot.

Graphically, DX12 appears to be a bit better. It properly displays the progress bar on the loading screen (the vines near the bottom of the parchment, see screenshots 4 and 5), which are missing in OGL and Vulkan. Apart from that, no visible differences.
Reply
#2
Quote:RPCS3 randomly crashes or (rarely) freezes

This is the issue of last emu versions over the month i think. I would say it's the main issue imho.
Reply
#3
Game re-tested using rpcs3-v0.0.2-2017-07-12-bb563b3e_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Recompiler (LLVM)
SPU decoder: Recompiler (ASMJIT)
Load liblv2.sprx only
GPU settings: OpenGL; Vulkan @ 1280x720 w/ VSync, Frame limit set to 60
Audio settings: XAudio2
Input/Output: DualShock 4

The demo runs much better overall this time. It does go ingame but it always crashes for me after the initial stage where you play as the archer. One strange thing that I've noticed is that the game seems to skip to a later stage randomly; sometimes I can only walk a couple of steps before it considers the stage finished and tries to load the next stage.

As for the graphics, there's a bit of flickering around the moon and an inconsistent framerate (see screenshot #1) when using OpenGL; with Vulkan, nothing flickers, it looks pretty much perfect and runs at a smooth 60 fps. Regardless of the renderer, sometimes text doesn't render properly (see screenshots #2 and #3). Sometimes the text shows fine, sometimes it doesn't, but when it doesn't, it's always the same characters that are missing.

I guess this can be upgraded to Ingame.
Reply
#4
rpcs3-v0.0.5-7486-90f81659_win64

Playable.


Attached Files Thumbnail(s)
           

.rar   RPCS3Trine.rar (Size: 146.21 KB / Downloads: 0)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)