Hello There, Guest! Register

LittleBigPlanet 3 [BCUS98362]
#1
RPCS3 v0.0.1-5-1f45f05 Pre-Alpha

Load libraries:
- libac3dec.prx
- libac3dec2.prx
- libadec.prx
- libat3dec.prx
- libatrac3plus.prx
- libatxdec.sprx
- libdmux.prx
- libdmuxpamf.prx
- libfiber.prx
- libfont.prx
- libfontFT.prx
- libfreetype.prx
- libfreetypeTT.prx
- libfs.prx
- libl10n.prx
- libmvcdec.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libsail.prx
- libsail_avi.prx
- libsjvtd.prx
- libsmvd2.prx
- libsmvd4.prx
- libspurs_jq.prx
- libsre.prx
- libsync2.prx

PPU Decoder: Interpreter (fast)
PPU Threads: 2
SPU Decoder: Recompiler (ASMJIT)

---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC0000005.
Segfault reading location 00000000b97f0000 at 000000000026c609.
Instruction address: 000000000026c609.
Function address: 000000000026c500 (base+0x25c500).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------
Reply
#2
Mods, please move this game to "Intro"

Testing: Minimal.
Specs: I7-860, HD 6970, 8Gb RAM

Settings:
OpenGL
1280 X 720
Interpreter(Fast) + Recompiler (ASMJIT)
Uncheck "Load required libraries" as it hangs the game on a black screen.
I actually had no libraries loaded so..... yeah.

I did actually manage to get the same screen with other configurations though, so your milage may vary. Please note that before the final screen it installed game data onto the virtual PS3 hard drive.




Please remember that I'm not a programmer and did not test this game for too long.
'mon then!

Ryzen 5 3600 (@ 3.95GHz) | 16Gb DDR4 3200Mhz | MSI GTX 1660 6gb
Reply
#3
Disabling large parts of the game by not loading libsre (spurs) and such is very hacky. It is pure coincidence that it displays anything at all. The game can never work with such a configuration.
Reply
#4
(04-09-2017, 01:17 PM)ssshadow Wrote: Disabling large parts of the game by not loading libsre (spurs) and such is very hacky. It is pure coincidence that it displays anything at all. The game can never work with such a configuration.

This okay then? I am not 100% sure yet, but it seems that in order to install game files your first need to not have any libraries loaded. However, after having the files installed you can boot the game with the basic files necessary. Again, i'm not 100% on this so I'll get rid of the game data a little later and try reinstalling with the necessary libraries loaded to see what happens.

[Image: C8-9379XkAA3Iy3.jpg]

The RAR file has both the RPCS3 Log and the image.

Can this be considered to be in the "Intro" pile now?

(04-09-2017, 04:24 PM)KoDa Wrote:
(04-09-2017, 01:17 PM)ssshadow Wrote: Disabling large parts of the game by not loading libsre (spurs) and such is very hacky. It is pure coincidence that it displays anything at all. The game can never work with such a configuration.

This okay then? I am not 100% sure yet, but it seems that in order to install game files your first need to not have any libraries loaded. However, after having the files installed you can boot the game with the basic files necessary. Again, i'm not 100% on this so I'll get rid of the game data a little later and try reinstalling with the necessary libraries loaded to see what happens.

[Image: C8-9379XkAA3Iy3.jpg]

The RAR file has both the RPCS3 Log and the image.

Can this be considered to be in the "Intro" pile now?

Alright, i just tested the game once again and it appears to actually be working first time with the following libs loaded:

libresc
librtc
libspurs
libsre

This is strange considering the first time I tested the game it wouldn't get past a black screen with those libraries loaded. A further screenshot has been provided.
'mon then!

Ryzen 5 3600 (@ 3.95GHz) | 16Gb DDR4 3200Mhz | MSI GTX 1660 6gb
Reply
#5
Fair enough I guess... Moving to intro.
Reply
#6
Oh, and everyone please note that if you want to get the game to get to the intro you must only use the latest PS3 firmware (currently 4.81) as with any other firmware the game becomes stuck on the black screen with a few coloured pixels.
'mon then!

Ryzen 5 3600 (@ 3.95GHz) | 16Gb DDR4 3200Mhz | MSI GTX 1660 6gb
Reply
#7
RPCS3 v0.0.3-3-da3f3fd Alpha - master build

Still stucked on loading screen.




.gz   RPCS3.log.gz (Size: 179.84 KB / Downloads: 9)
[Image: CwrhKKk.png]
[Image: 35v3py-2.png]
Reply
#8
Look At the attachment 

I got the fonts working but ist big and blury

   
Reply
#9
In preparation for upcoming changes to the compatibility database, this thread is being moved to ingame. Due to other threads for the same media (Disc or PSN) already being in that category.

If you find a specific game ID that performs differently than others for the same game+edition of the same format (PSN or Disc) even when tested with the same build and settings then please discuss it in the relevant thread(s) and PM a moderator so we can look into it.

Tested with: RPCS3 v0.0.4-6209-d8ae94df Alpha

Note: I'm fairly certain this requires some Profile files from a real ps3 to play, these files also contain PSN account information so you shouldn't share them with anyone.
Reply
#10
I was able to complete the campaign with co-op for LBP3 to completion as of 0.0.10-10442. No issues or slowdowns.

LLVM, no accurate x float, async shader with interpreter, resolution scale 200%, multithread rsx enabled, force blit enabled.

Ryzen 3700x, windows 8.1 64 bit, gtx 1070.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)