Infamous [BCUS98119]
Started by jmoney31




26 posts in this topic
Hakj3r
Member


0
23 posts 1 threads Joined: Jan 2018
06-01-2018, 09:53 PM -
#11
RPCS3 v0.0.5-6884-dcd7f442f Alpha | HEAD
Reaches up to 8FPS. PPU interpreter (fast) + ASMJIT + Vulcan.

-----------------------------------------------------------------------------

RPCS3 v0.0.5-6997-83f096c43 Alpha | HEAD
10-15FPS on PPU LLVM + SPU ASMJIT + Vulcan. Graphics looks the same as with PPU interpreter (fast) imo. Single one thing that's bad is screen jumping at random between two corners of the window (pics in attachments).
This post was last modified: 06-23-2018, 09:41 PM by Hakj3r.


Attached Files Thumbnail(s)
       
CPU: Intel I9-9900k @ 4.7 GHz
GPU: Nvidia GeForce GTX1080
RAM: 16GB DDR4 3200
Motherboard: MSI MPG Z390 Gaming Plus
DarkMaster
Member


0
1 posts 0 threads Joined: Nov 2017
06-22-2018, 03:46 PM -
#12
RPCS3 ver. 0.0.5-6980-81e5f3b7f Alpha
The game loads fine and with an FPS as high as 4 and generally 1-2 FPS with OpenGL. Sound is understandable(aka. I know what they say). With Vulkan though FPS is generally as high as 4-5 FPS but sound goes to hell and back.
For settings I left everything on default as I deleted my old version and redownloaded then I changed to Vulkan for a second test.
As a note enabling LLMV Recomp. breaks everything and brings no speedup. Also what is "Occlusion pool overflow"?
Other than low FPS I could play the game slowly. Played as far as the "how to shoot lightning tutorial" when you charge batteries, for those interested.
Hakj3r
Member


0
23 posts 1 threads Joined: Jan 2018
08-12-2018, 10:32 PM -
#13
@"DarkMaster" I don't know what it is, but it can be avoided by checking "Disable ZCull Occlusion Queries" in Debug tab. In my case it doubles the performance. Also just checked again, SPU LLVM recompiler works good, in my case even better than ASMJIT, if you already have SPU cache.

Got 10-15FPS right now, my settings are in attached photos.
PS: Also in the config file (RPCS3>data>BCUS98119) you need to change "Accurate xfloat" to true.
This post was last modified: 08-12-2018, 10:34 PM by Hakj3r.


Attached Files Thumbnail(s)
           
CPU: Intel I9-9900k @ 4.7 GHz
GPU: Nvidia GeForce GTX1080
RAM: 16GB DDR4 3200
Motherboard: MSI MPG Z390 Gaming Plus
HamutKaput
Member


0
4 posts 0 threads Joined: Aug 2018
08-22-2018, 12:37 PM -
#14
The game was mostly running between 4 to 8 fps on the privious build with some minor graphical bugs mostly involving lighting. On the current build(rpcs3 0.0.5-72280874d18f76 Alpha) the fps has gone up to mostly above 10 with some dips to 4-8 however now there are certain missing graphics and flickering mostly around the hero model as i have seen. I have attached the logs and a screenshot along with my config.yml file so you can see the settings i used in case you want to recreate the problem.

Edit: recently i fiddled with the settings a bit more and after changing the spu decoder to ASMJIT launching the game once and then changing it back to LLVM the issue disappeared now the game runs between 8 to 27 fps depending on the location and the number of enemies engaged as far as i can tell


.7z   Logs.7z (Size: 1.9 KB / Downloads: 17)    
This post was last modified: 08-23-2018, 12:18 AM by HamutKaput.
Asinine
Moderator
*****


3
1,976 posts 79 threads Joined: Aug 2017
08-25-2018, 09:04 AM -
#15
SPU LLVM is still experimental, issues are to be expected. But you can try the accurate xfloat option if SPU LLVM causes issues xfloat will likely fix it.
Hakj3r
Member


0
23 posts 1 threads Joined: Jan 2018
08-31-2018, 11:33 PM -
#16
Accurate xfloat is a must with SPU LLVM in this game. Though ASMJIT works just as well minus annoying lags when LLVM compiles.
CPU: Intel I9-9900k @ 4.7 GHz
GPU: Nvidia GeForce GTX1080
RAM: 16GB DDR4 3200
Motherboard: MSI MPG Z390 Gaming Plus
Hakj3r
Member


0
23 posts 1 threads Joined: Jan 2018
01-02-2020, 06:22 PM -
#17
Ok, one of the few last patches before v0.0.8-9305 fixed the problem with the sound (no more cracking).
And relaxed ZCULL doesn't really change anything for me.
FPS 13-60 (depending where you look)
Config:
Stock with:
- CPU: "Enable SPU loop detection" off
- GPU: "Renderer": Vulcan
This post was last modified: 01-03-2020, 08:56 AM by Hakj3r.
CPU: Intel I9-9900k @ 4.7 GHz
GPU: Nvidia GeForce GTX1080
RAM: 16GB DDR4 3200
Motherboard: MSI MPG Z390 Gaming Plus
Hadronikle
Member


0
1 posts 0 threads Joined: Feb 2020
02-05-2020, 06:44 PM -
#18
As of the time of this posting i am on version 0.0.8-9510-3cc42c1b Alpha

there are small audio issues and less graphical issues, just some flickering in some places. there are some issues though, I am only getting around 20% GPU usage ans 15% CPU usage. i am getting around 20-24 fps standing still, walking/ running is 15-10 fps. i figured out how to get past 30fps turn vsync on and frame cap up to 60 fps. any suggestions welcome.


thread scheduler is on
SPU cache is on
Accurate xfloat is on
Multithreaded RSX is on


Ryzen 7 2700x 
GTX 1080ti
24GB Ram
hairybones
Member


0
1 posts 0 threads Joined: Mar 2020
03-30-2020, 04:06 PM -
#19
New as of version: 0.0.9-10071-51050b Alpha

Game Runs anywhere between 18-27 fps while roaming, with some scenes dipping to ~5fps, and others running faster than 30fps. Noticed many corrupted textures, poor lighting/fullbright scenes, and slow cutscenes (for some reason). Also its worth noting that the game only utilizes up to 30% CPU and 25% GPU. Not sure if theres a way for me to bump those usage numbers up myself and possibly see better results.

   

Renderer: Vulkan (all defaults)
SPU Decoder: ASMJIT (LLVM yields similar or sometimes worse results)
CPU: AMD Ryzen 7 2700X (No OC)
GPU: AMD Radeon 5700XT (No OC)
RAM: 16GB DDR4 3200mhz

   
   
   
krashd
Member


0
1 posts 0 threads Joined: May 2020
05-19-2020, 12:14 PM -
#20
Hello, I'm a new member, great to be here and all that bumff.

Right, straight to business...  I got bored being in lockdown so I went through every option in RPCS3 and the custom config to find out how to run InFamous a bit better and squeeze out every last drop of FPS and so here is my report.

Title specifics: BCES00609

System: Ryzen 1700X - Radeon RX 5700 XT - 16GB of mammaries.

RPCS3 version: 0.0.10-10406-3d320aea Alpha

RPCS3 global settings: Default settings except for the following..
     Anti-Aliasing = Disabled (I kept getting an RPCS3 warning about my card not liking MSAA so I disabled it globally)
     Max LLVM Compile Threads = 14 (I have 16 in total and like to keep 2 for background tasks)

BCES00609 custom settings:
     SPU Decoder = LLVM (default anyway)
     Enable SPU loop detection = unchecked (slight fps increase but big stability increase/less stuttering)
     Preferred SPU Threads = 6 or lower (I found that PPU and RSX need almost as many threads as SPU, for my Ryzen the ideal number was 6 threads for SPU and 10 to be shared between PPU and RSX)
     Renderer = Vulkan (default anyway)
     Strict Rendering Mode = checked (this cleaned up the graphical issues such as the broken glass on the ground which looked like purple wire-frame blocks without this setting)
     Disable On-Disk Shader Cache = checked (this made the biggest difference, an extra 7fps in every scene!)
     
Alterations to config_BCES00609.yml:
     'Disable FIFO Reordering: true' (this got me an extra 1 or 2 fps overall)

Results:
     Solid 30fps during Sony and Sucker Punch cinematics (to be expected)
     21fps during the "Press Start" screen at beginning of intro sequence.
     45fps at moment of nuclear flash after pressing Start.
     Between 18 and 27fps during the hectic "people fleeing" scene (this is where audio begins to stutter)
     37fps during the aerial shot of the blast.

Since I must have restarted the game 60 or 70 times during these tests I didn't bother to go any further than the above scenes or it would have taken me all day to get through all of the options in the config file.  I also just assumed that any difference I saw during the intro sequence would likely be replicated in the game anyway.

Two final notes:
1.) I tried ASMJIT as SPU decoder but the ingame difference was negligible while the difference during the two intro cinematics (Sony and Sucker Punch) was huge, they both dropped from a solid 30fps to around 6fps, so ASMJIT clearly isn't beneficial for my setup.
2.) Disabling Thread Scheduler while enabling Lower SPU Priority seemed to give an fps boost when I first did these together but the boost wasn't permanent and disappeared the next time I loaded the game, then after some playing around with other settings I tried these two again and got the same boost, so I don't know if it is maybe related to something that was cached or not but these two options have promise, they just aren't consistent.  Sometimes the game runs faster, sometimes it does not.


I might follow this up with further experimentation in other titles unless I die from the virus.

krashd aka Rob


Forum Jump:


Users browsing this thread: 1 Guest(s)