Hello There, Guest! Register

Scott Pilgrim vs. The World: The Game [NPUB30162]
#81
is it normal to have invisible enemies from time to time??
Reply
#82
Game apparently runs great in both Vulkan and OpenGL, i can let the demo run for hours and "feels" ok. As soon as i press Start to start the game the whole emulator freezes.


Attached Files
.7z   RPCS3.7z (Size: 240.94 KB / Downloads: 2)
Reply
#83
Same here, running latest version of the emulator 0.0.9-9798-73a99462 with firmware 4.85 installed. Tried with both Vulkan and OpenGL with vertex shaders enabled and disabled, always freezes after pressing start at title screen. It used to work flawlessly on a previous version I was running.
Reply
#84
I run the game on Linux with Vulkan (Intel 620) setting for GPU. For some reason sprites in the game are a bit blurred and have outline. You can find them on the screenshot:
https://postimg.cc/nMMCn4mc
On OpenGL it looks alright, but I have in-game graphic issues with it.
https://postimg.cc/3WyJsKMk
Any ideas about blurred sprites and a outline on Vulkan?

RPCS3 Version: 0.0.9-10010-1ceb779a Alpha

Tried the same setup on the different laptop with Nvidia graphics: Vulkan output isn't blurred, but OpenGL on the integrated Intel suffers from the same issues.
Glitches around "Press Start" label and "Ubisoft Presents" (Linux + OpenGL + Intel):
https://postimg.cc/dZQSGKhP
In game is completely non-playable (Linux + OpenGL + Intel):
https://postimg.cc/k29GP1R6

In addition i tried to check previous versions of RPCS3 on Linux + Intel + OpenGL and was able to find few regressions:
rpcs3-v0.0.6-8089-8194c92f_linux64 - full and correct loading icon, gliches around labels, playable, no in-game glitches (but a bit slow)
rpcs3-v0.0.6-8537-9c64318e_linux64 - full and correct loading icon, gliches around labels, playable, but glitchy in-game
rpcs3-v0.0.6-8561-ec9b896f_linux64 - full but yellow loading icon, gliches around labels, playable, but glitchy in-game
rpcs3-v0.0.6-8608-64aff7f0_linux64 - half and yellow loading icon, gliches around labels, not playable in-game
rpcs3-v0.0.9-10023-158e34fa_linux64 - half and correct loading icon, gliches around labels, not playable in-game

Is this something that worth opening a issue on github or a combination Linux + Intel + OpenGL isn't a priority and it has no sense to do?
Reply
#85
Is there a trick to getting the emulator to save data for more than one player? I thought creating another user under Manage --> User Accounts might do the trick, but nothing works. Second player data isn't saving for me under the Guest account.
Reply
#86
Tried to run latest version of rpcs3 on latest Ubuntu (20.04) - Sprites on Vulkan are still look blurred, but OpenGL looks good, no glitches.
Really pity since I'm getting better performance on Vulkan.
Reply
#87
I got this game running on my PC flawlessly. Other than the occasional white line, the game runs great. No tears, stutters, bugs, etc. Almost constant 60 FPS. Now I'm wondering, would it be possible to do online co-op? The RPCS3 FAQ says that a small amount of games with simple network code have been tested to work. My question is, am I able to test this theory out with two computers myself using the latest build, or do I need to wait for an update before the emulator gives me the ability to try it out?
Reply
#88
Small trick: to get higher frame rate on a low-end pc set lowest available resolution (720x480) and check "Stretch To Display Area". It will allow you to play full screen with very minor scaling defects.

(04-11-2020, 08:13 PM)LemurThemepark Wrote: Is there a trick to getting the emulator to save data for more than one player? I thought creating another user under Manage --> User Accounts might do the trick, but nothing works. Second player data isn't saving for me under the Guest account.
Looks like that multiple accounts under the same game don't work yet:
Code:
U {PPU[0x1000000] Thread (main_thread) [0x01675110]} cellUserInfo TODO: cellUserInfoSelectUser_SetList(setList=*0x216c1060, funcSelect=*0x14596c8, container=0xffffffff, userdata=*0x216c0fe0)
U {PPU[0x1000000] Thread (main_thread) [0x01675120]} cellUserInfo TODO: cellUserInfoGetList(listNum=*0x216c10b4, listBuf=*0x216c1074, currentUserId=*0x216c1050)
E {PPU[0x1000010] Thread (ONYX Savegame) [0x016748e8]} cellSaveData: cellSaveDataUserAutoLoad(version=0, userId=0, dirName=“NPUB30162”, errDialog=0, setBuf=*0x227df3e0, funcStat=*0x14db328, funcFile=*0x14db3c8, container=0xffffffff, userdata=*0x227df2a0)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)