Hello There, Guest! Register

Tales of Xillia - [BLES01815]
#1
((Test on RPCS3 LLVM-aef5113d))

Interpreter(fast) & Interpreter(ASMJIT)
Better in OpenGL
--------------------
Movie : Slow
Graphic : Slow - Problem in Graphic
Music : Not Work
SaveGame : Work
LoadGame : Work



The Log File:-
BLES01815 - [Tales of Xillia] - File
___________________________________
CPU:- Intel I7-6800K @ 3.40 GHz (OverClock 4.5 GHz)
GPU:- GTX 1080
Motherboards:- ASUS X-99A-II
RAM:- 32.0 GB (2666 MHz)
Reply
#2
OpenGL, rpcs3-v0.0.2-2017-03-22-3bfe17a1_win64, PPU and SPU Recompiler

Crashing going into battle after load or on character select menu if new game.
With PPU Interpretor works, but FPS lower.
Reply
#3
(03-24-2017, 07:11 PM)Toriaizu Wrote: OpenGL, rpcs3-v0.0.2-2017-03-22-3bfe17a1_win64, PPU and SPU Recompiler

Crashing going into battle after load or on character select menu if new game.
With PPU Interpretor works, but FPS lower.

Old problem . I just try again. use rpcs3-v0.0.2-2017-06-30-6bd38ad7_win64.zip
Reply
#4
kd's latest changes fixed the minimap, controller buttons UI and battle UI numbers, as well as the character texture bug (the red lines).




Only text left to fix.
Reply
#5
For me, the biggest problem is the problem with the fonts, there is no text in the game - it's not interesting to play. And this problem is typical for most games of the series Thales of. ..
Very much I ask, if who or knows, in what a problem with fonts, write here. Thank you
Reply
#6
Ignoring the broken text in most Tales games, would they be playable otherwise? That is do they run "fast enough" and with no real bugs or crashes?
Reply
#7
Tales of Xillia 1 & 2 seem to run at full speed. even though they're far from 60 fps. Crashes would need in-depth testing, but those previously identified (like when Ludger wakes up, or at the end of a fight in ToX2) are fixed. Only other bug I can think of is the music stopping, but that's not major.
As for other Tales games, Vesperia has trap errors and is very slow overall, Graces f, Berseria and Zestiria don't reach the main menu, Symphonia Chronicles is playable.
Reply
#8
I can confirm that. With current build and kd's changes it runs in a good speed... in the beginning zones 20-30fps..

I locked the fps to 30 because it seems to impact the playspeed.. Without limit it is running at 60fps outside the battle (in the beginning) but it is too fast. In some foren I read that the framerate should be 30 fps outside of fight and 60fps in a fight but I can't confirm that.

Audio and fonts are still broken.. and sometimes you have boxes around the characters infight. But I think the map didn't work a few builds back them now it seems to work.
I didn't experience any crashes till now..

I used LLVM and SPU recompiler. 1280x720



Edit: I played a bit further.. some areas are running with 30-50fps.. some only with 20 like in the end of my video.. And I think the black box issues are lightning or shadow problems.. They are also appearing in ingame cutscenes

HyPeR
Reply
#9
Missing log / version with commit
Reply
#10
Photo 
Quote:E {rsx::thread} RSX: NV3089_IMAGE_IN_SIZE: unknown origin (0)
U {PPU[0x1000000] Thread (main_thread) [0x006e637c]} cellSysutil TODO: cellVideoOutConfigure(videoOut=0, config=*0xd00108c4, option=*0x0, waitForEvent=0)
U {PPU[0x1000007] Thread (CThread) [0x006e6648]} sceNpTrophy TODO: sceNpTrophyGetRequiredDiskSpace(context=0x1, handle=0x1, reqspace=*0xd0067bb0, options=0x0)
E {PPU[0x1000000] Thread (main_thread) [0x006e6490]} 'sys_ppu_thread_detach' failed with 0x80010005 : CELL_ESRCH [1]
E {PPU[0x1000000] Thread (main_thread) [0x006e64c4]} 'sys_ppu_thread_join' failed with 0x80010005 : CELL_ESRCH [1]
E {PPU[0x1000000] Thread (main_thread) [0x006e6490]} 'sys_ppu_thread_detach' failed with 0x80010005 : CELL_ESRCH [2]
S {rsx::thread} RSX: New program compiled successfully
E {PPU[0x1000000] Thread (main_thread) [0x00faeee4]} 'sys_fs_stat' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd0/game/BLES01815_INSTALL/USRDIR/FILEDATABASELOCAL.TLFDBX” [1]
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} PPU: LLVM: Loaded module v2-libadec.sprx-C1FA8E97F96CF507-skylake.obj
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} sys_prx: Loaded module: /dev_flash/sys/external/libadec.sprx
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} PPU: LLVM: Loaded module v2-libat3dec.sprx-CF7CA4764ADFE9E1-skylake.obj
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} sys_prx: Loaded module: /dev_flash/sys/external/libat3dec.sprx
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} PPU: LLVM: Loaded module v2-libatxdec.sprx-6D48FF4B62CB07E2-skylake.obj
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} sys_prx: Loaded module: /dev_flash/sys/external/libatxdec.sprx
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} PPU: LLVM: Loaded module v2-libatrac3plus.sprx-579A6F0C799EE900-skylake.obj
S {PPU[0x1000000] Thread (main_thread) [0x00f1a0c4]} sys_prx: Loaded module: /dev_flash/sys/external/libatrac3plus.sprx
U {PPU[0x1000000] Thread (main_thread) [0x00f7fd80]} sys_spu TODO: Unimplemented SPU Thread options (0x2)
U {PPU[0x1000000] Thread (main_thread) [0x00f85e58]} sys_prx TODO: _sys_prx_get_module_id_by_name(name=“cellLibprof”, flags=0, pOpt=*0x0)
E {PPU[0x1000000] Thread (main_thread) [0x00f85e58]} 'sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [2]
S {Audio Thread} XAudio 2.9 initialized
E {PPU[0x1000000] Thread (main_thread) [0x006e6490]} 'sys_ppu_thread_detach' failed with 0x80010002 : CELL_EINVAL [1]
E {PPU[0x100000e] Thread (CThread) [0x006e6648]} sceNpTrophy: sceNpTrophyRegisterContext(context=0x1, handle=0x1, statusCb=*0xdd8ee8, arg=*0x0, options=0x0)
E {PPU[0x1000000] Thread (main_thread) [0x006e64c4]} 'sys_ppu_thread_join' failed with 0x80010005 : CELL_ESRCH [2]
E {PPU[0x1000000] Thread (main_thread) [0x006e6490]} 'sys_ppu_thread_detach' failed with 0x80010005 : CELL_ESRCH [3]


  • RPCS 0.0.3.3-c7c0139 Alpha
  • Vulkan with Geforce GTX 970 @ 1080P able to run 30fps no issues. Agree with HyPeR that it's better locked to 30.
  • Music cuts in and out although menu sound/environment sounds seem fine along with voices
  • Garbled text but that's nothing new and shadows around the bottom of characters as below
[Image: cV8dtdb.png]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)