Hello There, Guest! Register

Atelier Rorona: The Alchemist of Arland [BLES01030]
#1
Tested on recent master build v0.0.1-35b7cf4 (PR #2309). Like other Atelier games, it's stuck on ingame cutscene.

LLE used
Code:
- libadec.prx
- libat3dec.prx
- libatrac3plus.prx
- libatxdec.prx
- libl10n.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx
- libfs.prx
- libfont.prx
- libfontFT.prx
- libfreetype.prx
- libfreetypeTT.prx
- libsail.prx
- libsail_avi.prx
- libsail_rec.prx
Reply
#2
Should be playable as of this PR. Someone confirm?
Reply
#3
Tried it with the build I downloaded yesterday.
Had to manually load libfs.sprx (+ auto selection).

Intro, main and ingame menu, and saving and loading work.
I only tried maybe 5 minutes into the game, but aside from missing textures everything seems to work so far. Music, menu sounds, walking around and dialogs seem to work. UI seems to be fine, as do a few 3D objects.

I'll try how far I can get with the missing textures when I have the time later today.

Edit: Had a few random crashes, one when trying to load a cutscene, which worked on the second try, and one trying to enter a battle.
Reply
#4
Graphics should be more or less flawless. What GPU? Update the drivers regardless. Also try OpenGL.
Reply
#5
GeForce GTX 960.

Just updated driver to latest (381.65), as well as RPCS3 (2017-04-20-463e18f8), no change, same problem in OpenGL.
Reply
#6
(04-23-2017, 05:40 PM)scidi Wrote: GeForce GTX 960.

Just updated driver to latest (381.65), as well as RPCS3 (2017-04-20-463e18f8), no change, same problem in OpenGL.

Probably using some strange WIP build. Use latest master version here: https://rpcs3.net/download
Reply
#7
Just checked, it is the latest master version as far as I can tell.
Edit: Got it from https://ci.appveyor.com/project/rpcs3/rp.../artifacts

I've added the log file in case it is any help, although I had to compress it because the forum wouldn't take it otherwise (it's a bit over 11 MB uncompresed).
Reply
#8
Due to multiple reports of random crashes I'm moving all PhyreEngine Atelier games to ingame for now.
Reply
#9
Game now shows textures correctly, there is no transparent textures as of 0.0.5.6601 (vulkan strict rendering, haven't tested other combinations yet), sometimes though the graphics go a bit corrupt outside strict rendering.
  • Physics now working too, can now open the atelier door, or click on people or the book.
  • FPS all over the place, between 7 and 60 range on Ryzen 1600x-390x in atelier/town. Dialog scenes around 45, walking around in atelier around 18-22, square street ┬áis 8-9fps.
  • Log shows a huge amount of "E {rsx::thread} RSX: failed to find section for render targert 0xC115E0000 + 0x7080000" and a few PPU errors (mutex locks mostly and a few sys_fs_stat failures for cell_enoent)
There doesn't appear to be anything majorly wrong, it seems fully playable albeit some audio, fps and outline issues. As long as the game is started new on pc, it will be fine, loading from real ps3 converted save file seems broken.

Issues I can see:
  • Speech and music are fine, sound effects are fuzzy and weird. 16bit audio override just breaks audio fully. possibly related to sub-60 fps?
  • Cartoon outline is not anti-aliased or seems a bit off, might be due to strict rendering, could be fixed via forcing antialiasing or similar.
  • FPS tanking a lot, even in scenes of not much on screen or being done. a faster pc might be fully playback, not mine though.
  • Loading a save file from an official PS3 copy doesn't work, it basically loads as if a new game in atelier albeit with broken physics (no object shows interaction icon, only rorona in party despite the save file having others, rorona is lvl1 despite being lvl 20-30+ in save file)


Attached Files Thumbnail(s)
                   
Reply
#10
This tanks to 15 fps on a real PS3 too Wink

But no random crashes? Like in the crafting menus or on loading screens and going in to and out of the world map? Ar Tonelico 3 still has these problems (identical engine, bugs otherwise etc).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)