Naruto Ultimate Ninja Storm Demo [NPEB90080]
Started by Ani




7 posts in this topic
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
01-31-2017, 12:47 AM -
#1
Tested on build 35b7cf4c
Requires a small hack on cellGame (you can download the hacked build here)

Change
Code:
s32 cellHddGameGetSizeKB()
{
    fmt::throw_exception("Unimplemented" HERE);
}
To
Code:
s32 cellHddGameGetSizeKB(vm::ptr<u32> size)
{
    cellGame.warning("cellHddGameGetSizeKB(): Unimplemented, returning 0");
    if (size)
    {
        *size = 0;
    }
    return CELL_OK;
}

Needed libraries:
- libdmux.prx
- libdmuxpamf.prx
- libpamf.prx
- libresc.prx
- libsail.prx
- libsre.prx
PPU Decoder: Interpreter (fast)
SPU Decoder: Interpreter (fast) / Recompiler (ASMJIT)

Screenshot:
http://i.imgur.com/ivQUSBd.jpg

Log:

    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
ShinpiKage
Guest


 
02-06-2017, 01:58 AM -
#2
so uhhh how do i access the game?
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
02-06-2017, 02:02 AM -
#3
(02-06-2017, 01:58 AM)ShinpiKage Wrote: so uhhh how do i access the game?

What do you mean by that?
Also, latest build has that hack so no need to do it yourself. Just boot the game with the indicated settings and you're good to go.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
Neilburst
Guest


 
03-07-2017, 06:46 AM -
#4
So i just try the hacked build and these setting but stuck after the opening scene
with this Error : F {rsx::thread} class gl::glsl::link_exception thrown: linkage failed: 'Attached fragment shader is not compiled.
how do i fix it sir?
Neilburst
Guest


 
03-07-2017, 06:51 AM -
#5
So.. i just try this game but got stuck after the opening scene and get this error

F {rsx::thread} class gl::glsl::link_exception thrown: linkage failed: 'Attached fragment shader is not compiled.

how can i fix that?
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
03-07-2017, 11:17 AM -
#6
You don't need the hacked build, use latest master and settings above. If it doesn't work attach rpcs3.log as an attachment to the post. Needs compression to zip, rar or 7z first.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
Neilburst
Guest


 
03-08-2017, 05:48 AM -
#7
Here is the log
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
03-11-2017, 12:25 PM -
#8
Your log is empty. If you reopen RPCS3 before getting the log it will reset it.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7


Forum Jump:


Users browsing this thread: 1 Guest(s)