Hello There, Guest! Register

Dai-2-Ji Super Robot Taisen OGs [BLJS10133]
#1
I can load pass the logos. And sometimes to the menu screen. All BGM - Sound work perfectly. But I can't finish the intro. It always hangs up at some point. And it also sometimes hangs on the Banpresto logo.
I used the massive LLE list from Catherin game (I don't really remember the name) and Dai-3-ji Super robot taisen Z (not 100% confirmed so need a little tweak)

But there are 2 problems:

1. The emulator sometimes stop processsing even though the FPS counter is still running and require me to pause and resume a few times (but not always) to make the emulator running again.
2. The results above only happen when the emulator freshly load the data on the HDD. After I stop the emulator or restart it will show the game data is broken.
Supported by ssshadow
Quote:Hmm, the log ends with two game messages:

·W {PPU[0x1000012] Thread (GameDataInstall) [0x00c3c4a8]} cellSysutil: cellMsgDialogOpen2(type=0x85, msgString=“??????????????
?????????????????????????
”, callback=*0xd3fef0, userData=*0xd01c7cb4, extParam=*0x0)
·W {PPU[0x1000012] Thread (GameDataInstall) [0x00c3c4a8]} cellSysutil: ??????????????
?????????????????????????

Google translate:
The game data is broken.
Please close the game and delete game data.
Which make me delete the data everytime and reload it onto the HDD again.

BTW: The game works normally using OpenGL. Vulkan/Dx12 has some issues with graphic bugs and blackscreens

P/S: There are 2 log files. The log file named "RPCS3-2" is the file that I tried to load the game recently with the newest build "527d9713".
The normal file is the one that I was able to load into the menu screen. But sadly I didn't take the screenshots.
Reply
#2
(01-30-2017, 05:30 AM)prokit Wrote: I can load pass the logos. And sometimes to the menu screen. All BGM - Sound work perfectly. But I can't finish the intro. It always hangs up at some point. And it also sometimes hangs on the Banpresto logo.
I used the massive LLE list from Catherin game (I don't really remember the name) and Dai-3-ji Super robot taisen Z (not 100% confirmed so need a little tweak)

But there are 2 problems:

1. The emulator sometimes stop processsing even though the FPS counter is still running and require me to pause and resume a few times (but not always) to make the emulator running again.
2. The results above only happen when the emulator freshly load the data on the HDD. After I stop the emulator or restart it will show the game data is broken.
Supported by ssshadow
Quote:Hmm, the log ends with two game messages:

·W {PPU[0x1000012] Thread (GameDataInstall) [0x00c3c4a8]} cellSysutil: cellMsgDialogOpen2(type=0x85, msgString=“??????????????
?????????????????????????
”, callback=*0xd3fef0, userData=*0xd01c7cb4, extParam=*0x0)
·W {PPU[0x1000012] Thread (GameDataInstall) [0x00c3c4a8]} cellSysutil: ??????????????
?????????????????????????

Google translate:
The game data is broken.
Please close the game and delete game data.
Which make me delete the data everytime and reload it onto the HDD again.

BTW: The game works normally using OpenGL. Vulkan/Dx12 has some issues with graphic bugs and blackscreens

P/S: There are 2 log files. The log file named "RPCS3-2" is the file that I tried to load the game recently with the newest build "527d9713".
The normal file is the one that I was able to load into the menu screen. But sadly I didn't take the screenshots.
you can use my LLE list below..

If it go in the game, please tell me.

E {PPU[0x1000006] Thread (GameThread) [0x00011f00]} PPU: 'sys_rwlock_runlock' aborted
F {PPU[0x1000006] Thread (GameThread) [0x00011f00]} class std::runtime_error thrown: Verification failed: cpu_flag:Confusedignal
(in file C:\rpcs3\rpcs3\Emu\CPU\CPUThread.cpp:130)
E {PPU[0x1000005] Thread (_gcm_intr_thread) [0x00012294]} 'sys_rwlock_wlock' failed with 0x80010008 : CELL_EDEADLK

This is err, What is wrong?

What is problem this game?
Reply
#3
[/quote]U {PPU[0x1000007] Thread (fios mediathread 2) [0x00f49ec0]} sys_fs TODO: sys_fs_fcntl(): Unknown operation 0xc0000006 (fd=4294967295, arg=*0xd015a8a8, size=0x20)
E {PPU[0x1000007] Thread (fios mediathread 2) [0x00f4aee4]} 'sys_fs_stat' failed with 0x8001003a : CELL_ENOTMOUNTED
Would like to ask this problem,please.
Reply
#4
You can edit posts so there's no need to double post. Also, don't post log spam directly on the thread and attach it like you just did.
Reply
#5
(02-10-2017, 12:38 AM)Annie Wrote: You can edit posts so there's no need to double post. Also, don't post log spam directly on the thread and attach it like you just did.
I see . this is my mistake, I am sorry.
Would like to ask this problem,please. The red code:
U {PPU[0x1000007] Thread (fios mediathread 2) [0x00f49ec0]} sys_fs TODO: sys_fs_fcntl(): Unknown operation 0xc0000006 (fd=4294967295, arg=*0xd015a8a8, size=0x20)
E {PPU[0x1000007] Thread (fios mediathread 2) [0x00f4aee4]} 'sys_fs_stat' failed with 0x8001003a : CELL_ENOTMOUNTED
Reply
#6
I tested game on latest build and got some intro gameplay with opengl only. With vulkan its crash after title screenn but if you use opengl you got some intro cutscenes. For og moon dwellers same (after title screen got some cutscene and crash).

decrypt all sdat first

lle

- libadec.sprx
- libat3dec.sprx
- libatrac3plus.sprx
- libatxdec.sprx
- libavcdec.sprx
- libdmux.sprx
- libdmuxpamf.sprx
- libfiber.sprx
- libfs.sprx
- libjpgdec.sprx
- libl10n.sprx
- libpamf.sprx
- libpngdec.sprx
- libresc.sprx
- librtc.sprx
- libsail.sprx
- libsail_avi.sprx
- libsail_rec.sprx
- libspurs_jq.sprx
- libsre.sprx

Don t sure but those lle compatible with moon dwellers too because i run it too on same lle. And yes sorry for i don t make screenshots because i can t get corrrect aspect ratio with opengl. Same bandicam and fraps make screenshots not correct, reflect all as mirror.

thanks to lle config onelight
Reply
#7
nstallation of Dai-2-Ji Super Robot Taisen OG will be a random problemF {rsx::thread} class std::runtime_error thrown: Invalid RSX method 0x4 (arg=0x0) (in file C:\rpcs3\rpcs3\Emu\RSX\rsx_methods.cpp:34)

F {rsx::thread} class std::runtime_error thrown: rsx::thread::ReadIO32(addr=0x1f000000): RSXIO memory not mapped (in file C:\rpcs3\rpcs3\Emu\RSX\RSXThread.cpp:1073)

F {PPU[0x1000001] Thread () [0x00a0b128]} class std::runtime_error thrown: Locking failed (lwmutex=*0x23414358, owner=0x1000000) (in file C:\rpcs3\rpcs3\Emu\Cell\Modules\sys_lwmutex_.cpp:160)

F {PPU[0x1000000] Thread (main_thread) [0x00a0b1a8]} class std::runtime_error thrown: Locking failed (lwmutex=*0x23414358, owner=0xfffffffc) (in file C:\rpcs3\rpcs3\Emu\Cell\Modules\sys_lwcond_.cpp:258)

F {rsx::thread} class std::runtime_error thrown: Invalid RSX method 0x8 (arg=0x41710) (in file C:\rpcs3\rpcs3\Emu\RSX\rsx_methods.cpp:34)

F {PPU[0x1000012] Thread (GameDataInstall) [0x00c3db28]} class std::runtime_error thrown: Locking failed (lwmutex=*0xd01c75d0, owner=0x100000a) (in file C:\rpcs3\rpcs3\Emu\Cell\Modules\sys_lwmutex_.cpp:16
Reply
#8
(02-27-2017, 05:59 PM)goku1988 Wrote: I tested game on latest build and got some intro gameplay with opengl only. With vulkan its crash after title screenn but if you use opengl you got some intro cutscenes. For og moon dwellers same (after title screen got some cutscene and crash).

decrypt all sdat first

lle

- libadec.sprx
- libat3dec.sprx
- libatrac3plus.sprx
- libatxdec.sprx
- libavcdec.sprx
- libdmux.sprx
- libdmuxpamf.sprx
- libfiber.sprx
- libfs.sprx
- libjpgdec.sprx
- libl10n.sprx
- libpamf.sprx
- libpngdec.sprx
- libresc.sprx
- librtc.sprx
- libsail.sprx
- libsail_avi.sprx
- libsail_rec.sprx
- libspurs_jq.sprx
- libsre.sprx

Don t sure but those lle compatible with moon dwellers too because i run it too on same lle. And yes sorry for i don t make screenshots because i can t get corrrect aspect ratio with opengl. Same bandicam and fraps make screenshots not correct, reflect all as mirror.

thanks to lle config onelight

Installation data is not resolved. See if this can be resolved this year.
Reply
#9
[youtube]3nf2X7ns7nA[/youtube]

[youtube]LO_dlyUCVBA[/youtube]

[youtube]3nf2X7ns7nA[/youtube]

[youtube]8aLSkBtT9VQ[/youtube]

[youtube]OkZCsE5ksoc[/youtube]

[youtube]wvc09ST2Erg[/youtube]
Reply
#10
God Bless the team.
Have the Data issue been fixed yet ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)