Hello There, Guest! Register

Metal Gear Solid: Peace Walker - HD Edition [NPEB00686]
#1
Screen is black and game have fps don't show anyting

Audio:
Convert to 16 bit: false
Dump to file: false
Renderer: XAudio2

Core:
Hook static functions: true
Load liblv2.sprx only: false

Load libraries:
- libac3dec.prx
- libadec.prx
- libapostsrc_mini.prx
- libatrac3plus.prx
- libavcdec.prx
- libdivxdec.prx
- libdmux.prx
- libfont.prx
- libfontFT.prx
- libfreetype.prx
- libfreetypeTT.prx
- libfs.prx
- libio.prx
- libjpgenc.prx
- libl10n.prx
- libmvcdec.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libsail.prx
- libsjvtd.prx
- libsmvd2.prx
- libsmvd4.prx
- libspurs_jq.prx
- libsre.prx
- libsvc1d.prx
- libvdec.prx
- libvpost.prx


PPU Decoder: Interpreter (precise)
SPU Decoder: Recompiler (ASMJIT)
Reply
#2
Playable, soon in master, i send log after pr merged in master Smile
[video=youtube]https://youtu.be/g5tIjNpWZp8[/video]
Reply
#3
Now that the PR #3022 is merged to master
MGS PW is playable just fine
Note that I am using the Us disc version while this is Eu PSN
but I figure it won't matter

Note: it still give a 60 fps black screen of nothing when using LLVM
so it works only with Interpreter Fast with 15-30 fps
and the only thing keeping it from mintaining its original 30 fps is the lack of llvm

Here is the log from last master
Reply
#4
Zangetsu didn't post the log.
fifazalata posted in wrong thread.

Still loadable until proper testing is made
Reply
#5
oops sorry i have forget add log after pr fix is merged
soon works also in lv2 only mode with gcm pr
Move in playable
Reply
#6
RPCS3 v0.0.3-11-b8776b8 Alpha
Intel® Core™ i5 CPU 750 @ 2.67GHz | 4 Threads | 8.00 GiB RAM
the game is working 15~30 vulkan Interpreter (fast) if you chose recompiler (llvm) you well get black screen
the audio is working but sometimes when ingame the audio just stop working but the game keep working just fine but no audio
i think you can move it to ingame
[video=youtube]https://youtu.be/rOE4CDR_kzM[/video]
Reply
#7
As far as I can tell the game is completely playable when using Interpreter (Fast). Runs fairly well on my system (i5-3570K at 4.5GHz, GTX 1060 6GB, 16GB RAM). Stays between 20-30 FPS at most times. LLVM currently results in the game being stuck on the first loading screen with the loading icon spinning endlessly. I created an issue on Github for this here.
Reply
#8
Is it full speed at 30 fps? If so, and it really seems playable, attach/link a log file so this can be moved up.
Reply
#9
It appears to run full speed at 30fps. Here's a quick recording I did.
[video=youtube]https://youtu.be/e8itgT-uxHk[/video]
I screwed up the stealth but just ran with it and died. I'm currently in chapter 2 of the game and have had no issues with it so I'd definitely consider it playable.

Here's a link to the log file since the forums won't let me attach it with a .txt or .log extension:
https://www.dropbox.com/s/i5zvpe5rfbhnxrw/RPCS3.log
Reply
#10
(08-21-2017, 12:29 AM)ssshadow Wrote: Is it full speed at 30 fps? If so, and it really seems playable, attach/link a log file so this can be moved up.

Yes, shadow.
From initial testing, he's right.
Request moving to Playable.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)