Hello There, Guest! Register

Metal Gear Solid: Peace Walker - HD Edition [NPEB00686]
#11
Moving.
Reply
#12
I'm getting a weird glitch. The game runs pretty well, but when the camera is angled to show the furthest available draw distance, first there are visual glitches, and then a total black screen. If I angle the camera pointed directly down, it's perfectly clear and the framerate is fine, but if I angle it horizontal to look across a map, just black.
Reply
#13
I used auto-loaded the libraries and the game looks very nice, only prob is the sounds. I have an echoing stuttering which ruins the whole experience. I experimented with all of the emu sound settings but had no luck
Reply
#14
Its playable but it seems that there might be an audio channel issue. I know sound issue was reported before but from what I can tell it seems that there is not enough defined resources or available channels for the audio.
Reply
#15
Once i'm past the control type selection screen, it just freezes on the map screen and says
F {PPU[0x100000c] Thread (GDV::RequestPool::Thread00) [0x01145400]} MEM: Access violation reading location 0x0

Any known fix for that?

EDIT:
rpcs3-v0.0.5-6649-7303f04b_win64 seems to have fixed it


Attached Files
.gz   RPCS3.log.gz (Size: 141.76 KB / Downloads: 10)
Reply
#16
(08-21-2017, 09:59 AM)fifazalata Wrote:
(08-21-2017, 12:29 AM)ssshadow Wrote: Is it full speed at 30 fps? If so, and it really seems playable, attach/link a log file so this can be moved up.

Yes, shadow.
From initial testing, he's right.
Request moving to Playable.

Very playable on RPCS3 v0.0.5-7018-345f92ab0 Alpha . 
Reply
#17
I'm not sure if it's my upgraded specs or a newer build, but I'm no longer getting audio stuttering.
Currently using RPCS3 v0.0.5-7321-52377791 Alpha.
AMD Ryzen 7 1700 @ 3.5GHz
GTX 1060 6GB
16GB DDR4 @ 3200MHz
Reply
#18
(01-28-2017, 03:05 AM)AAKH1361 Wrote: Screen is black and game have fps don't show anyting

Audio:
 Convert to 16 bit: false
 Dump to file: false
 Renderer: XAudio2

Core:
 Hook static functions: true
 Load liblv2.sprx only: false

Load libraries:
   - libac3dec.prx
   - libadec.prx
   - libapostsrc_mini.prx
   - libatrac3plus.prx
   - libavcdec.prx
   - libdivxdec.prx
   - libdmux.prx
   - libfont.prx
   - libfontFT.prx
   - libfreetype.prx
   - libfreetypeTT.prx
   - libfs.prx
   - libio.prx
   - libjpgenc.prx
   - libl10n.prx
   - libmvcdec.prx
   - libpamf.prx
   - libresc.prx
   - librtc.prx
   - libsail.prx
   - libsjvtd.prx
   - libsmvd2.prx
   - libsmvd4.prx
   - libspurs_jq.prx
   - libsre.prx
   - libsvc1d.prx
   - libvdec.prx
   - libvpost.prx


PPU Decoder: Interpreter (precise)
SPU Decoder: Recompiler (ASMJIT)
I did this but the PS4 controller does not work but in ohter games works. Any solutions? Thanks
Reply
#19
Don't follow settings from three years ago lol Those settings are horrible. You basically never want to use interpreters, and loadliblv2.sprx only is enough for 99% of games, no need to load individual modules.
Reply
#20
Just finished the game, and had no issues. The only thing I had to change was the renderer form OpenGL to Vulkan, and turn on Vsync to get rid of screen tearing.

Video by me:
[color=var(--newCommunityTheme-linkText)]https://www.youtube.com/watch?v=9pXRTyhF3LI&t=5s[/color]
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)