Hello There, Guest! Register

Time and Eternity [NPUB31189]
Interpreter 2
Recompiler ASMJIT (Also works with Interpreter (fast), starts up faster, no sound problems then)
Frame Limit: Auto

cellFiber_Library v1.1
cellSpursJq_Library v1.1
cellSre_Library v1.1
cellOskExtUtility_Library v1.1

Get's to the main menu. Music plays perfectly fine after a few startup problems. Button sounds work too. Crashes when trying to start a new game, after the settings menu.

{PPU Thread[0x10] (CThread)[0x00be0f54]} Exception:
(in file C:\rpcs3\rpcs3\Emu\SysCalls\Modules\cellSysutil.cpp:310, in function cellSysutilRegisterCallbackDispatcher)

cellOskExtUtility_Library v1.1 was necessary to get to the settings menu. Crashed without it when clicking on "New Game"

It hangs during the loading screen (no crash though, before actively stopping the emulation), when I add cellSysutil_Library v1.1. I attached both log files.

€: Tested a bit more.

cellFiber_Library v1.1
cellSpursJq_Library v1.1

Are not needed to get to the point where I was so far.
Game shows loading screen fast, but unfortunately stops loading at some point. I've tried adding libsysutil_np_thropy and libsysutil_np but it resulted in 0x0 read error

- libfs.prx
- libresc.prx
- librtc.prx

PPU Decoder: Interpreter (fast)
SPU Decoder: Recompiler (ASMJIT)
Renderer: Vulkan
You forgot to LLE libsre and spurs_jq... Like the last line of the log in your screenshot says.
I was sure that I tried with that, but nevermind. With 2(spurs_jp, sre) or 3(spurs_jp, sre, fs) more libs it goes much further.
Now goes ingame, but not always.

After first loading screen it should go to main menu automatically, but when progress bar disapper and nothing else is displayed after some time then pressing start should help(but not always).

When it went to main menu I've started new game, and typed in character name. Then it started doing sth and stopped. After that I turned off emu and started it again. From that moment in menu was available option for loading. And just like in video it leads to gameplay but there is not much of it Big Grin

Video: https://youtu.be/YICGgBh8mOk

Libs Used:
- libl10n.prx
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx

Log in attachment
On b407d12e build you can play through first section with heavy graphical glitches but at steady 30fps. After next loading screen game show only black screen. All settings same as before.
Duplicated thread.
There is high increase in performance on c1738cf (you can get 30FPS by the most of the time). Besides that nothing new, but if sb have a save with some progress then after swapping files maybe game will load further sections properly
Graphics are fixed now. Still goes to a neverending black screen after the Meet and Greet though.
It's finally possible to proceed after the Meet and Greet!

Cutscenes work almost perfectly. It stocks a tiny little bit sometimes. But not really a big deal.

Ingame there are small graphical glitches. You can sometimes see the outline of the sprites. Vulkan has more problems. Big black areas on the screen

Performance is fine. I am getting 30fps ingame with openGL. It seems like some cutscenes have slight performance problems. When going to the assassins guild I had brief slowdowns down to 10fps.

Saving and loading works.

Worldmap works.

I haven't played very much yet, but all in all I'd say playable.

OpenGL log attached.

Forum Jump:

Users browsing this thread: 1 Guest(s)