Hello There, Guest! Register

Angry Birds Trillogy [NPEB01235]
#1
Mod edit: See this post for appropriate settings: http://www.emunewz.net/forum/showthread....#pid239588


I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

Using Latest Appveyor Build.
Settings:
Interpreter 2, Interpreter (fast)
DX12 Auto frame limit, OpenAL
Networking: Disconnected.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Video Proof:
https://youtu.be/epfpaP1RXSU
Reply
#2
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: The Game Boots up into loading screens, And Title screens.

Then it's not for the Playable, it's for the Intro ones.
Also, uploading a log is mandatory AFAIK and you didn't specify any of your settings.
And yet, the GameID shouldn't have a dash in the middle. Just [NPEB01235]

Also 72277b2 is from my fork (??) and not from RPCS3's master branch
You should download from here https://ci.appveyor.com/project/rpcs3/rp.../artifacts
Reply
#3
(03-13-2016, 03:02 PM)Annie Wrote:
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: The Game Boots up into loading screens, And Title screens.

Then it's not for the Playable, it's for the Intro ones.
Also, uploading a log is mandatory AFAIK and you didn't specify any of your settings.
And yet, the GameID shouldn't have a dash in the middle. Just [NPEB01235].

Updated the log above, and will input settings
Reply
#4
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Please consult the submission guidelines. I have corrected the title and moved it to the right section.
Also quite interesting - it's trying to execute sys_gamepad_ycon_if.
Reply
#5
(03-13-2016, 03:09 PM)tambre Wrote:
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Please consult the submission guidelines. I have corrected the title and moved it to the right section.
Also quite interesting - it's trying to execute sys_gamepad_ycon_if.

Correct. No idea what module that would come under though?

Testing with different settings now and will upload videos testing different scenarios shortly to youtube.

also noted that was Annie's build and will be using the Appveyor builds from the official branch to test.
Reply
#6
(03-13-2016, 03:23 PM)xXBeefyDjXx Wrote:
(03-13-2016, 03:09 PM)tambre Wrote:
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Please consult the submission guidelines. I have corrected the title and moved it to the right section.
Also quite interesting - it's trying to execute sys_gamepad_ycon_if.

Correct. No idea what module that would come under though?

Testing with different settings now and will upload videos testing different scenarios shortly to youtube.

also noted that was Annie's build and will be using the Appveyor builds from the official branch to test.

That's a system call. It can't be LLE'd. Please also keep in mind when testing, that LLE'ing quite a few libraries won't work.
Reply
#7
(03-13-2016, 03:23 PM)xXBeefyDjXx Wrote:
(03-13-2016, 03:09 PM)tambre Wrote:
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Please consult the submission guidelines. I have corrected the title and moved it to the right section.
Also quite interesting - it's trying to execute sys_gamepad_ycon_if.

Correct. No idea what module that would come under though?

Testing with different settings now and will upload videos testing different scenarios shortly to youtube.

also noted that was Annie's build and will be using the Appveyor builds from the official branch to test.

That's a system call afaik, nothing you can LLE.
I tried running the game with the modules and settings you stated above and all I get is a black screen ending on an exception.
Currently on Visual Studio 2015 trying to get a StackTrace.
Reply
#8
(03-13-2016, 03:27 PM)Annie Wrote:
(03-13-2016, 03:23 PM)xXBeefyDjXx Wrote:
(03-13-2016, 03:09 PM)tambre Wrote:
(03-13-2016, 03:00 PM)xXBeefyDjXx Wrote: I have managed to get Angry Birds Trilogy [NPEB-01235] To work..

The Game Boots up into loading screens, And Title screens.

Pressing start allows menu loads, and then into cutscreens.

I will upload logs now, and Video later today.

LLEs Used:
cellCamera_Lib
cellFiber_lib
libgem
cellHttp_lib
cellSre_lib

Please consult the submission guidelines. I have corrected the title and moved it to the right section.
Also quite interesting - it's trying to execute sys_gamepad_ycon_if.

Correct. No idea what module that would come under though?

Testing with different settings now and will upload videos testing different scenarios shortly to youtube.

also noted that was Annie's build and will be using the Appveyor builds from the official branch to test.

That's a system call afaik, nothing you can LLE.
I tried running the game with the modules and settings you stated above and all I get is a black screen ending on an exception.
Currently on Visual Studio 2015 trying to get a StackTrace.

Video uploading now should give you guys a better insight into the way rpcs3 wants to handle itself
Reply
#9
Uploaded
Reply
#10
Update: The final error message It gives from My testing is
error X3037: constructors only defined for numeric base types

As shown in log attached here.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)