Catherine [BLUS30428]
Started by ssshadow




174 posts in this topic
master94ga
Guest


 
06-05-2017, 08:30 PM -
(05-26-2017, 01:54 PM)Annie Wrote: XAudio2 + PPU LLVM + SPU ASMJIT / Fast + Vulkan + Lower SPU thread priority and test with Bind SPU to secondary cores on/off to see what works better for you
I'm using this settings and I get cracking audio. I'm on W10, with R5 1600x, Rx 480 and 8GB of ram.
Beep-boop
Guest


 
06-06-2017, 01:07 PM -
The game runs fine, but after the first level the screen goes black and nothing happens. Any suggestions? I assume it has to do something with the trophies.
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
06-07-2017, 05:35 PM -
(06-06-2017, 01:07 PM)Beep-boop Wrote: The game runs fine, but after the first level the screen goes black and nothing happens. Any suggestions? I assume it has to do something with the trophies.

Use PPU LLVM.

Maybe SPU interpreter (fast).
Beep-boop
Guest


 
06-08-2017, 09:07 PM -
(06-07-2017, 05:35 PM)ssshadow Wrote:
(06-06-2017, 01:07 PM)Beep-boop Wrote: The game runs fine, but after the first level the screen goes black and nothing happens. Any suggestions? I assume it has to do something with the trophies.

Use PPU LLVM.

Maybe SPU interpreter (fast).

Tried that, it got even worse.
LLVM + interpreter (fast) doesn't even open menu
LLVM + ASMJIT cuts sound at the menu and doesn't get me past the difficulty selection
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
06-09-2017, 01:02 PM -
(06-08-2017, 09:07 PM)Beep-boop Wrote:
(06-07-2017, 05:35 PM)ssshadow Wrote:
(06-06-2017, 01:07 PM)Beep-boop Wrote: The game runs fine, but after the first level the screen goes black and nothing happens. Any suggestions? I assume it has to do something with the trophies.

Use PPU LLVM.

Maybe SPU interpreter (fast).

Tried that, it got even worse.
LLVM + interpreter (fast) doesn't even open menu
LLVM + ASMJIT cuts sound at the menu and doesn't get me past the difficulty selection

So this is the real error:
Code:
·E 0:01:22.718118 {PPU[0x1000011] Thread (_cellsurMixerMain) [0x00acfef8]} 'sys_mutex_unlock' failed with 0x80010009 : CELL_EPERM

Here the sound thread dies and as soon as the game tries to change which music is playing or whatever it waits forever for this thread, that is it hangs.

This is a thread synchronization bug, one of if not the hardest class of bugs to track down. It depends on timing, a faster or slower CPU will change the probability of it happening.
Beep-boop
Guest


 
06-10-2017, 10:14 AM -
(06-09-2017, 01:02 PM)ssshadow Wrote:
(06-08-2017, 09:07 PM)Beep-boop Wrote:
(06-07-2017, 05:35 PM)ssshadow Wrote:
(06-06-2017, 01:07 PM)Beep-boop Wrote: The game runs fine, but after the first level the screen goes black and nothing happens. Any suggestions? I assume it has to do something with the trophies.

Use PPU LLVM.

Maybe SPU interpreter (fast).

Tried that, it got even worse.
LLVM + interpreter (fast) doesn't even open menu
LLVM + ASMJIT cuts sound at the menu and doesn't get me past the difficulty selection

So this is the real error:
Code:
·E 0:01:22.718118 {PPU[0x1000011] Thread (_cellsurMixerMain) [0x00acfef8]} 'sys_mutex_unlock' failed with 0x80010009 : CELL_EPERM

Here the sound thread dies and as soon as the game tries to change which music is playing or whatever it waits forever for this thread, that is it hangs.

This is a thread synchronization bug, one of if not the hardest class of bugs to track down. It depends on timing, a faster or slower CPU will change the probability of it happening.

So no Catherine for me unless I change my PC? Well anyway, thanks for your help
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
06-10-2017, 10:14 PM -
(06-10-2017, 10:14 AM)Beep-boop Wrote:
(06-09-2017, 01:02 PM)ssshadow Wrote:
(06-08-2017, 09:07 PM)Beep-boop Wrote:
(06-07-2017, 05:35 PM)ssshadow Wrote: Use PPU LLVM.

Maybe SPU interpreter (fast).

Tried that, it got even worse.
LLVM + interpreter (fast) doesn't even open menu
LLVM + ASMJIT cuts sound at the menu and doesn't get me past the difficulty selection

So this is the real error:
Code:
·E 0:01:22.718118 {PPU[0x1000011] Thread (_cellsurMixerMain) [0x00acfef8]} 'sys_mutex_unlock' failed with 0x80010009 : CELL_EPERM

Here the sound thread dies and as soon as the game tries to change which music is playing or whatever it waits forever for this thread, that is it hangs.

This is a thread synchronization bug, one of if not the hardest class of bugs to track down. It depends on timing, a faster or slower CPU will change the probability of it happening.

So no Catherine for me unless I change my PC? Well anyway, thanks for your help

Well random changes will randomly alter timing. Of course the bug should be properly fixed on our end.
Belegarsson
Guest


 
07-15-2017, 01:49 PM -
The game runs flawlessly for me but I have a pretty weird bug where subtitles randomly missing some letters. Is this source data issue?

[Image: uYxULwI.png]
Ani
Administrator
*******


8
3,087 posts 75 threads Joined: Aug 2017
07-15-2017, 05:28 PM -
Enable strict mode rendering on GPU settings. This should only be used on cases like those where parts of the game are missing, because it impacts performance.
jhackler
Guest


 
07-21-2017, 05:27 PM -
For me game acts like it is launching says it is running but never produces a graphics window. Hatsune miku works fine on my system though. Using llvm on both and default setting with vulkan. ryzen 7 1600 @ 3.6ghz and rx 470 and 16 gb of ram at 2933


Forum Jump:


Users browsing this thread: 1 Guest(s)