Hello There, Guest! Register

Catherine [BLUS30428]
#91
Would it matter if I used the version I bought from the PSN instead of the version I dumped off my game disc?
Reply
#92
This thread is about the US disc version "BLUS30428" and that is what was tested, so yes it could matter. Historically the PSN version didn't even boot but I guess the PSN fixes for Demon's Souls helped it...

Maybe it was already mentioned, but surely the game runs stable (and slow) with PPU and SPU interpreters at least?
Reply
#93
(03-23-2017, 11:23 PM)ssshadow Wrote: This thread is about the US disc version "BLUS30428" and that is what was tested, so yes it could matter. Historically the PSN version didn't even boot but I guess the PSN fixes for Demon's Souls helped it...

Maybe it was already mentioned, but surely the game runs stable (and slow) with PPU and SPU interpreters at least?

Yes I have nearly always 30 FPS with no graphics or sounds glitches with PPU and SPU Fast interpreters and DX12, and no freeze at all, but recompilers are laggy and sounds are crackly and sometimes the sounds stop and the game don't load any further screens than the main menu
Reply
#94
(03-24-2017, 12:00 AM)fenix71 Wrote:
(03-23-2017, 11:23 PM)ssshadow Wrote: This thread is about the US disc version "BLUS30428" and that is what was tested, so yes it could matter. Historically the PSN version didn't even boot but I guess the PSN fixes for Demon's Souls helped it...

Maybe it was already mentioned, but surely the game runs stable (and slow) with PPU and SPU interpreters at least?

Yes I have nearly always 30 FPS with no graphics or sounds glitches with PPU and SPU Fast interpreters and DX12, and no freeze at all, but recompilers are laggy and sounds are crackly and sometimes the sounds stop and the game don't load any further screens than the main menu

Must be some really unfortunate sync issue. But at least the game runs at full speed for you regardless Smile
Reply
#95
I get a new error now that I changed the thing to "sandybridge":

Quote:---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC000001D.
Exception address: 00000000122014db.
Instruction address: 00000000122014db.
Function address: 00000000122013f0 (base+0x22013f0).
RPCS3 image base: 0000000000010000.

Illegal instruction exception occured.
Note that your CPU must support SSSE3 extension.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------

Edit: Forgot to include the log file.
Reply
#96
Then whatever CPU you have isn't entirely compatible with the instruction set of a Sandy Bridge. Maybe "generic" instead of "sandybridge".

But not that this seems to fix anything as said above...
Reply
#97
---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000000000018 at 000000000059a934.
Instruction address: 000000000059a934.
Function address: 000000000059a910 (base+0x58a910).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------




Is that normal ?
Reply
#98
(03-30-2017, 11:43 AM)Sakimotor Wrote: ---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000000000018 at 000000000059a934.
Instruction address: 000000000059a934.
Function address: 000000000059a910 (base+0x58a910).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------




Is that normal ?

Seems like some bad luck there... Maybe the SPU or PPU interpreter will work. Could be too slow, but start by testing them.

Trying OpenGL/Vulkan/DX12 could also make a difference.
Reply
#99
(03-30-2017, 12:32 PM)ssshadow Wrote:
(03-30-2017, 11:43 AM)Sakimotor Wrote: ---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000000000018 at 000000000059a934.
Instruction address: 000000000059a934.
Function address: 000000000059a910 (base+0x58a910).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------




Is that normal ?

Seems like some bad luck there... Maybe the SPU or PPU interpreter will work. Could be too slow, but start by testing them.

Trying OpenGL/Vulkan/DX12 could also make a difference.

Just tried all of them and putting both fast interpreter on PPU and SPU makes my game hang on the black screen after Atlus logo
Reply
(03-30-2017, 12:48 PM)Sakimotor Wrote:
(03-30-2017, 12:32 PM)ssshadow Wrote:
(03-30-2017, 11:43 AM)Sakimotor Wrote: ---------------------------
Fatal error
---------------------------
Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000000000018 at 000000000059a934.
Instruction address: 000000000059a934.
Function address: 000000000059a910 (base+0x58a910).
Module name: 'rpcs3.exe'.
Module base: 0000000000010000.
RPCS3 image base: 0000000000010000.

HOW TO REPORT ERRORS: Check the FAQ, README, other sources.
Please, don't send incorrect reports. Thanks for understanding.
Press (Ctrl+C) to copy this message.
---------------------------
OK
---------------------------




Is that normal ?

Seems like some bad luck there... Maybe the SPU or PPU interpreter will work. Could be too slow, but start by testing them.

Trying OpenGL/Vulkan/DX12 could also make a difference.

Just tried all of them and putting both fast interpreter on PPU and SPU makes my game hang on the black screen after Atlus logo

Did you install the latest firmware version from the Sony website? 4.81 I think.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)