Atelier Meruru: The Apprentice of Arland [BLES01593]
Started by ssshadow




42 posts in this topic
Nezarn
Guest


 
09-22-2016, 09:46 PM -
#21
Im sure its the same problem with these games, since they are using the same engine, and are from the same devs.
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
09-23-2016, 10:09 AM -
#22
(09-22-2016, 09:14 PM)rauldj Wrote:
(09-22-2016, 08:34 PM)ssshadow Wrote: Since you have a much faster computer than me try starting a new game a few times and see if you get anything. I suspect that Ayesha just has the exact same black screen of death bug as the other Ateliers and Ar Tonelico 3, and it seems random when they hang. If it's a thread synchronization issue it might work better (or worse) for you.

The furthest I can reach is this intro scene were the camera just pans until you stop the emulation, similar to what happens randomly, at least to me, with Totori.

Is it the same problem Ar tonelico has when the text boxes of dialogue just stop showing, a character loops its animation endlessly or the screen just goes black?

As said, it seems like the exact same issue. And also, you got further than me. I have never actually seen any in game graphics in Ayesha. Maybe you got lucky, or maybe a faster CPU helps... I hope this is a bug in the emulator, but it could also be a bug in the game where some threads hangs because everything is running so slow, aka a deadlock.
rauldj
Guest


 
10-02-2016, 12:07 PM -
#23
Something happened with the Koei-Tecmo Atelier's in the recent builds that makes certain colors flash in a strange way.
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
10-02-2016, 04:51 PM -
#24
(10-02-2016, 12:07 PM)rauldj Wrote: Something happened with the Koei-Tecmo Atelier's in the recent builds that makes certain colors flash in a strange way.

Probably this new bug: https://github.com/RPCS3/rpcs3/issues/2178

Someone should state that it affects Atelier there.
rauldj
Guest


 
10-04-2016, 02:51 PM -
#25
Seems fixed on rpcs3-ReleaseLLVM-7a9841bb.
Rain_Kikyou
Guest


 
10-23-2016, 12:03 PM -
#26
(10-04-2016, 02:51 PM)rauldj Wrote: Seems fixed on rpcs3-ReleaseLLVM-7a9841bb.
In fact, no
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
10-23-2016, 12:30 PM -
#27
(10-23-2016, 12:03 PM)Rain_Kikyou Wrote:
(10-04-2016, 02:51 PM)rauldj Wrote: Seems fixed on rpcs3-ReleaseLLVM-7a9841bb.
In fact, no

He was talking about this bug that made everything in the game black and white.

That said the sky in your video is still back and white... My computer is too slow to get that far in the game. You can help to debug this
  • Download: https://renderdoc.org/builds
  • Start renderdocui.exe. Under "capture executable" select rpcs3.exe in "executable path" and then press capture.
  • In rpcs3 config -> settings -> graphics -> legacy OpenGL buffers ON.
  • Start the game, when you get to the black and white sky, press print screen on the keyboard. Renderdoc will capture technical information about the scene.
  • ctrl+s to save and you will get a .rdc file. Upload it somewhere and share it please.
Rain_Kikyou
Guest


 
10-23-2016, 01:55 PM -
#28
(10-23-2016, 12:30 PM)ssshadow Wrote:
(10-23-2016, 12:03 PM)Rain_Kikyou Wrote:
(10-04-2016, 02:51 PM)rauldj Wrote: Seems fixed on rpcs3-ReleaseLLVM-7a9841bb.
In fact, no

He was talking about this bug that made everything in the game black and white.

That said the sky in your video is still back and white... My computer is too slow to get that far in the game. You can help to debug this
  • Download: https://renderdoc.org/builds
  • Start renderdocui.exe. Under "capture executable" select rpcs3.exe in "executable path" and then press capture.
  • In rpcs3 config -> settings -> graphics -> legacy OpenGL buffers ON.
  • Start the game, when you get to the black and white sky, press print screen on the keyboard. Renderdoc will capture technical information about the scene.
  • ctrl+s to save and you will get a .rdc file. Upload it somewhere and share it please.

Thanks, but bad luck to capture the time is always not into the scene

I finally succeeded ...
https://drive.google.com/open?id=0B4z-S0...y1wTndyQVk
kd-11
RPCS3 Developer


0
75 posts 1 threads Joined: Aug 2017
10-24-2016, 09:42 AM -
#29
Does it work on vulkan or dx12? Something seems wrong with the vertex attributes since alot of drawcalls and several thousand triangles seem to just generate that wierd pillar thing in the middle. A screenshot of what this scene looks like on a real ps3 would be really helpful.

EDIT: Actually, after watching some youtube plays of this, it seems the structures are submitted broken and they form the pillar thing in the center of the screen instead of buildings. I'm leaning toward broken attribs.
Rain_Kikyou
Guest


 
10-24-2016, 10:00 AM -
#30
(10-24-2016, 09:42 AM)kd-11 Wrote: Does it work on vulkan or dx12? Something seems wrong with the vertex attributes since alot of drawcalls and several thousand triangles seem to just generate that wierd pillar thing in the middle. A screenshot of what this scene looks like on a real ps3 would be really helpful.

EDIT: Actually, after watching some youtube plays of this, it seems the structures are submitted broken and they form the pillar thing in the center of the screen instead of buildings. I'm leaning toward broken attribs.

OpenGL / vulkan / dx12 can work and graphics problems are the same


Forum Jump:


Users browsing this thread: 1 Guest(s)