Hello There, Guest! Register

Soul Calibur 4 [BLUS30160]
#1
Couldn't find a thread of this game ( I used search option, if I'm wrong, please correct me ), so I made a new thread. Seems playable, although slow and with no sound.

v 65fe9b0
Interpreter (fast)
Recompiler (ASMJIT)

libfiber
libresc
librtc
libspurs_jq
libsre
libsync2
Reply
#2
More screenshots.
https://postimg.org/image/5pp2so0h5/
https://postimg.org/image/9tyus55bz/
https://postimg.org/image/jkw01nenj/
https://postimg.org/image/o1syqgysf/
https://postimg.org/image/fzmkgyf8v/
https://postimg.org/image/j8nfs0ffd/
https://postimg.org/image/5ngudpivz/
https://postimg.org/image/iipz3hjpb/
Reply
#3
This is my test, other are pretty good, but unfortunately the number of frames is too poor

Reply
#4
https://www.youtube.com/watch?v=xtb4yb6w_2o

Just sharing..
all info are in the description but i will post here anyway xD

60 Fps during the stage presentation ..
57 Fps during Character presentation ..
25-30 Fps in battle ..
Cpu fault .. i'm sure of it ^^

MSI-Afterburner doesn't work .. that's why the fps are not showing ..

BLUS30160-[Soulcalibur IV]
GPU: GeForce GTX 1060 6GB
CPU: AMD FX-8370 Eight-Core Processor
Memory: 16 GB RAM
Operational System: Microsoft Windows 10 Pro

Rpcs3-v0.0.4-2018-01-06-d770a423_win64
GPU
Renderer: Vulkan
Anisotropic Filter: 16x
Resolution Scale: 300% (3840x2160)
Resolution Scale Threshould: 16x16 (Default)
Additional Settings:
Use GPU Texture Scaling
Stretch To Display Area

CPU
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Prefered SPU Threads: Auto
Firmware Settings: Load liblv2.sprx only
Additional Settings: Enable SPU loop detection

i'm sorry if i breaked any rule, that was not my intention..
sorry for my english too, noob brazilian here ^^

audio is poor.. :/
Reply
#5
I've gotten it to run fairly well, with some slight audio issues, and fps drops every now and then. However, using Vulkan, it actually runs a little too fast sometimes. With OpenGL, it runs okay, but a little too slow. Does anybody know any settings that might stabilize it to normal speed?

My specs:
GPU: GeForce GTX 960 2GB
CPU: AMD FX-8350 8-Core Processor
Memory: 16 GB
OS: Windows 10

My settings:
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: 2
Additional Settings: Enable SPU loop detection

Renderer: Vulkan
Aspect Ratio: 16:9
Framelimit: Off
Antisopteric filter: Automatic
Default Resolution: 1280x720
Resolution Scale: 300%
Resolution Scale Threshold: 1x1
Additional Settings: Use GPU Texture Scaling
Reply
#6
(01-31-2018, 11:32 PM)Jackofblaze Wrote: I've gotten it to run fairly well, with some slight audio issues, and fps drops every now and then. However, using Vulkan, it actually runs a little too fast sometimes. With OpenGL, it runs okay, but a little too slow. Does anybody know any settings that might stabilize it to normal speed?

My specs:
GPU: GeForce GTX 960 2GB
CPU: AMD FX-8350 8-Core Processor
Memory: 16 GB
OS: Windows 10

My settings:
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: 2
Additional Settings: Enable SPU loop detection

Renderer: Vulkan
Aspect Ratio: 16:9
Framelimit: Off
Antisopteric filter: Automatic
Default Resolution: 1280x720
Resolution Scale: 300%
Resolution Scale Threshold: 1x1
Additional Settings: Use GPU Texture Scaling

H-hey there xD
so, you can run it at 60 Fps ? in battle ? you have a Gtx 960, record it with Shadowplay, upload on youtube then post the link here or something..
my fps in battle is really low, 25, 30 Fps at the best..

i think my FX 8370 is the problem here..
Reply
#7
(02-17-2018, 02:42 PM)Celio1080p Wrote:
(01-31-2018, 11:32 PM)Jackofblaze Wrote: I've gotten it to run fairly well, with some slight audio issues, and fps drops every now and then. However, using Vulkan, it actually runs a little too fast sometimes. With OpenGL, it runs okay, but a little too slow. Does anybody know any settings that might stabilize it to normal speed?

My specs:
GPU: GeForce GTX 960 2GB
CPU: AMD FX-8350 8-Core Processor
Memory: 16 GB
OS: Windows 10

My settings:
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: 2
Additional Settings: Enable SPU loop detection

Renderer: Vulkan
Aspect Ratio: 16:9
Framelimit: Off
Antisopteric filter: Automatic
Default Resolution: 1280x720
Resolution Scale: 300%
Resolution Scale Threshold: 1x1
Additional Settings: Use GPU Texture Scaling

H-hey there xD
so, you can run it at 60 Fps ? in battle ? you have a Gtx 960, record it with Shadowplay, upload on youtube then post the link here or something..
my fps in battle is really low, 25, 30 Fps at the best..

i think my FX 8370 is the problem here..

Nah, I'm not running 60 fps, I'm running it about as well as you in battle. By fairly well I meant it's good enough that I'm comfortable playing it like that, but it's not perfect performance.
Reply
#8
FX Cpu's aren't exactly known for their performance
Reply
#9
(02-19-2018, 03:13 AM)Jackofblaze Wrote:
(02-17-2018, 02:42 PM)Celio1080p Wrote:
(01-31-2018, 11:32 PM)Jackofblaze Wrote: I've gotten it to run fairly well, with some slight audio issues, and fps drops every now and then. However, using Vulkan, it actually runs a little too fast sometimes. With OpenGL, it runs okay, but a little too slow. Does anybody know any settings that might stabilize it to normal speed?

My specs:
GPU: GeForce GTX 960 2GB
CPU: AMD FX-8350 8-Core Processor
Memory: 16 GB
OS: Windows 10

My settings:
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: 2
Additional Settings: Enable SPU loop detection

Renderer: Vulkan
Aspect Ratio: 16:9
Framelimit: Off
Antisopteric filter: Automatic
Default Resolution: 1280x720
Resolution Scale: 300%
Resolution Scale Threshold: 1x1
Additional Settings: Use GPU Texture Scaling

H-hey there xD
so, you can run it at 60 Fps ? in battle ? you have a Gtx 960, record it with Shadowplay, upload on youtube then post the link here or something..
my fps in battle is really low, 25, 30 Fps at the best..

i think my FX 8370 is the problem here..

Nah, I'm not running 60 fps, I'm running it about as well as you in battle. By fairly well I meant it's good enough that I'm comfortable playing it like that, but it's not perfect performance.

(02-19-2018, 10:37 AM)Asinine Wrote: FX Cpu's aren't exactly known for their performance

Ohh i see, ok, thank you very much guys xD

sad here.. ahaha..
Reply
#10
Hey everybody, first post here and big SC fan. I registered just to post this!

Build: RPCS3 0.0.5-6694-25ec899cf Alpha

My specs:
GPU: GeForce GTX 1080 8 GB
CPU: Intel i7-7700k 4.2 GHz
Memory: 32 GB
OS: Windows 10

My settings:
PPU Decoder: Recompiler (LLVM)
SPU Decoder: Recompiler (ASMJIT)
Firmware Settings: Load liblv2.sprx only
Preferred SPU Threads: 2
Additional Settings: Enable Thread Scheduler, Hook Static Functions
Renderer: Vulkan
Aspect Ratio: 16:9
Framelimit: 60
Anisotropic filter: Automatic
Default Resolution: 1280x720
Resolution Scale: 150% (1920x1080)
Resolution Scale Threshold: 1x1
Additional Settings: Stretch to Display Area, Use GPU Texture Scaling

60 fps all the time, in the opening, in the menus, and most importantly, in battle! The audio is a LITTLE choppy for me at times, but very bearable. Completed Story Mode a few times, but it seems to randomly, but seldomly, crash when battles finish and cutscenes begin.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)