Hello There, Guest! Register

Jak and Daxter Collection [BCUS98281]
#1
Game:Jak and Daxter Collection
ID: BCUS98281

Build: RPCS3 v0.0.1-3-fc56e70

Settings:
-PPU - Interpreter precise
-SPU - Recompiler ASMJIT
-OpenGL / D3D12 / Vulkan
-1280x720
-VSync
-XAudio

LLE:
-cellPngDec_Library
-cellSpursJq_Library
-cellSre_Library

-I got main menu using D3D12 / OpenGL.
-Vulkan plays audio and you can hear that you can control in the main menu, but it shows only a black screen for the intro and main menu.

-With OpenGL and D3D12 you will see the credits background for a second when you hover on the credits text.

-The audio comes in about 3 seconds in the main menu for all the backends.

-The speed is weard, because the audio speed is good and it is 60 fps but it looks like ingame the speed goes much faster than the normal speed of the game.

-It crashes when you choose a game.
F LDR: class std::runtime_error thrown: vm::falloc() failed (addr=0x20000000, memsz=0x4000000)

- Somethings it won't start, but when i manually remove the cache for this game, than it works again.

-Logs and screenshots are in the attachment.
Reply
#2
Does every game in the collection have its own executable? What happens when you load those instead?
Reply
#3
You can load libsail (and libsail_avi)
Reply
#4
(08-12-2016, 06:56 PM)Annie Wrote: You can load libsail (and libsail_avi)


Build used: RPCS3 v0.0.01-3-2d51212 Pre-Alpha
For all backends with lle libsail (and libsail_avi) I got no further than the intro, so no main menu (see attachment).

U {PPU[0x8000000d] Thread (_libsail-control) [0x004ea3bc]} cellPamf TODO: cellPamfReaderInitialize(): verification
U {PPU[0x8000000d] Thread (_libsail-control) [0x004ea3dc]} cellPamf TODO: cellPamfReaderGetNumberOfEp(pSelf=*0x20a3ecb0)
E {PPU[0x8000000d] Thread (_libsail-control) [0x0008e8fc]} cellGcmSys: cellGcmMapMainMemory: CELL_GCM_ERROR_NO_IO_PAGE_TABLE

F {rsx::thread} class std::runtime_error thrown: rsx::thread::ReadIO32(addr=0x34eff0): RSXIO memory not mapped
(in file C:\rpcs3\rpcs3\Emu\RSX\RSXThread.cpp:932)



Without libail (and libail_avi) i still got to the main menu (with the same problems i have said before).
Reply
#5
Also load libdmux, libvdec, libavcdec, libpamf and libdmuxpamf
Reply
#6
lle:
-libdmux
-libdmuxpamf
-libpamf
-libpngdec
-libsail
-libsail_avi
-libspurs_jq
-libsre
-libvdec

E {PPU[0x8000000d] Thread (_libsail-control) [0x0008e8fc]} cellGcmSys: cellGcmMapMainMemory: CELL_GCM_ERROR_NO_IO_PAGE_TABLE
S {SPU[0x35] Thread (fluxCellSpursKernel4)} SPU: Function detected [0x0223c-0x02244] (size=0x8)
F {PPU[0x8000000d] Thread (_libsail-control) [0x39800000]} struct vm::access_violation thrown: Access violation reading address 0x39800000

No main menu, only the intro.

-Afther the intro it takes a few minutes before it says the error.

(08-12-2016, 06:23 PM)shoopdahoop22 Wrote: Does every game in the collection have its own executable? What happens when you load those instead?

I have tried the (S)ELF files from all 3 games and all with the same results.

F LDR: class std::runtime_error thrown: vm::falloc() failed (addr=0x20000000, memsz=0x4000000)
S LDR: (S)ELF: boot done.

And the other files are BOOT.bin and EBOOT.bin files, but that boots the game normally
Reply
#7
Build: rpcs3-v0.0.2-5-d0cb5f1 Alpha
Settings:
-PPU - Interpreter fast
-SPU - Recompiler ASMJIT
-"Load liblv2.sprx only"
-1280x720
-VSync
-XAudio

-Any graphics API reaches game selection screen with no problem, showing intro as well. Also all have working credits.

-Audio seems to start less than a second after the game reaches the game selection menu.

-It's a 60fps game but at 60fps the character animations are sped up by a lot, at 30 they seem normal.

-Starts every time, no cache clearing necessary.

-When choosing a game:
E {rsx::thread} HLE: Getting the real address failed. (addr=0x4ea34)
E {rsx::thread} RSX: Invalid FIFO queue get/put registers found, get=0x4EA34, put=0x4F428

Game then freezes, instead of crashing.

-The address values for the error message vary every time the game is run.

-Log attached

If trying to load each game individually or when "Load required libraries" is enabled, same happens as before:
F LDR: class std::runtime_error thrown: vm::falloc() failed (addr=0x20000000, memsz=0x4000000)
Reply
#8
I have the same error. I really want to play Jak And Daxter HD and Jak II. Does anyone know how to get this working?
Reply
#9
The Collection works now with last master
but there is graphical issues & game is very slow as it's not woking with PPU LLVM
tested with build: 0.0.3-5609-31ec0053

Here's a video by reznoir from Jak 1


log of course is attached

Request moving to Ingame (for now at least)
Reply
#10
Its good it works. Hopefully it will work properly in an upcoming update.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)