Hello There, Guest! Register

Only able to use openGL
#1
currently, im using the most recent build and am unable to use vulkan or dx12 and im not quite sure why. using windows 7 ultimate 64x intel i5 4690k and nvidia geforce gtx 760 driver version 368.39. switching from openGL to the others results in errors.

RPCS3 v0.0.1-3-c618e02 Pre-Alpha
F LDR: class std::runtime_error thrown: Verification failed: D3D12Module = LoadLibrary(L"d3d12.dll&quotWink
(in file C:\rpcs3\rpcs3\Emu\RSX\D3D12\D3D12GSRender.cpp:47)
F LDR: class fmt::exception thrown: vk::context::createInstance(): Assertion failed! Result is FFFFFFFAh
(in file c:\rpcs3\rpcs3\emu\rsx\vk\VKHelpers.h:1087)

i've tried running as admin and switching ppu/spu, but that did nothing. i would put the dll in and debug vulkan myself, but those directories dont exist on my hard drive. assuming rpcs3 is working as a virtual machine, it still cant find the dx12 dll which is strange. theres really no interface where i can look at its insides either. any ideas on why they might be failing and how to fix it?
Reply
#2
Check in "program and features" if you have "Vulkan Run Time Libraries"
Reply
#3
(08-04-2016, 11:55 AM)thenewcomer Wrote: currently, im using the most recent build and am unable to use vulkan or dx12 and im not quite sure why. using windows 7 ultimate 64x intel i5 4690k and nvidia geforce gtx 760 driver version 368.39. switching from openGL to the others results in errors.

RPCS3 v0.0.1-3-c618e02 Pre-Alpha
F LDR: class std::runtime_error thrown: Verification failed: D3D12Module = LoadLibrary(L"d3d12.dll&quotWink
(in file C:\rpcs3\rpcs3\Emu\RSX\D3D12\D3D12GSRender.cpp:47)
F LDR: class fmt::exception thrown: vk::context::createInstance(): Assertion failed! Result is FFFFFFFAh
(in file c:\rpcs3\rpcs3\emu\rsx\vk\VKHelpers.h:1087)

i've tried running as admin and switching ppu/spu, but that did nothing. i would put the dll in and debug vulkan myself, but those directories dont exist on my hard drive. assuming rpcs3 is working as a virtual machine, it still cant find the dx12 dll which is strange. theres really no interface where i can look at its insides either. any ideas on why they might be failing and how to fix it?

DX12 only works under Windows 10, Vulkan, theoretically, supports Vista and up but it all depends on how it'll be implemented in the driver.
Reply
#4
(08-04-2016, 01:25 PM)M9k Wrote: Check in "program and features" if you have "Vulkan Run Time Libraries"

(08-04-2016, 01:43 PM)flashmozzg Wrote: DX12 only works under Windows 10, Vulkan, theoretically, supports Vista and up but it all depends on how it'll be implemented in the driver.

strange. i have the proper runtime libraries, and even updated my graphics card driver to 368.81, but it still gives the error "Result is FFFFFFFAh (in file c:\rpcs3\rpcs3\emu\rsx\vk\VKHelpers.h:1087)"

any ideas?
Reply
#5
Turn off internal gpu, or force running on nvidia gtx in its GPU control panel
Reply
#6
It should run with the NVIDIA GPU by default (it does on my laptop) but right click rpcs3.exe and select the one that says something about running with a graphical processor and then the one who says High performance NVIDIA GPU.
Try running vulkaninfo on your system to see if it's working (vulkaninfo in the run box).
It should output something like http://image.prntscr.com/image/50ad76720...a8ba1f.png
Reply
#7
(08-07-2016, 12:11 PM)Annie Wrote: right click rpcs3.exe and select the one that says something about running with a graphical processor and then the one who says High performance NVIDIA GPU.
Try running vulkaninfo on your system to see if it's working (vulkaninfo in the run box).
It should output something like http://image.prntscr.com/image/50ad76720...a8ba1f.png

im on a desktop so there definitely should not be an internal graphics thing going on here. it should be using my nvidia gpu and i even went into nvidia control panel and changed around some settings to try and force it. right clicking rpcs3.exe gives quite a few options, but none of them are related to the gpu and there was nothing under properties.

i ran vulkaninfo and it did spit out something similar to yours so im pretty sure its set up correctly http://image.prntscr.com/image/aa471719e...7405b1.png

for future reference, i was able to resolve the issue by installing the latest vulkan SDK (software development kit)

it seems like just having driver support isn't enough at the moment. hopefully as rpcs3 keeps developing, the need for the SDK will be dropped and it can be download and play like other emulators
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)