Hello There, Guest! Register

Wangan Midnight [BLJM60028]
#11
RPCS3 v0.0.5-6757-3e71284d5 Alpha
Playable! audio is good if you use PPU and  SPU LLVM Recompilers. SPU ASMJIT still has stuttering audio.


Attached Files Thumbnail(s)
               

.gz   RPCS3.log.gz (Size: 3.88 MB / Downloads: 12)
Reply
#12
RPCS3 v0.0.5-6901-5c9d0e4b4 Alpha
SPU LLVM caused game freezes for me after "Warning" screens (or right before auto-loading savegames before reaching [press start button] screen) but then later fixes itself after I played the game several more times (maybe due to alternations with the stuff in configurations).

audio stuttering reduced when choosing LLVM in SPU column but it's still there for me (and possibly for some others as well judging from my "research" on YouTube)

Also failed to autosave the game after I finished the last Akio Chapter (Series 12) PLUS skipping/going through the ending screen. Game just simply freezes right after the ending video (special thanks to whoever, producer name etc) thus had to force-closing the game. Progress for Series 12 also not saved when I restarted game to check after each game crash. Changing between Vulkan/OpenGL doesn't help things.

Should be "Ingame" instead of "Playable"
This line of log always appeared before the game freezes after the ending video for Series 12:
E {PPU[0x1000010] Thread (GDV::RequestPool::Thread00) [0x0088de58]} 'sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1]


Attached Files
.gz   RPCS3.log.gz (Size: 3.17 MB / Downloads: 5)
Reply
#13
UPDATE:
Also tested v0.0.5.6926 and v0.0.5.6757. Same results as above.
Included my current savegame here with Akio Series 12 unlocked in case any might be kind enough to re-test the game once again.

Error line for v0.0.5.6926:
E {PPU[0x100006e] Thread (_libsail-control) [0x007eff0c]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1]


Attached Files
.rar   BLJM60028-GAME.rar (Size: 2.66 MB / Downloads: 20)
Reply
#14
SPU LLVM is very new, any videos older than say a month on youtube would've been using ASMJIT not SPU LLVM. The main video on the rpcs3 channel for instance, was recorded by myself and you can see the audio stuttering, but this was before SPU LLVM was implemented. That being said, you have some issues with your settings. For starters, use 1280x720 instead of 1920x1080 this will increase performance and compatibility with many titles. If you want to render at 1920x1080 then use 150% resolution scaling (or more if you'd like). Disabling SPU Loop Detection can also help audio, but I would also recommend using a Preferred SPU Thread value of 1 or 2. Your cpu is weaker than mine so stuttering audio may still exist for you even with these settings changed.

You can also try using load automatic and manual libraries then ticking "libvdec.sprx" in the firmware list to see if it helps with the ending screen. I got to the last races in series 5 and 4 but couldn't even get close to the opponent on those specific races for some reason, tried for around an hour but the car couldn't keep up no matter what I did. I had to give up but had a very long play session with this game and no crashes at all.

I tried your save but got stuck on the third race, I really don't understand how the first two races can be so easy than the third one seems almost impossible, I must be managing the engine heat really badly, but no matter what I try I can't seem to catch up to the opponent, I tried with manual and assist and sat on ~325-334kmh almost the whole race which is basically where the car maxes out.
Can you try the settings above and get back to me?


Attached Files Thumbnail(s)
   
Reply
#15
The key is maintaining an almost constant amount of throttle in 3rd race such that you're barely touching red/fluctuating between yellow and red zone for engine heat. The more stable the throttle the higher average speed u can maintain. My speed range is closer to 334-342km/h for Series 12 and have gotten multiple times of rank S, although might be easier for me as I've been playing not too arcade racing games often Tongue
Also changing the "red"(engine tuning) card in [card set up] may help boosting the horsepower to ~943hp highest for my save (though doesn't help average top speed in 3rd race). I might've forgotten checking that before uploading the save.

I'll update this post after testing with your setting. Thx.

EDIT:
Performance worsened with ending screen stuttering like hell. On plus side game no longer freezes after that though sadly I still ended up in an eternal black screen. The whole RPCS3 then crashed when I Alt+F4 the game. Progress for Series 12 still not saved.
I'll try fiddle with more settings.
Log attached.


Attached Files
.rar   RPCS3.rar (Size: 2.54 MB / Downloads: 3)
Reply
#16
Using libvdec.sprx will make videos slower, it's LLE (Low Level Emulation) vs HLE (High Level Emulation). But it can fix issues with videos in some games. I managed to finish the race and can confirm that it hangs on a black screen after the credits, what a shame this is so close to being playable!

I'm moving this back to ingame until it can be confirmed that this issue is fixed.


Attached Files Thumbnail(s)
   
Reply
#17
Can no longer boot game with libvdec.sprx on since v0.0.5.6945. Right after game screen appears and shaders finished compiling in the "black" screen everything freezes.

And perhaps unsurprisingly the game also crashes after credits video for completing Series 10 of Tatsuya/Blackbird storyline.

Attached savegame with 1500hp engine swap card unlocked and equipped to make testing (if any1 might bother) easier,


Attached Files
.rar   BLJM60028-GAME.rar (Size: 2.66 MB / Downloads: 9)
Reply
#18
It's still working on the latest builds for me, if libvdec.sprx isn't helping with the cutscene issue then go back to using load liblv2.sprx only it will be faster.
Reply
#19
Moving to Playable, the game no longer freezes at the end of the credits so it's possible to get a clear save.
RPCS3 v0.0.5-7546-a56ba737 Alpha
https://cdn.discordapp.com/attachments/3...nknown.png
https://cdn.discordapp.com/attachments/3...nknown.png


Attached Files Thumbnail(s)
   

.gz   RPCS3.log.gz (Size: 1.1 MB / Downloads: 4)
Reply
#20
RPCS3 v0.0.6-7786-a36d3af3 Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.92 GiB RAM | AVX+ | TSX
! RSX: Found vulkan-compatible GPU: 'GeForce GTX 980 Ti'

[Image: attachment.php?aid=12698]

it's not Playable

sound is broken in high speed

here the test

https://drive.google.com/file/d/1kv0X9iy...sp=sharing

and log file in Attachment


Attached Files Thumbnail(s)
   

.gz   RPCS3 Wangan Midnight [BLJM60028].log.gz (Size: 1,015.71 KB / Downloads: 2)
soon
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)