RPCS3 for Newcomers
Started by Ani




127 posts in this topic
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
04-16-2016, 08:24 PM -
#31
You should really read the topic to understand what to do

A few notes:
- You're using a build from 25 Feb. Older builds aren't supported, only the latest one, which you can find at the beginning of the topic.
- You're not posting the log.
- There's something called Lightshot which automatically uploads screenshots to Imgur.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
jalal2653
Guest


 
04-17-2016, 07:47 AM -
#32
Annie: I am what my problem is? In addition, the game was played with the boot game that are applicable? Or should be (pkg) tnx
Keksus
Guest


 
04-17-2016, 07:57 AM -
#33
(04-17-2016, 07:47 AM)jalal2653 Wrote: Annie: I am what my problem is? In addition, the game was played with the boot game that are applicable? Or should be (pkg) tnx

The emulator is not very far in development yet and not intended for general use like the PS1 or PS2 emulator. Games not working, like in your example, is the norm.

To help development you should post the log file and tell the LLE modules you used. But don't expect the game to be playable in the near future. You could be lucky and maybe it's playable soon... or it could take some years until it runs fine.
jalal2653
Guest


 
04-17-2016, 08:09 AM -
#34
(04-17-2016, 07:57 AM)Keksus Wrote:
(04-17-2016, 07:47 AM)jalal2653 Wrote: Annie: I am what my problem is? In addition, the game was played with the boot game that are applicable? Or should be (pkg) tnx

The emulator is not very far in development yet and not intended for general use like the PS1 or PS2 emulator. Games not working, like in your example, is the norm.

To help development you should post the log file and tell the LLE modules you used. But don't expect the game to be playable in the near future. You could be lucky and maybe it's playable soon... or it could take some years until it runs fine.
tnx for message
Keksus
Guest


 
04-17-2016, 08:27 AM -
#35
But speaking of newcomer problems. I have some problems using LLE modules since the update which changed it to displaying file names instead of module names. I can find the modules needed, but since that update every game always gives me a stern

Quote:LDR: Unknown module 'cellLibprof'
LDR: Unknown function '0x05893E7C' in module 'cellLibprof' (index 2972)
LDR: Unknown function '0x6D045C2E' in module 'cellLibprof' (index 2973)
LDR: Unknown function '0x9FB6228E' in module 'sysPrxForUser' (index 2974)

(tried it here with Steins;Gate 0 which I was able to launch and even play with older versions)

What am I doing wrong?
tambre
Guest


 
04-17-2016, 09:11 AM -
#36
Because the game imports a module doesn't mean it wants/needs it. cellLibprof is a library available only on PS3 dev kits that enables profiling of SPU usage. It's not needed.
jalal2653
Guest


 
04-17-2016, 10:24 AM -
#37
[REDACTED CONSOLE SPAM]
this is my game runner 2

and my god of war 3
[REDACTED CONSOLE SPAM]
tambre
Guest


 
04-17-2016, 10:43 AM -
#38
You were already told to post the log, not the console output. Console output is useless for reporting issues. It also might be worth re-reading the original thread, that also mentions this.
Keksus
Guest


 
04-17-2016, 10:53 AM -
#39
(04-17-2016, 09:11 AM)tambre Wrote: Because the game imports a module doesn't mean it wants/needs it. cellLibprof is a library available only on PS3 dev kits that enables profiling of SPU usage. It's not needed.

As far as I am aware I am not loading it. Just checked the usual modules. And after that message nothing is happening.
Ani
Administrator
*******


11
3,610 posts 96 threads Joined: Aug 2017
04-17-2016, 11:47 AM -
#40
(04-17-2016, 10:53 AM)Keksus Wrote:
(04-17-2016, 09:11 AM)tambre Wrote: Because the game imports a module doesn't mean it wants/needs it. cellLibprof is a library available only on PS3 dev kits that enables profiling of SPU usage. It's not needed.

As far as I am aware I am not loading it. Just checked the usual modules. And after that message nothing is happening.

Did you press Run after booting the game? You now have to manually press run to start the emulation.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7


Forum Jump:


Users browsing this thread: 1 Guest(s)