Hello There, Guest! Register

Dragon's Crown [BLUS30767]
#1
Try this patch if the game fails to start: https://github.com/RPCS3/rpcs3/issues/30...-320465335
Reply
#2
You should try LLEing cell_SpursJq and cell_Sre
Reply
#3
I fixed the title for you this time. Please follow the submission guidelines in the future.
Reply
#4
With cell_SpursJq I got nothing.
With cell_Sre I have 50fps.

Sorry for formatting.
Reply
#5
Code:
{PPU Thread[0x1] (main_thread)[0x00d63844]} cellSpurs TODO: cellSpursSetExceptionEventHandler
---
{PPU Thread[0x62] (_fiberRuntime_2b607c00_00)[0x008e89f0]} cellSync2 TODO: cellSync2SemaphoreAcquire
{PPU Thread[0x1] (main_thread)[0x008e89f0]} cellSync2 TODO: cellSync2SemaphoreAcquire
---
{PPU Thread[0x3c] (CRI Server Manager)[0x008e8550]} cellSpursJq TODO: _cellSpursJobQueuePort2CopyPushJobBody
{PPU Thread[0x3c] (CRI Server Manager)[0x008e8610]} cellSpursJq TODO: cellSpursJobQueuePort2Sync

cell_Sre and cell_SpursJq are needed I believe.
cell_Sync2 can't be LLEd because it crashes the emulation due to some cell_Fiber error.
I tried with OpenGL here and I have the same black screen with FPS outcome.
Reply
#6
With 9d7c186a you can hear garbled sound after a while. Required LLE cellFiber, cellSpursJq and cellSre. After sound is over, when you press x, it's heard once again.
Reply
#7
(03-13-2016, 10:14 PM)Gundark Wrote: With 9d7c186a you can hear garbled sound after a while. Required LLE cellFiber, cellSpursJq and cellSre. After sound is over, when you press x, it's heard once again.

Nekotekina's PR should give this a boost, as it makes cellResc LLEable.
The cellAudio outputs are kinda irrelevant because the game can run and output audio (In s;g 0 it outputs the same stuff and it can output perfect audio).

I don't know about the cellSync2 though, it's missing HLE implementation
Code:
·U {PPU Thread[0x1] (main_thread)[0x008e8c00]} cellSync2 TODO: cellSync2SemaphoreAcquire
Reply
#8
I have the game running just fine until past the character selection screen...
http://i.imgur.com/aiOcn6Y.jpg
http://i.imgur.com/1w9DMpt.jpg
(sorry I'm new to the emulation in rpcs3 I don't know if I have to post log or something like that, I don't even know where to find it :T, sorry too my english is bad :/ )

The sound is working fine too, but after you press to chose a character the game just froze in the character screen



The screen of my rpcs3 settings:
[Image: zvS6uqN.png]
RPCS3 v0.0.0.9-5fe1e7a1
Reply
#9
No luck here, I can't replicate. Still having black screen with fps. After closing a game in your rpcs3 folder there should be a file RPCS3.log. It's your log file. But if you start another game, it will be overwritten, so it's a good idea to rename it.
Reply
#10
(04-17-2016, 12:22 AM)bahlskra Wrote: I have the game running just fine until past the character selection screen...
http://i.imgur.com/aiOcn6Y.jpg
http://i.imgur.com/1w9DMpt.jpg
(sorry I'm new to the emulation in rpcs3 I don't know if I have to post log or something like that, I don't even know where to find it :T, sorry too my english is bad :/ )

The sound is working fine too, but after you press to chose a character the game just froze in the character screen



The screen of my rpcs3 settings:
RPCS3 v0.0.0.9-5fe1e7a1

Welcome to the forum!

Please read the newcomer's guide and see the list of playable games.
If you're having any problems, please also read how to report issues and when reporting statuses of games or are having problems please read the submission guidelines.

Please keep in mind that piracy is not allowed and asking help with piracy, requesting pirated firmware files or games may result in a permanent suspension.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)