Hello There, Guest! Register

Shank [NPUB30232]
#1
Tested on recent master build. Stuck after playing intro. Requires libSre and L10n LLE'd.
Code:
G: E {SPU[0x5a] Thread (FMOD)[0x164e8]} Exception: Unknown STOP code: 0x0 (Out_MBox is empty)
(in file Emu\Cell\SPUThread.cpp:1418, in function SPUThread::stop_and_signal)
Reply
#2
RPCS3 v0.0.2-5-2b0736b Alpha
gos ingame but crash fast with this errorAngryAngry
F {rsx::thread} : class std::runtime_error thrown: Working buffer not big enough
(in file c:\rpcs3\rpcs3\emu\rsx\d3d12\../Common/ring_buffer_helper.h:72)

Reply
#3
RPCS3 v0.0.3-5-0302e8d Alpha
Intel® Core™ i5 CPU 750 @ 2.67GHz | 4 Threads | 8.00 GiB RAM
the game is working and this time not crashing but very slow sometimes

Reply
#4
Someone with a faster CPU has to test this one
Reply
#5
I gave it a try Smile

Game tested using rpcs3-v0.0.3-2017-07-27-7ac96f75_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Recompiler (LLVM)
SPU decoder: Recompiler (ASMJIT)
Load liblv2.sprx only
GPU settings: OpenGL; Vulkan @ 1280x720 w/ VSync, Frame limit set to 60
Audio settings: XAudio2
Input/Output: DualShock 4

This one is very odd. First of all, with both Vulkan and OpenGL, the game tends to lock up right before the ESRB rating screen (frame rate counter freezes). Every 1 in ~4 tries it gets past that. The main menu text is missing a bunch of characters but can still be navigated (screenshot #1).

Ingame, Vulkan shows flickering black triangles but looks otherwise okay. OpenGL looks almost perfect, no flickering.

Now for the strange part: With both renderers, the game starts at 60 fps for me. Even if I stand still doing absolutely nothing, the frame rate drops gradually. At the start of the first level with nothing really going on, it goes down to around 18 fps. Then it suddenly jumps back to 60. When encountering the first enemies in the same room, the best I could get was 50, the worst 5 fps. These numbers are similar with Vulkan. When the fps go very low, the controller also becomes partially unresponsive; I have to press buttons several times before the game reacts. I tried to capture this behavior in a couple of screenshots. Pay attention to the frame rate counter in screenshots 2/3/4 & 5/6.
Reply
#6
RPCS3 v0.0.4-6075-0064976c Alpha
Playable with consistently high framerate (i almost never went below 60)

Need to use OpenGL or you will experience some graphical issues.


Attached Files Thumbnail(s)
   

.gz   RPCS3.log.gz (Size: 225.97 KB / Downloads: 1)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)