Steins;Gate 0 [BLJM61303]
Started by Ani




73 posts in this topic
Ani
Administrator
*******


11
3,722 posts 96 threads Joined: Aug 2017
02-17-2016, 06:11 PM -
#71
(02-17-2016, 11:40 AM)kungfulon Wrote: i had the game run smoothly at 60fps (except video scenes) with the same settings as MrComputerRevo. i re-encoded all usm files to MPEG and it worked.

Yeah, if the movies are altered it works.
But, I've been trying to run the unmodified version of the game in all the recent commits and it still isn't working for me.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
haruka
Guest


 
09-27-2016, 07:21 PM -
#72
Raising this title up.

I tested this game with v0.0.1-5-adc5ee9 again, and I found a trick to play(read: skip) the video without modifying the game.

Detailed steps:
1. On title screen, when it tells you to press circle to start, wait for the game to load another intro video. The beginning of the video is a clock on the left of the screen. If you are already at main menu, press cross to go back.
2. Wait until the sound of video is played (Important!).
3. Skip this video and start a new game as usual.

The video after the story intro will be able to play and you will be able to skip it by pressing circle. I guess that this makes the game playable.

This is apparently a trick and I don't know the mechanics... Maybe I should point this out as a github issue as well.

Tried many setting combinations, and the working ones are:
Interpreter / Recompiler PPU
Recompiler SPU (Interpreter doesn't work)
Any renderer

LLE libraries:
libsre
libresc
librtc (to get correct date and time of save. Savedata is working)
libspurs_jq
libvdec and all related libraries (related?)

Is a video demonstration needed / recommended?
Ani
Administrator
*******


11
3,722 posts 96 threads Joined: Aug 2017
10-12-2016, 06:06 PM -
#73
Sadly that didn't work for me.
It's most likely an issue on the video decoding part, I haven't got the slightest idea on what might be causing that.
Been wanting to get ingame with this one for months.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
Ani
Administrator
*******


11
3,722 posts 96 threads Joined: Aug 2017
01-26-2017, 04:45 PM -
#74
With Nekotekina's latest commit 0.0.1-9-da804cf this game is now playable on stable ~60fps.

Load libraries:
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx
PPU Decoder: Interpreter (fast)
SPU Decoder: Interpreter (fast)




    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7


Forum Jump:


Users browsing this thread: 1 Guest(s)