Streets of Rage 2 [NPUB30444]
Started by ps0ne




4 posts in this topic
ps0ne
Member


0
304 posts 59 threads Joined: Oct 2017
12-20-2015, 04:18 PM -
#1
Game is builded similar to comix zone. This means it is another pretender to playable state.

OGL
ppu 2
spu jit

lle
spursiq
sar
jpg/png dec
fiber
sail
tambre
Guest


 
12-20-2015, 04:24 PM -
#2
(12-20-2015, 04:18 PM)ps0ne Wrote: Game is builded similar to comix zone. This means it is another pretender to playable state.

OGL
ppu 2
spu jit

lle
spursiq
sar
jpg/png dec
fiber
sail

What is the "sar" module and are jpg/png dec really needed?
ps0ne
Member


0
304 posts 59 threads Joined: Oct 2017
12-20-2015, 04:36 PM -
#3
Sorry i meant sre not sar

Looks like ser and spursjq are enough to tick
ps0ne
Member


0
304 posts 59 threads Joined: Oct 2017
02-21-2016, 12:39 PM -
#4
I reached 5th base and it looks like game is playable like rest of Sega Vintage Collection, saving does not work though.
Aeternal600
Guest


 
07-28-2017, 08:05 PM -
#5
Game tested using rpcs3-v0.0.3-2017-07-27-7ac96f75_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Recompiler (LLVM)
SPU decoder: Recompiler (ASMJIT)
Load automatic and manual selection -> libvdec.sprx
GPU settings: OpenGL; Vulkan @ 1280x720 w/ VSync, Frame limit set to 60
Audio settings: XAudio2
Input/Output: DualShock 4

Runs perfectly at full speed for me. I couldn't detect any glitches, at least when playing on OpenGL. Saving and loading work.

As with Altered Beast, I had to manually load libvdec.sprx, otherwise RPCS3 always failed with the following error at the initial "SEGA" logo screen: "F {PPU[0x1000013] Thread (HLE Video Decoder)} class std::runtime_error thrown: Unsupported time_base.num (1000/1, tpf=1)
(in file C:\rpcs3\rpcs3\Emu\Cell\Modules\cellVdec.cpp:332)".

Again, as with Altered Beast, Vulkan flickers heavily, so OpenGL is the better choice.

Playable Big Grin


Forum Jump:


Users browsing this thread: 1 Guest(s)