Metal Slug 3 [NPEB02252]
Started by vlj




33 posts in this topic
vlj
Guest


 
08-31-2015, 11:33 PM -
#1
I didn't find a previous entry for the game, although I though I saw one once.

The game works with commit 99a9fd8505932547bd862554b3c4ff9b6158b0a2 :
- With PPU Interpreter 2 at 20 fps, with GL and DX12.
- With LLVM recompiler at 5 fps.

On one of my branch (llvm36-wip3) it runs between 20 and 55 fps with llvm recompiler (mostly 55 fps, but can go down to 20 fps if there are a lot of explosions).
It takes a while to warm up llvm though.

sound works, but I benchmarked without sound at all.

Please note that the game will hang at start up (because of trophy apparently), it recovers fine if resumed.

I completed the first level of the game.
Sound works with xaudio 2.
After being run for 5-6 min the game hits a constant 60 fps (with llvm recompiler).
There are slow down but they seem to be generated by the game itself (probably to emulate older console behavior) since the fps are always at 60 fps and music is never distorded.
Dante38490
Guest


 
09-16-2015, 10:23 PM -
#2
Vidéo GamePlay with 60 fps

Butz_san
Guest


 
09-21-2015, 02:31 AM -
#3
In windows is working fine but whenever I tried to run the game on Linux, I got the following message

Code:
[email protected]:~/PS3/rpcs34/build/bin$ ./rpcs3
/rpcs3_vm: g_base_addr = 0x7febf8970000, g_priv_addr = 0x7feaf8970000
terminate called after throwing an instance of 'fmt::exception'
flashmozzg
Guest


 
09-21-2015, 02:19 PM -
#4
(09-21-2015, 02:31 AM)Butz_san Wrote: In windows is working fine but whenever I tried to run the game on Linux, I got the following message

Code:
[email protected]:~/PS3/rpcs34/build/bin$ ./rpcs3
/rpcs3_vm: g_base_addr = 0x7febf8970000, g_priv_addr = 0x7feaf8970000
terminate called after throwing an instance of 'fmt::exception'

Please post the log too.
Butz_san
Guest


 
09-22-2015, 01:44 AM -
#5
The log doesn't say much, look:
This happens when I pick the game
Code:
E Unknown function '0xAFC62605' in 'sceNp' module (0x1a6a88)
E Unknown function '0xBA8C569E' in 'sceNpSns' module (0x1a76a8)

Then, the emu just close itself and give me the message that I post early
Code:
[email protected]:~/PS3/rpcs34/build/bin$ ./rpcs3
/rpcs3_vm: g_base_addr = 0x7febf8970000, g_priv_addr = 0x7feaf8970000
terminate called after throwing an instance of 'fmt::exception'
ZeCoxao
Guest


 
09-22-2015, 07:52 PM -
#6
i can't seem to make it work. here are the errors:
http://pastie.org/private/uioyy5vskua4vbtfz8vuq
tambre
Guest


 
09-22-2015, 07:54 PM -
#7
(09-22-2015, 07:52 PM)ZeCoxao Wrote: i can't seem to make it work. here are the errors:
http://pastie.org/private/uioyy5vskua4vbtfz8vuq

*pokes zecoxao with a stick*

Post the full .log file. We need more than only errors.
flashmozzg
Guest


 
09-22-2015, 10:17 PM -
#8
(09-22-2015, 07:52 PM)ZeCoxao Wrote: i can't seem to make it work. here are the errors:
http://pastie.org/private/uioyy5vskua4vbtfz8vuq

I have NPUB31698 version and it's working fine...
ZeCoxao
Guest


 
09-25-2015, 11:12 PM -
#9
(09-22-2015, 07:54 PM)tambre Wrote:
(09-22-2015, 07:52 PM)ZeCoxao Wrote: i can't seem to make it work. here are the errors:
http://pastie.org/private/uioyy5vskua4vbtfz8vuq

*pokes zecoxao with a stick*

Post the full .log file. We need more than only errors.
log is posted in previous post (attachment)
tambre
Guest


 
09-26-2015, 05:37 AM -
#10
(09-25-2015, 11:12 PM)ZeCoxao Wrote:
(09-22-2015, 07:54 PM)tambre Wrote:
(09-22-2015, 07:52 PM)ZeCoxao Wrote: i can't seem to make it work. here are the errors:
http://pastie.org/private/uioyy5vskua4vbtfz8vuq

*pokes zecoxao with a stick*

Post the full .log file. We need more than only errors.
log is posted in previous post (attachment)

Try running it at the resolution of 1280x720. I'm pretty sure that's the native resolution, that the game is meant to run at.


Forum Jump:


Users browsing this thread: 2 Guest(s)