Hello There, Guest! Register

Metal Slug 3 [NPEB02252]
#11
Now, I was able to run Metal Slug 3 on Linux, the problem is that it never load again O_o. It ran just once and nothing more T_T.

[Image: 8hlaJpj.jpg]
[Image: pPeZ9GE.png]

The error is almost the same (there isn't any log in the console, the emu close itself)

Code:
[email protected]:~/Emu-+/rpcs3/build/bin$ ./rpcs3
/rpcs3_vm: g_base_addr = 0x7f7d5c938000, g_priv_addr = 0x7f7c5c938000
terminate called after throwing an instance of 'fmt::exception'
  what():  Access violation writing location 0x0
(in file /home/butz/Emu-+/rpcs3/Utilities/Thread.cpp:1173, in function signal_handler)
Abortado
Reply
#12
(10-07-2015, 03:07 AM)Butz_san Wrote: Now, I was able to run Metal Slug 3 on Linux, the problem is that it never load again O_o. It ran just once and nothing more T_T.

The error is almost the same (there isn't any log in the console, the emu close itself)

Code:
[email protected]:~/Emu-+/rpcs3/build/bin$ ./rpcs3
/rpcs3_vm: g_base_addr = 0x7f7d5c938000, g_priv_addr = 0x7f7c5c938000
terminate called after throwing an instance of 'fmt::exception'
  what():  Access violation writing location 0x0
(in file /home/butz/Emu-+/rpcs3/Utilities/Thread.cpp:1173, in function signal_handler)
Abortado

Just post the log file - RPCS3.log....
Reply
#13
Ok, here is the log

Code:
http://pastebin.com/Rf4R1VLZ
Reply
#14
(10-07-2015, 05:00 AM)Butz_san Wrote: Ok, here is the log

Code:
http://pastebin.com/Rf4R1VLZ

Well the game calls to exit, since your rendering backend is set to "Null". You should be able to use OpenGL. Also, I'd suggest you to use PPU Intepreter 2, since it's as accurate as PPU Interpreter, but a lot faster. Also, for some reason, it shows that the resolution is "Unknown" in the log, but that might just be a side effect of the Renderer being "Null".

Basically: try again with the OpenGL renderer.
Reply
#15
With OpenGL render crashes, so it doesn't give me any log Sad
Reply
#16
(10-08-2015, 03:02 AM)Butz_san Wrote: With OpenGL render crashes, so it doesn't give me any log Sad

So there is no RPCS3.log created with OpenGL renderer? RPCS3.log is always created as soon as RPCS3 is started. Also, it could at least contain some info about the crash.
Reply
#17
(10-08-2015, 04:44 AM)tambre Wrote:
(10-08-2015, 03:02 AM)Butz_san Wrote: With OpenGL render crashes, so it doesn't give me any log Sad

So there is no RPCS3.log created with OpenGL renderer? RPCS3.log is always created as soon as RPCS3 is started. Also, it could at least contain some info about the crash.

It just crash, it gives me an Access Violation and the emu close itself without any message, just the console, look:

[Image: AoTPF2O.jpg]
Reply
#18
(10-09-2015, 04:07 AM)Butz_san Wrote:
(10-08-2015, 04:44 AM)tambre Wrote:
(10-08-2015, 03:02 AM)Butz_san Wrote: With OpenGL render crashes, so it doesn't give me any log Sad

So there is no RPCS3.log created with OpenGL renderer? RPCS3.log is always created as soon as RPCS3 is started. Also, it could at least contain some info about the crash.

It just crash, it gives me an Access Violation and the emu close itself without any message, just the console, look:

You still fail to answer to my questions and to provide the log, which might provide some useful information for solving the problem.

Though what I can say thanks to the console output is that, it seems to crash the application right away, instead of handling the access violation gracefully, as it does on windows.

Please provide the RPCS3.log file, that is generated, when RPCS3 is ran or I wont be able to trace the root cause of the access violation.
Reply
#19
I was able to run the game again, here is the log

Code:
http://pastebin.com/AG5zwPHQ

I found a solution about it too, if I change the size of the LLMV blocks in the configurations it runs the game again, the problem is that I have to do the same everytime I want to play it, in windows this doesn't happen
Reply
#20
hi i run metal slug 3NPUB31698 on opengl with latest build rpcs3-ReleaseLLVM-77bf86ea and 23fps with this PC RAM 8 GB
Intel hd 4600 and Core i 5 4460 3.2Ghz Windows10 Pro64bit
With DX12 and llvm recompiler fps = 40-55 sometimes 60
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)