Catherine [BLES01459]
Started by Dante38490




13 posts in this topic
Dante38490
Guest


 
06-28-2015, 12:36 AM -
#1
Update 2017-03-20 Graphics and performance are flawless with DX12 and Vulkan on a fast CPU. Use ASMJIT + LLVM. If ASMJIT shows a black screen use fast SPU interpreter.







In Only with build DX12
Show the loading screen, 30 fps with the flashing icon.

And then shows after 20 sec another Logo "Deep Silver"

The 2nd logo disappears after 55 sec.
Log error

Note that this sequence is repeated in a loop.
Quote:E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 4(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 8(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 12(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 16(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 20(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 24(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 28(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 32(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 36(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 40(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 44(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 48(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 52(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 56(0x2dc8)
E {RSXThread} TODO: CELL_GCM_NV4097_SET_TEXTURE_CONTROL2 + 60(0x2dc8)
E {RSXThread} Unknow min filter 7
E {RSXThread} Unknow mag filter 4
ssshadow
Administrator
*******


4
2,494 posts 63 threads Joined: Aug 2017
06-28-2015, 11:51 AM -
#2
Any sound like in the other version?
Dante38490
Guest


 
06-28-2015, 12:08 PM -
#3
(06-28-2015, 11:51 AM)ssshadow Wrote: Any sound like in the other version?
Yes after second logo

I did several test by timing the time for loading the first screen and shows really interesting thing.
From the black screen until the disappearance of the logo.

With CPU : PPU interpreter
Quote:SPU interpreter = 7:05 min
SPU interpreter 2 = 34 sec
SPU asmjit = 12:00 min

With CPU : PPU interpreter 2
Quote:SPU interpreter = 27 sec
SPU interpreter 2 = 18 sec
SPU asmjit = 4:40 min

So we see that the CPU fastest is the "PPU interpreter 2"
I can not test the "PPU JIT (LLVM)" it is not yet compatible with VS 2015.

Then the SPU fastest is very clearly the "SPU Interpreter 2", the "SPU JIT (ASMJIT)" is so slow that even the "SPU Interpreter" is faster and has fewer freeze.

The problem with "SPU JIT (ASMJIT)" are caused by the changes made Nekotekina on that branch, the master branch she has no problem, and no freeze.

This problem should be solved when Neko will be merge to the master, I hope so ^^
Dante38490
Guest


 
08-15-2015, 03:31 PM -
#4
For last My build Game Show nothing, rpcs3 is a pause with error
Quote:E {PPU[0x1] Thread (main_thread)[0x00c2fd9c]} Exception: Access violation writing location 0x762
(in file ..\Utilities\Thread.cpp:1122, in function _se_translator)
E {PPU[0x1aa] Thread (CriSr_ProcessServer)[0x00a90350]} cellSync: cellSyncMutexTryLock() -> CELL_SYNC_ERROR_BUSY (0x8041010a)
UBWMaster
Guest


 
04-10-2017, 11:37 AM -
#5
Hey is this game just work in the US version? Cause with this version I stuck at black screen after Atlus Logo. I'm using PPU(LLVM) + SPU(ASMJIT) + OpenGL Render with auto modul. Here's the log
Keksus
Guest


 
04-10-2017, 10:05 PM -
#6
Try LLVM Recompiler and SPU Interpreter (Fast).
UBWMaster
Guest


 
04-11-2017, 06:26 AM -
#7
(04-10-2017, 10:05 PM)Keksus Wrote: Try LLVM Recompiler and SPU Interpreter (Fast).

The result is the same stuck at black screen after Atlus Logo. I'm using this version "rpcs3-v0.0.2-2017-04-03-65488078_win64". Maybe the game just works for the US version for now...
Keksus
Guest


 
04-11-2017, 02:29 PM -
#8
Nope. EU Version works perfectly fine with 30fps like the US version. So most likely playable, but I didn't check saving and loading or anything after taking a look at the tutorial.

DX12 with LLVM recompiler and SPU interpreter (fast)
ssshadow
Administrator
*******


4
2,494 posts 63 threads Joined: Aug 2017
04-11-2017, 03:53 PM -
#9
It is probably playable. ASMJIT randomly black screens for some people. Use "fast" SPU interpreter in that case. There is a performance penalty but not too drastic. Someone still got 30 fps either way.

Moving thread.
BadSeed
Guest


 
05-03-2017, 10:39 AM -
#10
Saving / Loading works fine , the game runs smoothly on 30 fps most of the time .

I'd like to report sound sync issues ,
other times sounds is turned off completely (It happened to me several times and I noticed it happens if u skip dialog too fast)

Also the game Rapunzel on the bar doesn't not work (black screen).

Using PPU LLMV,SPU ASMJIT,D3D12,XAudio2


Forum Jump:


Users browsing this thread: 2 Guest(s)