Metal Slug NEOGEO [NPUB30258]
Started by ps0ne




18 posts in this topic
ps0ne
Member


0
303 posts 59 threads Joined: Oct 2017
02-21-2016, 10:42 AM -
#11
Im sorry, i have no tools to compile. If uncommenting a line is a hack then we can wait, maybe amd will fix it in future drivers. Game stops randomly, sometimes on begning sometimes later depend on commit, i will wait for future commits.
tambre
Guest


 
02-21-2016, 11:11 AM -
#12
I don't think working around "proper" drivers that refuse to do stuff, when you screw up is not a good idea and is hacky, if not a blatant hack.
kd-11
RPCS3 Developer


0
75 posts 1 threads Joined: Aug 2017
02-21-2016, 09:33 PM -
#13
(02-21-2016, 11:11 AM)tambre Wrote: I don't think working around "proper" drivers that refuse to do stuff, when you screw up is not a good idea and is hacky, if not a blatant hack.

The error that the AMD driver gives, while valid, is not really an indicator of a problem with the shaders at all, it just means that nothing has been bound to the sampler descriptors. I have access to an AMD machine now, so I'll see if there's a proper way to fix it.
ps0ne
Member


0
303 posts 59 threads Joined: Oct 2017
02-21-2016, 10:44 PM -
#14
Great Smile Wish you a success.
kd-11
RPCS3 Developer


0
75 posts 1 threads Joined: Aug 2017
02-23-2016, 03:53 PM -
#15
(02-21-2016, 10:44 PM)ps0ne Wrote: Great Smile Wish you a success.

I've submitted a fix so once its merged you may test. The game however still crashes with the win32 error ERR_DISK_CHANGED as with DX12 with is another issue altogether. To work around this, copy the folder /dev_hdd0/game/NPJB7001 to /dev_hdd1/game/NPJB7001. Should get to main menu.

The "game" is actually a neogeo station emulator running a packaged rom file. An emulator within an emulator Smile
ps0ne
Member


0
303 posts 59 threads Joined: Oct 2017
02-25-2016, 07:36 AM -
#16
Thanks for a fix Smile

Using OpenGL have no errors. I reach menu, select normal mode and just now loading creen lasts forever. No error, it just loads and loads.

yes indeed. Game uses some emulibraries. I decrypted all dats. There are also two prx modules: libaac_neogeo and libemu_m68k.
Copying them to other lle's prxs and enabling them on the list gives no help.
tambre
Guest


 
02-25-2016, 10:12 AM -
#17
(02-25-2016, 07:36 AM)ps0ne Wrote: Thanks for a fix Smile

Using OpenGL have no errors. I reach menu, select normal mode and just now loading creen lasts forever. No error, it just loads and loads.

yes indeed. Game uses some emulibraries. I decrypted all dats. There are also two prx modules: libaac_neogeo and libemu_m68k.
Copying them to other lle's prxs and enabling them on the list gives no help.

LLE'ing them won't do anything, as they're not system libraries.
Games can have their own modules (as in this case), that they can load and then call functions from. Kinda like .dll's.
ps0ne
Member


0
303 posts 59 threads Joined: Oct 2017
04-19-2017, 09:09 PM -
#18
Game works now. Some new messages about writing to HDD appeared at loading game, maybe few fixes with save data. Game is weird so its nice to see it working.

I manually decrypted two custom .sprxes Its funny watching they are compiled during a game by llvm. but thankst to it game is fast

log is actually from second run with llvm. Some data writing was in first run.
digitaldude
RPCS3 Tester


0
2,678 posts 524 threads Joined: Aug 2017
12-22-2017, 10:13 PM -
#19
rpcs3-v0.0.4-2017-12-19-f24491de_win64

Playable.


Attached Files Thumbnail(s)
   

.rar   RPCS3MetalSlug.rar (Size: 90.57 KB / Downloads: 5)


Forum Jump:


Users browsing this thread: 1 Guest(s)