Skate 3 [BLUS30464]
Started by supergatto




76 posts in this topic
reznoire
Member


0
18 posts 0 threads Joined: Aug 2017
07-15-2017, 04:48 PM -
#51

Tested with the 7/13 blog build.

ppu/spu recompiler, vulkan.

Runs nearly full speed in the training grounds (not the main environments).
EnderStrider
Unregistered


 
07-20-2017, 01:33 AM -
#52
Using DXD12 renderer I got this in log:
"F {rsx::thread} class std::runtime_error thrown: HRESULT = D3D12 device was removed with error status 0x887A0001
(in file c:\rpcs3\rpcs3\emu\rsx\d3d12\D3D12PipelineState.h:185)"
and I got a freezed black screen and when I close the game ,RPCS3 stop responding.
the game runs in opengl 4.5 renderer but with 15 fps

specs:
Intel® Core™ i5-3230M CPU @ 2.60GHz | SSSE3 Supported | 4 Threads | 8 GB RAM
Nvidea GeForce 710m 2gb Vram
mchtt
Unregistered


 
07-20-2017, 05:03 PM -
#53
Tested with 07/20 build.
Recompiler, Vulkan
Got almost 60 fps in some training areas :-D
PROOF
Ani
Administrator
*******


16
4,010 posts 104 threads Joined: Aug 2017
07-23-2017, 02:55 PM -
#54
Missing logs. Don't use D3D12, it's not maintained.
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux
Enverex
Unregistered


 
08-03-2017, 11:40 AM -
#55
It gets quite far for me (logos play fine, menu works fine, etc) but the graphics go a bit crazy once you get properly in-game.

The player is a crazy blue beam of light which is glitching all over the place and the camera appears to be under the ground - https://youtu.be/R4qM6QX4TjY?t=111

That's using LLVM/ASMJIT and Vulkan. Log attached (Edit: Log not attached, even 7z'd it's larger than the forum's small limit of 2MB).

The log (whilst this is happening) appears to be almost exclusively...
{rsx::thread} RSX: TODO: NV4097_CLEAR_REPORT_VALUE: ZPASS_PIXEL_CNT
ssshadow
Administrator
*******


4
2,494 posts 63 threads Joined: Aug 2017
08-03-2017, 09:09 PM -
#56
Upload log to mega.nz or something, or split the archive into parts.
Enverex
Unregistered


 
08-04-2017, 09:33 AM -
#57
Managed to make it fit by just not letting the game run for as long. Here's the log.
hemingCaomataa
Member


0
2 posts 0 threads Joined: Aug 2017
08-24-2017, 08:49 PM -
#58
Great performance in the training area, 20-60 . 5-20 In the bigger areas. Using recompiler. Somtimes game will fail to load on startup with random crashes up to loading into the game.

Absolutely amazing to see this game run on a pc. I've been waiting for this to emulated for so long.

I'm getting alot of 'sys_fs_open' failed with 0x80010006 in the logs.
EX:
E {PPU[0x1000001] Thread (null: ) [0x019e8090]} 'sys_fs_open' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd1/cache/BLUS30464/data/content/marquee/texture/0x2c7f38180009019e.psg” [1]
E {PPU[0x1000001] Thread (null: ) [0x019e8090]} 'sys_fs_open' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd0/game/BLUS30464_INSTALL/USRDIR/data/content/marquee/texture/0x2c7f38180009019e.psg” [1]
E {PPU[0x1000001] Thread (null: ) [0x019e8090]} 'sys_fs_open' failed with 0x80010006 : CELL_ENOENT, “/dev_hdd1/cache/BLUS30464/data/content/marquee/model/andrew_reynolds/Arm/0x2c7f381100080111.psg” [1]

Would like to see more development into getting this game into a good state (already phenomenal progress). Definitely have my support.
This post was last modified: 09-10-2017, 04:30 PM by hemingCaomataa.
elfen
Member


0
4 posts 1 threads Joined: Sep 2017
09-14-2017, 05:50 AM -
#59
Starting from build 0.0.3-6078 in this game my pc hangs up when using xinput.
Legtayor
Member


0
1 posts 0 threads Joined: Sep 2017
09-24-2017, 02:02 AM -
#60
Using the Sept 23 build I am unable to get past the blue EA screen, using Recompiler/Recompiler/Vulkan.


Forum Jump:


Users browsing this thread: 5 Guest(s)