Digimon All-Star Rumble [BLUS31441]
Started by DragonNeos




10 posts in this topic
DragonNeos
Guest


 
11-29-2014, 10:00 PM -
#1
This game was tested on RPCS3-d9b0b56. The emulator will load a black screen and the log displays various warnings and errors.
blackspider1433
Guest


 
01-04-2017, 09:48 AM -
#2
Hi all

Looks like nobody is interested in this game Dodgy But I registered in the website only 4 it

I tried the game with rpcs3-ReleaseLLVM-2d9e02b0

I only used libresc.prx , libspurs_jq.prx & libsre.prx

It works very good but the problem is with the sound that lags and you can't hear what's said. When u don't input anything the sound is great but when you start inputting and when you start the game the sound is horrible. Playing without sound is great but I'd really like if someone can help me to fix this, if possible

I used precise PPU and fast SPU decoder (Fast PPU didn't help with sound. And precise SPU decoder cuts the sound). Used vulkan as render (openGl is slower), auto frame limit, tried vsync and log shader programs with not much difference. XAudio2 (OpenAl is alot worse it lags even with no input). Tried dump to file and convert to 16 bit with no help


My log is as attached

Sorry if some of the information is more or less than needed



I know I might be trying in a dead end, but any suggestions related to sound problems are welcomed. I read alot in your great website and it helped me alot so I don't want to stop now as I feel I'm very close of achieving what I started Shy
ssshadow
Administrator
*******


4
2,494 posts 63 threads Joined: Aug 2017
01-04-2017, 03:22 PM -
#3
You didn't attach the log file.

In general for audio you can try with or without the recompilers and XAudio or OpenAl. Then you should also see if you can LLE some audio modules that the game makes use of (the log file will tell you or me if this is the case.).

Try with the massive list of modules from Catherine, it uses several audio/video ones and has pretty good sound despite running at 5 fps: http://www.emunewz.net/forum/showthread.php?tid=175609

Oh, and since the game apparently runs now make a post and just copy my general layout from the Catherine thread (settings used, screenshots, log file, etc) and this thread can be moved half playable or playable. Smile
Dante38490
Guest


 
01-05-2017, 12:55 PM -
#4
Eu Fail, Actually this game Perflecty Playables, Sound Perfect, Save works end very good speed 45 fps in interpreter 2

Ani
Administrator
*******


11
3,708 posts 96 threads Joined: Aug 2017
02-17-2017, 02:56 PM -
#5
Can you provided detailed information? By John GodGames' video we can indeed see this is Playable, but please post a log and settings used.
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
Aeternal600
Guest


 
03-15-2017, 05:53 PM -
#6
Re-tested using rpcs3-v0.0.2-2017-03-14-1b5a479b_win64 on an i7 4770K @ 3.5 GHz, GTX 1070, 16 GB DDR3 running Windows 10-64 with the following settings:

PPU decoder: Interpreter (fast)
SPU decoder: Recompiler (ASMJIT)
LLE libraries picked automatically by RPCS3
Graphics settings: OpenGL, DX12, Vulkan @ 1280x720 w/ VSync, Frame limit set to Auto
Audio settings: XAudio2
Input/Output: XInput

My results are similar to what Dante38490 posted above.

The audio, controls, saving & loading, etc. all work without issues.

As for the graphics, DX12 gives a runtime error right away: "·F 0:00:11.987377 {rsx::thread} class std::runtime_error thrown: Verification failed (e=0xb7):
(in file C:\rpcs3\rpcs3\Emu\RSX\D3D12\D3D12Buffer.cpp:274)".

OpenGL and Vulkan both boot. Speed isn't that great in some modes. In story mode, I get around 12-13 fps with both renderers. Battle mode ranges between 30-45 fps with OpenGL and 40-60 fps with Vulkan, depending on the stage. OpenGL shows some artifacts related to lighting; Vulkan is much better in this regard. See screenshots #1 vs #2 (battle mode) #3 vs #4 (story mode) as an example.

I've attached an archive containing logs for each of the three renderers.
Yagami Light9
Guest


 
05-22-2017, 10:43 PM -
#7


[Core]
PPU Decoder:
-Recompiler (LLVM)
SPU Decoder:
-Recompiler (ASMJIT)

-Bind SPU threads to secondary cores
-Lower SPU thread priority

[Library Loading Mode]
-Automatically Load required libraries

[Graphics]
Render:
-Vulkan

Resolution:
-1280x720

-Use GPU texture scaling

Aspect ratio:
-16:9
Frame limit:
-OFF

[Audio]
Audio Out:
-XAudio2
-Downmix to Stereo
Ani
Administrator
*******


11
3,708 posts 96 threads Joined: Aug 2017
05-25-2017, 12:38 AM -
#8
Missing log / commit version
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7
H3X
Guest


 
08-10-2017, 09:35 AM -
#9
I7-6700k @ 4.5GHZ(OC) | 8 Threads | 16 GB RAM | GTX 960
Above 60 FPS

[Image: qMv5Lk4.jpg]

[Core]
PPU Decoder:
-Recompiler (LLVM)
SPU Decoder:
-Recompiler (ASMJIT)

-Only Check Enable SPU loop detection

[Library Loading Mode]
-Automatically Load required libraries

[Graphics]
Render:
-Vulkan

Resolution:
-1280x720

-Nothing Checked

Aspect ratio:
-16:9
Frame limit:
-OFF

[Audio]
Audio Out:
-XAudio2
-Downmix to Stereo
EliasM108
Member


0
4 posts 0 threads Joined: Oct 2017
10-30-2017, 03:23 PM -
#10
heavy sound glitches and ingame lag...i would say its better to be moved to "INGAME"


Forum Jump:


Users browsing this thread: 2 Guest(s)