Hello There, Guest! Register

Splatterhouse [BLUS30335]
#31
It actually works with recompiler now, will make a detailed report later.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#32
No change on recompiler from what I see on today's build. Still get this:
F {PPU[0x1000000] Thread (main_thread) [0x0094e1cc]} MEM: Access violation reading location 0x11e
Reply
#33
Here

[Image: Splatterhouse_RPCS3.png]

Settings: LLVM recompiler and Vulkan, 3 SPU threads and Strict Rendering Mode
Build: rpcs3-v0.0.5-6603-3e863f21

Works okay, though I feel shader compilation is a bit slower than in other games.

Log attached.


Attached Files
.gz   RPCS3.log.gz (Size: 310.93 KB / Downloads: 15)
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#34
Is this playable? Audio is good? FPS is good outside of shader compilation? saving etc works? Not too many crashes?

If the answer is yes, please retest and add three ingame screenshots so we can move it to playable.
Reply
#35
I'll record a video when I can.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#36
Thanks baguettez  for the details, but I still can't get it. I've tried the exact settings you have, but still crashes on the gameplay loading screen with the MEM error. There's some delta here that I hope you can help figure out so we can all play this awesome beat 'em up. Wink


Here's just some of the settings I tried:
  • OpenGL/Vulkan
  • SPU Threads: Auto, 3
  • Enable/disable thread scheduler
  • auto/libv2 libs
  • SPU intepreter/recompiler
  • With/w/o Strict Rendering Mode
  • With/w/o DLC
  • Check for TUs (none)
  • Created a new save and started over again
  • Cleared shader/LLVM cache
I've run out of ideas!! Tongue

Works fine with PPU interpreter, but just super slow obviously.

HW:
Intel i6700k @4ghz.
Nvidia 1080
16 gigs ram
Reply
#37
I figured it out Tongue you need to pass the first part (try to reach the first checkpoint) in interpreter and then you can play with recompiler.

Keep in mind though, performance isn't perfect (when there's lots of blood and other effects on the screen), and it may crash or freeze randomly.
i7 4790k 4.4Ghz / Z97 Pro / 8Gb 1600Mhz / GTX 970 / Windows 10 x64
Reply
#38
Yeah, confirmed. Once you get past the first area you can switch to Recompiler. But, as you mentioned, the game is not yet stable. I was able to complete the next two areas before reaching a spot that ALWAYS freezes, even with Interpreter. 4/4 freezes there. Looks like I'm blocked. Darn, if the game was stable, it would be perfectly playable (minus the first area that requires Interpreter).
Reply
#39
Just wanted to update thread.

The game is more stable now, graphically fine, good audio with solid performance.

The only remaining issue is certain areas require PPU Interpreter to get around mem errors. You can just use Intepreter to get to next checkpoint in the level (~5 min) which has acceptable performance, quit, change to Recompiler and play until you hit it again (usually 1-2 spots per chapter).
Reply
#40
Finally getting 30 fps. Music is muted on purpose. Game crashes frequently, but finally getting consistent 30fps. Seems to not be able to get past the spot in this video either. But I haven't tried messing with settings too much yet. Tested default vulkan 4k.

RPCS3 v0.0.5-7456-dfacdd8a Alpha | HEAD
Intel® Core™ i7-8700K CPU @ 3.70GHz | 12 Threads | 15.89 GiB RAM | AVX+ | TSX



Attached Files
.7z   RPCS3.7z (Size: 306.25 KB / Downloads: 11)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)