BlackDaemonYu-Gi-Oh! Millennium Duels [NPUB31455]
Started by BlackDaemon




7 posts in this topic
BlackDaemon
Moderator
*****


0
844 posts 374 threads Joined: Aug 2017
08-16-2014, 06:39 AM -
#1
Shows white screen and some textures in RSX debugger.
BlackDaemon
Moderator
*****


0
844 posts 374 threads Joined: Aug 2017
01-30-2017, 07:00 AM -
#2
Tested on modded build v0.0.1-8-60bd2fb. Crashes after two intros. Requires a minor hack in sceNp2.cpp to skip unimplemented functions

replace
Code:
replace ->fmt::throw_exception("Unimplemented" HERE);
to
Code:
UNIMPLEMENTED_FUNC(sceNp2); return CELL_OK;

LLE used
Code:
- libadec.prx
- libat3dec.prx
- libatrac3plus.prx
- libatxdec.prx
- libl10n.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx
- libsync2.prx
- libgifdec.prx
- libjpgdec.prx
- libpngdec.prx
digitaldude
RPCS3 Tester


0
2,678 posts 524 threads Joined: Aug 2017
01-03-2018, 05:03 PM -
#3
rpcs3-v0.0.4-2018-01-02-ee009ec9_win64

Playable.


Attached Files Thumbnail(s)
   

.rar   RPCS3YuGiOhMillenium.rar (Size: 446.69 KB / Downloads: 35)
lamote
Member


0
20 posts 1 threads Joined: Nov 2017
03-02-2018, 09:30 PM -
#4
(01-03-2018, 05:03 PM)digitaldude Wrote: rpcs3-v0.0.4-2018-01-02-ee009ec9_win64

Playable.


what is your settings?
because is give me white screen

thanks for answer


digitaldude
RPCS3 Tester


0
2,678 posts 524 threads Joined: Aug 2017
03-02-2018, 09:44 PM -
#5
(03-02-2018, 09:30 PM)lamote Wrote:
(01-03-2018, 05:03 PM)digitaldude Wrote: rpcs3-v0.0.4-2018-01-02-ee009ec9_win64

Playable.


what is your settings?
because is give me white screen

thanks for answer



Download latest master and copy settings in image.


Attached Files Thumbnail(s)
       
lamote
Member


0
20 posts 1 threads Joined: Nov 2017
03-02-2018, 10:53 PM -
#6
(03-02-2018, 09:44 PM)digitaldude Wrote:
(03-02-2018, 09:30 PM)lamote Wrote: 18-01-02-ee009ec9_win64
Download latest master and copy settings in image.

i've tried with last build and delete before both cache
but nothing has been changed

this say in red
Code:
E {PPU[0x100000f] Thread (_libsail-control) [0x00cbfaa8]} '_sys_prx_get_module_id_by_name' failed with 0x8001112e : CELL_PRX_ERROR_UNKNOWN_MODULE [1]
E {PPU[0x100000f] Thread (_libsail-control) [0x00cc0548]} '_sys_prx_load_module' failed with 0x8001113b : CELL_PRX_ERROR_LIBRARY_FOUND [1]
E {PPU[0x100000e] Thread (Worker thread) [0x00070bec]} Stat: 'sys_mutex_lock' failed with 0x80010005 : CELL_ESRCH [x194]
E {PPU[0x100000e] Thread (Worker thread) [0x00070bec]} Stat: 'sys_cond_signal' failed with 0x80010005 : CELL_ESRCH [x194]
E {PPU[0x100000e] Thread (Worker thread) [0x00070bec]} Stat: 'sys_mutex_unlock' failed with 0x80010005 : CELL_ESRCH [x194]
Ani
Administrator
*******


8
3,094 posts 75 threads Joined: Aug 2017
03-02-2018, 10:59 PM -
#7
To avoid spam, read and follow support guidelines.
https://github.com/RPCS3/rpcs3/wiki/How-...or-Support
lamote
Member


0
20 posts 1 threads Joined: Nov 2017
03-02-2018, 11:14 PM -
#8
(03-02-2018, 09:44 PM)digitaldude Wrote: Download latest master and copy settings in image.


i've installed in a new folder emulator and now works

so when we update emulator to a new build

for update version in our computers

we have to install emulator again or just unpack and replace over old build?

thanks
This post was last modified: 03-02-2018, 11:17 PM by lamote.


Forum Jump:


Users browsing this thread: 1 Guest(s)