Hello There, Guest! Register

Hatsune Miku: Project DIVA F [BLUS31319]
#31
(02-25-2016, 08:10 PM)xXBeefyDjXx Wrote: Hello all!

I will upload logs later however I have downloaded and tried to run RPCS3 using the latest release over on AppVeyor (As of 20:00 25/2)

The game runs and will show the Sega/Crypton logos, Play (though distorted due to 30fps not 60) the miku "Sega" sound and then attempt to load the Cutscene before the title.

This crashes saying something about the Demuxer, and then crashes RPCS3, I will include logs later today when I have a chance Smile

Please don't make duplicate threads. Use the search functionality.
Also please read the submission guidelines.
Reply
#32
(02-25-2016, 08:18 PM)tambre Wrote:
(02-25-2016, 08:10 PM)xXBeefyDjXx Wrote: Hello all!

I will upload logs later however I have downloaded and tried to run RPCS3 using the latest release over on AppVeyor (As of 20:00 25/2)

The game runs and will show the Sega/Crypton logos, Play (though distorted due to 30fps not 60) the miku "Sega" sound and then attempt to load the Cutscene before the title.

This crashes saying something about the Demuxer, and then crashes RPCS3, I will include logs later today when I have a chance Smile

Please don't make duplicate threads. Use the search functionality.
Also please read the submission guidelines.

Searched and nothing came up, strangely...
Reply
#33
(02-25-2016, 08:26 PM)xXBeefyDjXx Wrote:
(02-25-2016, 08:18 PM)tambre Wrote:
(02-25-2016, 08:10 PM)xXBeefyDjXx Wrote: Hello all!

I will upload logs later however I have downloaded and tried to run RPCS3 using the latest release over on AppVeyor (As of 20:00 25/2)

The game runs and will show the Sega/Crypton logos, Play (though distorted due to 30fps not 60) the miku "Sega" sound and then attempt to load the Cutscene before the title.

This crashes saying something about the Demuxer, and then crashes RPCS3, I will include logs later today when I have a chance Smile

Please don't make duplicate threads. Use the search functionality.
Also please read the submission guidelines.

Searched and nothing came up, strangely...

Use google instead of the Search function of the forum.
"BLUS31319 emunewz" for instance.
That's what I always do, "GameID emunewz" (without the quotes).

For uploading logs into the forum, you need to zip them to .zip. Use windows' native zipping function or get 7-zip (I use the latter).
Reply
#34
Is there any progress on getting it to run?
What settings and LLE Modules should I set to get it to run?
Thanks if anybody can help!
Reply
#35
(03-15-2016, 02:15 PM)Bryceless Wrote: Is there any progress on getting it to run?
What settings and LLE Modules should I set to get it to run?
Thanks if anybody can help!

All up to the testers. At this point you basically throw basics sets of LLE at a game, try some different settings and hope that it doesn't crash immediately.
Reply
#36
game still hangs at opening movie with dmux error, if you move\rename adv.pam in USRDIR\rom\movie , then it goes to before menu "Press Start Button", but game is stuck there (fps indicator is still, music is playing, but stuff aren't moving.)

[Image: 4txwHOq.png]

log if movie file is present: http://pastebin.com/fAsLX9Gr

Code:
·F {PPU Thread[0x1ee] (Demuxer[0x1ed] Thread)[0x00000000]} Exception: dmuxEnableEs: unknown filter (0xe0, 0x0, 0x0, 0x0)
(in file C:\rpcs3\rpcs3\Emu\SysCalls\Modules\cellDmux.cpp:681, in function dmuxOpen::<lambda_196d71cde4562b60432812cfb1be3340>::operator ())

log if movie file is removed: http://pastebin.com/xXf0bVw3



EDIT: btw demo works fine with graphics too, gonna make a video. (demo doesn't have any videos)

edit2: gameplay from the DEMO


Reply
#37
@tambre

the 1 demo miss backround in opengl. how so often dx12 shows backround xd

ok a proplem in all miku demos f2 the same .

whould someone test vulkan? would be interesting too see if ther is backround or not.
Reply
#38
With Vulkan, the demo doesn't boot. (i have a nvidia gtx 970.)

FragmentProgram.frag: http://pastebin.com/UKXRBaep
VertexProgram.vert: http://pastebin.com/89HQkCAz
Log: http://pastebin.com/fGZsdT8i

Code:
·E {rsx::thread} RSX: Warning, version 420 is not yet complete; most version-specific features are present, but some are missing.
ERROR: 0:79: 'textureLod' : no matching overloaded function found
ERROR: 0:79: 'w' : vector field selection out of range
ERROR: 0:81: 'textureLod' : no matching overloaded function found
ERROR: 0:81: 'w' : vector field selection out of range
ERROR: 0:83: 'textureLod' : no matching overloaded function found
ERROR: 0:83: 'w' : vector field selection out of range
ERROR: 0:86: 'textureLod' : no matching overloaded function found
ERROR: 0:86: 'w' : vector field selection out of range
ERROR: 0:103: 'textureLod' : no matching overloaded function found
ERROR: 0:103: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:109: 'textureLod' : no matching overloaded function found
ERROR: 0:109: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:110: 'textureLod' : no matching overloaded function found
ERROR: 0:110: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:112: 'textureLod' : no matching overloaded function found
ERROR: 0:112: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:116: 'textureLod' : no matching overloaded function found
ERROR: 0:116: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 18 compilation errors.  No code generated.

After stopping emulator, it crashes.

Code:
·! Stopping emulator...
·! All threads signaled...
·S {PPU Thread[0x100] (200baad0)[0x0066f5f0]} HLE: Last syscall: 107 (sys_cond_wait)
·! {PPU Thread[0x2] (Callback Thread)[0x00000000]} Thread aborted
·! {PPU Thread[0x100] (200baad0)[0x0066f5f0]} Thread aborted
·! {SPU[0x11b] Thread (_synth2 Thread)[0x00d00]} Thread aborted
·S {PPU Thread[0x113] (_sys_mixerSurBusReq)[0x006a3708]} HLE: Last syscall: 107 (sys_cond_wait)
·S {PPU Thread[0x10b] (_sys_MixerChStripMain)[0x006aae48]} HLE: Last syscall: 107 (sys_cond_wait)
·! {PPU Thread[0x113] (_sys_mixerSurBusReq)[0x006a3708]} Thread aborted
·! {PPU Thread[0x10b] (_sys_MixerChStripMain)[0x006aae48]} Thread aborted
·S {PPU Thread[0x116] (_cellsurMixerMain)[0x006af304]} HLE: Last syscall: 130 (sys_event_queue_receive)
·! {PPU Thread[0x116] (_cellsurMixerMain)[0x006af304]} Thread aborted
·F {rsx::thread} Exception: Failed to compile fragment shader
(in file C:\rpcs3\rpcs3\Emu\RSX\VK\VKFragmentProgram.cpp:280, in function VKFragmentProgram::Compile)
·! {PPU Thread[0x1] (main_thread)[0x00583900]} Thread aborted
·! All threads stopped...
·! Objects cleared...
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
Reply
#39
(03-17-2016, 04:25 PM)Nezarn Wrote: With Vulkan, the demo doesn't boot. (i have a nvidia gtx 970.)

FragmentProgram.frag: http://pastebin.com/UKXRBaep
VertexProgram.vert: http://pastebin.com/89HQkCAz
Log: http://pastebin.com/fGZsdT8i

Code:
·E {rsx::thread} RSX: Warning, version 420 is not yet complete; most version-specific features are present, but some are missing.
ERROR: 0:79: 'textureLod' : no matching overloaded function found
ERROR: 0:79: 'w' : vector field selection out of range
ERROR: 0:81: 'textureLod' : no matching overloaded function found
ERROR: 0:81: 'w' : vector field selection out of range
ERROR: 0:83: 'textureLod' : no matching overloaded function found
ERROR: 0:83: 'w' : vector field selection out of range
ERROR: 0:86: 'textureLod' : no matching overloaded function found
ERROR: 0:86: 'w' : vector field selection out of range
ERROR: 0:103: 'textureLod' : no matching overloaded function found
ERROR: 0:103: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:109: 'textureLod' : no matching overloaded function found
ERROR: 0:109: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:110: 'textureLod' : no matching overloaded function found
ERROR: 0:110: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:112: 'textureLod' : no matching overloaded function found
ERROR: 0:112: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 0:116: 'textureLod' : no matching overloaded function found
ERROR: 0:116: 'assign' :  cannot convert from 'const float' to 'temp 4-component vector of float'
ERROR: 18 compilation errors.  No code generated.

After stopping emulator, it crashes.

Code:
·! Stopping emulator...
·! All threads signaled...
·S {PPU Thread[0x100] (200baad0)[0x0066f5f0]} HLE: Last syscall: 107 (sys_cond_wait)
·! {PPU Thread[0x2] (Callback Thread)[0x00000000]} Thread aborted
·! {PPU Thread[0x100] (200baad0)[0x0066f5f0]} Thread aborted
·! {SPU[0x11b] Thread (_synth2 Thread)[0x00d00]} Thread aborted
·S {PPU Thread[0x113] (_sys_mixerSurBusReq)[0x006a3708]} HLE: Last syscall: 107 (sys_cond_wait)
·S {PPU Thread[0x10b] (_sys_MixerChStripMain)[0x006aae48]} HLE: Last syscall: 107 (sys_cond_wait)
·! {PPU Thread[0x113] (_sys_mixerSurBusReq)[0x006a3708]} Thread aborted
·! {PPU Thread[0x10b] (_sys_MixerChStripMain)[0x006aae48]} Thread aborted
·S {PPU Thread[0x116] (_cellsurMixerMain)[0x006af304]} HLE: Last syscall: 130 (sys_event_queue_receive)
·! {PPU Thread[0x116] (_cellsurMixerMain)[0x006af304]} Thread aborted
·F {rsx::thread} Exception: Failed to compile fragment shader
(in file C:\rpcs3\rpcs3\Emu\RSX\VK\VKFragmentProgram.cpp:280, in function VKFragmentProgram::Compile)
·! {PPU Thread[0x1] (main_thread)[0x00583900]} Thread aborted
·! All threads stopped...
·! Objects cleared...
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!
·E RSX: Program destructor invoked!

I can already see the problem. Thanks for sharing the shader files, it's usually a big help. Will submit a fix ASAP
Reply
#40
There are some issues with Vulkan (idk if this demo only or it affects other games too)

In 720x480, game only has black screen
Log: https://gist.github.com/Nezarn/628a9440438d9645067d
FragmentProgram.frag: http://pastebin.com/Eb5AvG1h
VertexProgram.vert: http://pastebin.com/xLxwYWaS

In 1280x720, only a bit of the screen can be seen
Log: https://gist.github.com/Nezarn/d30c1ca6685b79e976a2
FragmentProgram.frag: http://pastebin.com/5igSxM8R
FragmentProgram.txt: http://pastebin.com/thWAFdmM
VertexProgram.vert: http://pastebin.com/zwSRkMHr
VertexProgram.txt: http://pastebin.com/tdNeqMGT
[Image: UUMh1jZ.png]

In 1920x1080, the screen isn't centered.
Log: https://gist.github.com/Nezarn/4ba925730c05c4770421
FragmentProgram.frag: http://pastebin.com/ZjgkFzWM
VertexProgram.vert: http://pastebin.com/bB2Yibku
[Image: W0Ek52l.png]

In all three logs this is getting spammed:
Code:
·E {rsx::thread} RSX: Texel buffer was not bound: in_tc1_buffer
·E {rsx::thread} RSX: Texel buffer was not bound: in_tc2_buffer
·E {rsx::thread} RSX: Texel buffer was not bound: in_tc3_buffer
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)