Hello There, Guest! Register

Assault Heroes [NPUB30028]
#1
The game goes to load with black GSFrame and vary between 16-30 frames.

[Image: JsejlzT.png]

[Image: xgoFXwn.png]


Log file:
http://pastebin.com/46Gh211U
Reply
#2
infinite loop:
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)

Code:
[E : RSXThread]: TODO: cellGcmSetBackPolygonMode(0x1b02)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetBackPolygonMode(0x1b02)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[E : RSXThread]: TODO: cellGcmSetVertexDataBaseOffset(0x0, 0x0)
[W : PPU[68] Thread (RenderPTask)[0x002719a0]]: sys_mutex warning: sys_mutex_lock(id=46) aborted
[! : RSXThread]: RSX thread exit...
[!]: Mutex(47) was owned by thread 68 (recursive=1)
[!]: Mutex(46) was owned by thread 1 (recursive=1)
[!]: Closing memory...
Reply
#3
* rpcs3 revision 75e81bc *

Now no more infinite loop.; the game no longer crashes after booting;
In "RSX Debugger" generated some texture, but at the moment visible with a black screen.

Some significant changes in the new log file.
Code:
...
HLE: E {PPU[1] Thread (CPUThread)[0x00bc801c]} sys_fs error: "" not found! flags: 0x00000000
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40000000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40001000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40002000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40003000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40004000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40005000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40006000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40007000)
MEM: E {PPU[1] Thread (CPUThread)[0x005dfc0c]} Page already registered (addr=0x40008000)
...


log updated
http://pastebin.com/wK7zhVPm

Reply
#4
Another two or three corrupted images in RSX debugger, game is promising, but it is looped again or i dont know what to press to go past menu.

New log:
Reply
#5
(12-14-2014, 11:28 AM)ps0ne Wrote: Another two or three corrupted images in RSX debugger, game is promising, but it is looped again or i dont know what to press to go past menu.

New log:

The game uses "DRAW_INLINE_ARRAY" so no hopes for it to run anytime soon.
Reply
#6
Shows intros on recent master build. One of SPURS threads crashes during loading. Requires libSre and JpgDec LLE'd.
Reply
#7
Goes ingame on recent master build v0.0.1-1669d0fd (PR #2352).

LLE used
Code:
- libac3dec.prx
    - libac3dec2.prx
    - libadec.prx
    - libapostsrc_mini.prx
    - libat3dec.prx
    - libatrac3plus.prx
    - libatxdec.prx
    - libaudio.prx
    - libdmux.prx
    - libdmuxpamf.prx
    - libgifdec.prx
    - libjpgdec.prx
    - libl10n.prx
    - libpamf.prx
    - libpngdec.prx
    - libresc.prx
    - librtc.prx
    - libsail.prx
    - libsail_avi.prx
    - libsail_rec.prx
    - libsjvtd.prx
    - libsmvd2.prx
    - libsmvd4.prx
    - libspurs_jq.prx
    - libsre.prx
Reply
#8
It's playable now at 60fps, the only issue is the terrain doesnt look exactly right but doesn't stop gaming from being playable.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)