Hello There, Guest! Register

Sonic CD [NPUB30624]
#71
It should be fully working again now in latest build.
Reply
#72
(11-15-2014, 03:57 PM)jacky400 Wrote: It should be fully working again now in latest build.
Arf last build not works now, error is returnd, but works after press resume ^^

Quote:E {PPU[242] Thread (AUTOSAVE)[0x300090a0]} Exception: Access violation: addr = 0xf00f30 (is_alive=1, last_syscall=0x8b7ed64b (cellSaveDataAutoSave2))
Reply
#73
The recompiler seems to enable Blast Processing Tongue Look at that frame rate. Music is also working now (kind of, sounds like it's way too fast), did it before? Seems like it would be playable now. I guess only save/load is missing. (New game creates a save -> crash)




Reply
#74
(12-19-2014, 02:13 PM)ssshadow Wrote: The recompiler seems to enable Blast Processing Tongue Look at that frame rate. Music is also working now (kind of, sounds like it's way too fast), did it before? Seems like it would be playable now. I guess only save/load is missing. (New game creates a save -> crash)

Woah, what revision is that?
Reply
#75
(12-19-2014, 03:04 PM)tambre Wrote:
(12-19-2014, 02:13 PM)ssshadow Wrote: The recompiler seems to enable Blast Processing Tongue Look at that frame rate. Music is also working now (kind of, sounds like it's way too fast), did it before? Seems like it would be playable now. I guess only save/load is missing. (New game creates a save -> crash)

Woah, what revision is that?

Think it was this one, just quickly downloaded some new-ish revision with the recompiler to test.

But yeah, frame rate is between 150-300 when you leave it at the main menu and let the computer play different random levels. And this is with a Sandy Bridge quad i7 at 2-3 ghz or whatever the turbo was. A desktop Haswell i7 at 4+ ghz might get double the frame rate, that is 600 fps : o

Edit: Left it running for a while and got 380 fps momentarily. For the record it's about 3 fps on the interpreter...

Reply
#76
(12-19-2014, 04:27 PM)ssshadow Wrote: Think it was this one, just quickly downloaded some new-ish revision with the recompiler to test.

But yeah, frame rate is between 150-300 when you leave it at the main menu and let the computer play different random levels. And this is with a Sandy Bridge quad i7 at 2-3 ghz or whatever the turbo was. A desktop Haswell i7 at 4+ ghz might get double the frame rate, that is 600 fps : o

Edit: Left it running for a while and got 380 fps momentarily. For the record it's about 3 fps on the interpreter...

Chili dogs! That's some sonic speed we got here Big GrinTongue
Reply
#77
(12-19-2014, 04:27 PM)ssshadow Wrote:
(12-19-2014, 03:04 PM)tambre Wrote:
(12-19-2014, 02:13 PM)ssshadow Wrote: The recompiler seems to enable Blast Processing Tongue Look at that frame rate. Music is also working now (kind of, sounds like it's way too fast), did it before? Seems like it would be playable now. I guess only save/load is missing. (New game creates a save -> crash)

Woah, what revision is that?

Think it was this one, just quickly downloaded some new-ish revision with the recompiler to test.

But yeah, frame rate is between 150-300 when you leave it at the main menu and let the computer play different random levels. And this is with a Sandy Bridge quad i7 at 2-3 ghz or whatever the turbo was. A desktop Haswell i7 at 4+ ghz might get double the frame rate, that is 600 fps : o

Edit: Left it running for a while and got 380 fps momentarily. For the record it's about 3 fps on the interpreter...

On Dual Core Pentium i get max 80 fps.Begin on 20-30 fps.
Reply
#78
Wow, 450 fps in menu and in-game 280 fps.
Reply
#79
(12-19-2014, 02:13 PM)ssshadow Wrote: The recompiler seems to enable Blast Processing Tongue Look at that frame rate. Music is also working now (kind of, sounds like it's way too fast), did it before? Seems like it would be playable now. I guess only save/load is missing. (New game creates a save -> crash)

Actually no, it's not related to saving at all: it's due to cellSail not being implemented.

I hacked up a very (well, hacky) implementation. It's actually opening its OPENING.pamf movie and then trying to inspect the stream. Even though it should now have a valid PAMF handle, it's still not playing that movie though. It goes in-game, but probably due to the save functions, it is in a perpetual saving state (see screenshot below.)

I'm not going to add a hack just for this and I am not really the person to be implementing this stuff, probably. @tambre?
Reply
#80
(12-20-2014, 09:28 AM)leon112211 Wrote:
(12-20-2014, 06:51 AM)Darkriot Wrote: Wow, 450 fps in menu and in-game 280 fps.

Can you upload the recomplier please thx

aam, it is in this thread: http://www.emunewz.net/forum/showthread....mp;page=26 (with spurs_taskset).
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)