Hello There, Guest! Register

Disgaea D2 [BLES01939]
#61
i7-6700K @ 4 Ghz with 64 GB RAM  (the RAM doesn't seem relevant , RSPC3s RAM use is tiny while playing Disgaea D2) 
GeForce 980Ms  8GB
Windows 10 Pro

1.40 with all DLC seems to work about as well as 1.30 once you update the speed patch as per ( https://github.com/RPCS3/rpcs3/issues/4022 )

Default settings for the most part but enable VSync and Strict Rendering.  I recommend limiting the Frame Rate to 60 (nothing breaks but the graphics look like they are in fast forward when it gets much above that).  

Vulkan - Some minor graphical issues, the most obvious being the layering issue on the start menu. Without Speed Patch the larger / more occupied rooms of the castle drop to 30-40 FPS (you can tell but still very playable).  With Speed Patch occupied Castle FPS mostly hovers around 60 FPS sometimes dropping to 55 (feels a little snappier than the PS3 did in practice). 
  
OpenGL - No Graphics issues I saw in a quick look. Without Sped Patch the larger/more occuried rooms of the castle range from 27-37 FPS (there's a noticeable slugglishness) . With Speed Patch. With Speed Patch 41-47 FPS in the same areas. 

It should be noted that even on the PS3 there's some sluggish in Disgaea 3/4/D2 in very occupied "home" areas. 

Site note: Default resolution for the above but 1080p doesn't seem to make any difference that I can ascertain, so go for it.
Reply
#62
Sorry for reviving, but I'm having problems.

My specs are i5-4460 @ 3.20 GHz, Radeon R9 290 4gb, 8gb RAM

I've tried the latest version of RPCS3 v0.0.5-7161-69af60749 Alpha | HEAD (also I've got the speed patch) installed and I get constant 60 fps in the castle and when moving around, but when the pointer is hovering over the base plate and in the opening cutscene where Laharl and Etna ride the 'stars' into the garden, the FPS drops to 10 and freezes for a few seconds. Also when I want to look at the movement where monsters can go and I try to move my characters it drops to 20fps and it's constantly stuttering (along with the audio).

I've also tried v0.0.5-6639-90e0bade_win64 and it's reversed, in the castle I have 40-ish fps while the cutscene with the stars and when hovering over the base plate there's no problems.

Mind you I haven't tried any actual moves in battles.

I've attached the logs from v7161.


Attached Files
.gz   RPCS3.log.gz (Size: 123.88 KB / Downloads: 1)
Reply
#63
i7-6700K @ 4 Ghz with 64 GB RAM (the RAM doesn't seem relevant , RSPC3s RAM use is tiny while playing Disgaea D2)
GeForce 980Ms 8GB
Windows 10 Pro
rpcs3-v0.0.7-8623-432364cb_win64

A quick update to current stage:
Vulkan - The graphical issue seem mostly fixed. Would definitely recommend using it over OpenGL now. Speed is generally high (40-60 without speedpatch, mostly on the higher side). The speed patch actually gets a pretty solid 59-60 FPS now. If you're on 1.40 you still need the speedpatch.yaml addition from https://github.com/RPCS3/rpcs3/issues/4022 . There's some tiny flickering on the cursor on the battle screen when there's overlap. You do need to put in a frame limit now (otherwise the scrolling on the main menu is so fast you can't select the option to Load Games.)

I can't duplicate the problems from the previous post, so I assume they are fixed now.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)