Portal 2 [BLUS30732]
Started by Darkriot




32 posts in this topic
Darkriot
Member


0
498 posts 29 threads Joined: Aug 2017
09-09-2014, 01:35 PM -
#11
Hello again Smile

AlexAltea, can u implement it?

Quote:HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa4260)
HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa427c)
HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa4298)
and
HLE: E {PPU[1] Thread (CPUThread)[0x00100028]} sys_prx TODO: sys_prx_load_module(path="/dev_bdvd/PS3_GAME/USRDIR/bin/tier0_ps3.sprx", flags=0x0, pOpt=0x0)

like nothing more suspicious is not present, because of what the game could not be loaded. (sorry for englishConfused)

Full log: http://pastebin.com/9Ym9vS1J
Darkriot
Member


0
498 posts 29 threads Joined: Aug 2017
09-09-2014, 02:32 PM -
#12
(09-09-2014, 02:14 PM)AlexAltea Wrote: I wanted to do this last month (and other stuff like BD decryption and the new website), but some real-life issues have spoiled my plans so I don't have time to work on this on my own. All I can do for now is explaining to other people how to these syscalls work and giving advices about how to implement.

Ooh, no problem. I hope, you will be able to solve your problems in the near future.
See you later Smile
GrantKane
RPCS3 Tester


0
2,667 posts 1,776 threads Joined: Aug 2017
03-14-2017, 12:09 AM -
#13
RPCS3 v0.0.2-3-1c8cb3b Alpha
Infinite loading.
shoopdahoop22
Guest


 
03-14-2017, 06:25 PM -
#14
Does anybody know what causes the game to show the yellow triangle instead of actually booting?
Ani
Administrator
*******


10
3,286 posts 94 threads Joined: Aug 2017
03-14-2017, 07:07 PM -
#15
Probably runs some firmware checks and realizes stuff is broken internally so it shuts down with a warning.
Darkriot
Member


0
498 posts 29 threads Joined: Aug 2017
03-16-2017, 03:31 PM -
#16
(03-14-2017, 06:25 PM)shoopdahoop22 Wrote: Does anybody know what causes the game to show the yellow triangle instead of actually booting?

because loading .sprx files still aren't implemented, i think.

Quote:HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa4260)
HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa427c)
HLE: E {PPU[1] Thread (CPUThread)[0x00100058]} sys_prx TODO: sys_prx_register_library(lib_addr=0xa4298)
and
HLE: E {PPU[1] Thread (CPUThread)[0x00100028]} sys_prx TODO: sys_prx_load_module(path="/dev_bdvd/PS3_GAME/USRDIR/bin/tier0_ps3.sprx", flags=0x0, pOpt=0x0)
shoopdahoop22
Guest


 
06-26-2017, 06:39 PM -
#17
With recent builds, Portal 2 now properly boots. Loading libsysmodule.sprx is required to get around the yellow triangle. However, it seems like libnet is needed to progress further:
E {PPU[0x1000008] Thread (CIPCServer::m_ThreadClient) [0x00102388]} libnet: Unknown/illegal socket error: 10049
(in file C:\rpcs3\rpcs3\Emu\Cell\Modules\sys_net.cpp:207)
E {PPU[0x1000008] Thread (CIPCServer::m_ThreadClient) [0x00102388]} libnet: connect(): error 6304




The log is too large to upload to the forums, so I uploaded it here instead:
https://drive.google.com/file/d/0BwnEMwJ...sp=sharing

Uncompressed, it's 55 megabytes in size!
Darkriot
Member


0
498 posts 29 threads Joined: Aug 2017
06-26-2017, 10:31 PM -
#18
wow! I'm gonna try this too Wink

Keep it up!
Darkriot
Member


0
498 posts 29 threads Joined: Aug 2017
07-07-2017, 07:42 PM -
#19
in that lle-gcm build, if you will also load "libnet" lle module then you can see the menu. (controls don't working...idk what's goin on, because of green rectagle)
Jusic
Guest


 
07-09-2017, 09:07 AM -
#20
(07-07-2017, 07:42 PM)Darkriot Wrote: in that lle-gcm build, if you will also load "libnet" lle module then you can see the menu. (controls don't working...idk what's goin on, because of green rectagle)

Upload log files please


Forum Jump:


Users browsing this thread: 2 Guest(s)